症状

查看运行 Microsoft Dynamics AX 4.0 应用程序对象服务器(AOS)服务的计算机上的应用程序日志时,可能会看到类似于以下内容的错误消息:

错误消息 1

事件类型: InformationEvent 源: Dynamics Server 17Date: 7/4/2007Time:12:30: 14 PMEvent 类别: NoneDescription:对象服务器01: RPC 错误:会话10中出现 RPC 异常1726

错误消息 2

事件类型: InformationEvent 源: Dynamics Server 01Event 类别: NoneEvent ID:110Date: 7/4/2007Time:12:30: 33 AMUser: N/AComputer:ComputerName说明:对象服务器01:没有来自10的 ping。 终止会话。

第一条错误消息可能与第二条错误消息相关联。 在 AOS 服务器结束会话10之前,返回 RPC 错误消息的每个会话将停止响应。 如果过多的会话停止响应并返回 RPC 错误消息,则 AOS 服务器可能会关闭。

原因

出现此问题的原因可能是用户退出了 Microsoft Dynamics AX ungracefully。 例如,用户使用任务管理器结束 Microsoft Dynamics AX 进程。 RPC 1726 是常规连接错误消息。 但是,RPC 1726 错误消息可能与 "没有来自10的 ping" 关联。 将终止会话 "错误消息。 在这种情况下,问题通常由退出 Microsoft Dynamics AX ungracefully 的用户导致。

解决方案

如果你在 Microsoft Dynamics AX 客户端上遇到此问题,请不要通过按 CTRL + ALT + DEL 退出客户端。 我们建议您使用 CTRL + Break,然后等待系统再次响应,或者联系 Microsoft Dynamics AX 管理员或对 "联机用户" 窗体具有权限的其他用户。 管理员或其他用户可以单击 " 结束会话 " 以关闭客户端会话。

更多信息

如果你在 AOS 服务器上遇到此问题,请务必确定原因是哪个会话以及用户执行了哪些操作来导致该问题。 若要执行此操作,请运行以下脚本:

select * from sysuserlog where logouttime = 0 and sessionid = <X> 

注意 将 <X> 替换为 RPC 错误消息中所示的会话。 在查询结果中,记下 " 用户 id " 和 " COMPUTERNAME " 列。 列值指示谁正在登录以及从何处进行登录。 通常,RPC 异常是由 ungracefully 退出应用程序导致的。 但是,例外情况也可能表示业务流程挂起或花费了很长时间。

参考

有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

953375 如何查找与 Microsoft Dynamics AX 中的 AOS 服务器上的应用程序日志中的 "RPC 错误:会话 ID 1726 出现 RPC 异常" 错误消息相关联的用户 ID

953374 将在 Microsoft Dynamics AX: "SPID [SPID_number] 中的 AOS 服务器上的应用程序日志中收到一条警告消息,表示会话 Id [SessionID] 的" SPID [] "仍存在于数据库中。 请删除数据库中的 SPID "

需要更多帮助?

扩展你的技能
了解培训
抢先获得新功能
加入 Microsoft 内部人员

此信息是否有帮助?

你对翻译质量的满意程度如何?

哪些因素影响了你的体验?

是否还有其他反馈?(可选)

谢谢您的反馈意见!

×