如何解决同步问题时与您在 Outlook 中的.ost 文件同步 Exchange Server 邮箱

概要

本文介绍如何解决 Microsoft Exchange Server 邮箱同步脱机文件夹 (.ost) 文件或 Microsoft Office Outlook 2007 Microsoft Office Outlook 2003年中使用时可能会遇到的问题。

简介

以下信息描述如何使用.ost 文件同步 Exchange Server 邮箱时可能会遇到的问题进行疑难解答。

确定是否要同步脱机文件夹

要确定是否正确地同步脱机文件夹,请执行以下步骤:

  1. 右键单击您想要验证,该文件夹,然后单击属性

  2. 单击同步选项卡。如果看不到同步选项卡,您没有将设置您的配置文件来使用脱机文件夹。

  3. 在下,此文件夹的统计信息,请验证以下字段中的设置:

    上次同步处理的日期日期

    服务器文件夹包含:# 项目

    脱机文件夹包含:# 项目

如果同步正常的在服务器文件夹包含字段和脱机文件夹包含字段中的项目数是相同的。如果同步工作不正常,或者如果服务器文件夹和脱机文件夹之间同步无法正常工作,您必须验证配置文件设置。若要执行此操作,请按照以下步骤,根据您所运行的 Outlook 的版本。

Outlook 2003

  1. 工具菜单上,单击电子邮件帐户

  2. 电子邮件帐户对话框中,请确保在电子邮件部分中,选择查看或更改现有电子邮件帐户选项,然后单击下一步

  3. 将新邮件传递到以下位置列表中,请确保已选定邮箱的帐户名称

  4. 单击Microsoft Exchange Server对象,然后单击更改

  5. 确认使用缓存 Exchange 模式选项已选中,然后单击下一步

  6. 单击完成,然后单击确定

  7. 退出 Outlook,然后重新打开 Outlook

Outlook 2007

  1. 工具菜单上,单击帐户设置

  2. 单击数据文件选项卡,然后确保邮箱的帐户名称被设置为默认值。

  3. 单击电子邮件选项卡。

  4. 单击邮箱-用户名,然后单击设置

  5. 单击高级选项卡中,验证使用缓存 Exchange 模式选项被选中,然后单击确定

  6. 帐户设置对话框中,单击关闭

  7. 退出 Outlook,然后重新打开 Outlook

Outlook 2010

  1. 文件菜单上,单击列表中的帐户设置,并选择帐户设置

  2. 单击数据文件选项卡,然后确保邮箱的帐户名称被设置为默认值。

  3. 单击电子邮件选项卡。

  4. 单击邮箱-用户名,然后单击更改

  5. 验证使用缓存 Exchange 模式选项已选中,然后单击确定

  6. 帐户设置对话框中,单击关闭

  7. 退出 Outlook,然后重新打开 Outlook

重新同步处理文件夹

检查这些设置后,使用以下方法之一来重新同步处理文件夹。

手动同步

  1. 在文件夹列表窗格中,单击您想要同步的文件夹。
    如果看不到文件夹列表窗格,请在转到菜单上单击文件夹列表

  2. 工具菜单上,指向发送/接收,然后单击此文件夹 (Microsoft Exchange Server)同步脱机文件夹,或单击全部发送/接收以同步处理所有脱机文件夹。

在 Outlook 2010 中发送/接收,请单击,然后单击全部发送/接收来同步处理所有脱机文件夹。


当同步过程开始时,您将看到一条同步状态消息在屏幕的右下角部分。如果您的邮箱中有许多项目,一段时间还没有同步脱机文件夹同步过程可能需要 30 多分钟。

自动同步

每次您处于联机状态,并且每次退出 Outlook 时自动同步所有脱机文件夹,请执行以下步骤:

  1. 工具菜单上,单击选项

  2. 单击邮件设置选项卡。

  3. 发送/接收部分中,单击以选中连接后立即发送复选框。

  4. 单击发送/接收

  5. 发送/接收组对话框中,请确保选中退出时执行自动发送/接收当退出选项,然后单击关闭

  6. 单击确定

创建一个新.ost 文件并再次同步脱机文件夹

如果除收件箱文件夹的所有文件夹进行都同步,或者如果不能同步处理文件夹,您可能有损坏的.ost 文件。要解决此问题,请创建一个新.ost 文件,然后再次同步文件夹。

如何创建一个新.ost 文件并同步处理文件夹

若要创建一个新.ost 文件,重命名旧的.ost 文件中,然后将新的.ost 文件同步运行 Microsoft Exchange Server 的计算机。重命名旧的.ost 文件时,Outlook 将创建一个新文件。若要执行此操作,请执行以下步骤:

  1. 退出所有程序。

  2. 单击开始,指向搜索,然后单击文件或文件夹

  3. 在搜索对话框中,单击所有文件和文件夹

  4. 全部或部分文件名选项卡中,键入*.ost 。

  5. 不要键入任何内容的单词或短语在该文件中。

  6. 单击查找范围列表中的硬盘。更多高级的选项在选项下,单击以选中包括子文件夹复选框,然后,然后单击搜索

    名称列中,可以看到该.ost 文件。.Ost 文件的默认位置如下所示。

    对于 Microsoft Windows 2000、 Microsoft Windows NT、 Windows XP 和 Windows Server 2003

    C:\Documents 和 Settings\user name\Local Settings\Application Data\Microsoft\Outlook

  7. .Ost 文件,用鼠标右键单击,然后单击
    重命名。通过使用不同的文件扩展名,例如,代替.ost 文件扩展名.old 文件扩展名重命名该文件。

  8. 文件菜单上,单击关闭

  9. 启动 Outlook,指向工具菜单上的发送/接收,然后单击全部发送/接收

查看同步状态的新屏幕的右下角部分中,您现在有一个新的.ost 文件。

.Ost 文件是存储在 Exchange Server 邮箱中的信息复制,因为此过程不会损坏任何信息。

替换已损坏的 Exchange Server 支持文件

如果您仍不能恢复同步,Microsoft Exchange Server 服务支持文件可能已损坏。若要替换已损坏的 Exchange Server 支持文件,必须首先删除 Exchange Server 服务支持文件和 originalOutlook 文件替换已删除的文件。

若要我们为您删除 Exchange Server 服务支持文件,请转到"下面是简单的解决方法"部分。如果您想自行删除 Exchange Server 服务支持文件,请转到"让我自己修复此问题"一节。

这是简单的解决方法

若要自动修复此问题,请单击下载按钮。在文件下载对话框中,单击运行打开,然后按照很容易修复向导中的步骤。

  • 此向导可能只提供英文版本。但是,自动修复也适用于其他语言版本的 Windows。

  • 如果你不出现在此问题的计算机上,将很容易修复解决方案保存至闪存驱动器或 CD 中,然后在出现此问题的计算机上运行。

我自己修复此问题

Easy fix 50670

如何删除 Outlook 2003 的 Microsoft Exchange Server 服务支持文件

若要执行此操作,请执行以下步骤:

  1. 单击开始指向
    程序,然后单击Windows 资源管理器

  2. 使用.old 文件扩展名重命名以下文件:

    • Emsabp32.dll

    • Emsmdb32.dll

    • Emsui32.dll

    备注:

    • 若要重命名该文件,用鼠标右键单击该文件,然后单击重命名

    • 此文件的默认位置如下所示:

      C:\Program Files\Common Files\System\MSMAPI\1033

如何删除 Outlook 2007 Microsoft Exchange Server 服务支持文件

若要执行此操作,请执行以下步骤:

  1. 单击开始,指向程序,再单击Windows 资源管理器

  2. 使用.old 文件扩展名重命名以下文件:

    Emsmdb32.dll 备注:

    • 若要重命名该文件,用鼠标右键单击该文件,然后单击重命名

    • 此文件的默认位置如下所示:

      C:\Program Files\Microsoft Office\OFFICE12

如何更换 Exchange Server 服务支持文件


 若要替换您重命名原始媒体的支持文件,请按照下列步骤操作:

  1. 单击开始,单击运行,键入控件,然后单击确定

  2. 双击添加/删除程序

  3. Microsoft Office,请单击,然后单击更改

  4. 单击重新安装或修复,然后单击重新安装 Office

详细信息

有关脱机文件夹和同步过程的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

远程邮件、 脱机文件夹和脱机工作

需要更多帮助?

扩展你的技能
了解培训
抢先获得新功能
加入 Microsoft 内部人员

此信息是否有帮助?

谢谢您的反馈意见!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×