症状

尝试导入 Dynamics 365 中的解决方案修补程序时,遇到以下错误:

"导入解决方案: [解决方案修补程序名称] 失败。 错误代码80048539。 "

如果你下载日志文件并在 Excel 中将其打开,你将看到其他详细信息,如以下内容:

症状1的详细信息:

"失败0x80048539 解决方案清单导入:失败:修补程序版本1.0.1.0 对于父版本 1.1.0.0 "无效"

症状2详细信息:

"失败0x80048539 解决方案清单导入:失败:保留解决方案 MyPatchTesting_Upgrade 已存在。 "

原因

提示

如果您使用 make.powerapps.com 导入非托管解决方案更新并收到此错误,则 Microsoft 意识到该问题,并且正在处理修补程序。 若要解决此问题,请打开 "高级设置",然后选择 "更新(不推荐)" 选项。

错误代码80048539表示导入的修补程序无效。 有几种可能的原因,包括以下几种:

原因1: 如果您看到上述 "症状1详细信息" 部分提到的错误详细信息:

解决方案修补程序版本低于已安装的解决方案版本。 例如:名为 SolutionA 的解决方案已使用版本1.1.0.0 安装,而你尝试导入版本为1.0.1.0 的修补程序。

原因2:如果您看到上述 "症状2详细信息" 部分提到的错误详细信息:

如果已为该解决方案导入升级,但尚未应用该升级,则可能会出现此情况。 导入作为现有解决方案升级的解决方案后,解决方案导入的结尾将提供一个用于应用解决方案升级的按钮。 如果在此解决方案的解决方案升级之前未单击该按钮,则需要在解决方案列表中找到该解决方案,然后单击 " 应用解决方案升级 " 按钮。 

解决方案

解决方案1: 如果您看到上述 "症状1详细信息" 部分提到的错误详细信息:

验证你尝试导入的解决方案修补程序版本比已安装的解决方案版本更高。

解决方案2: 如果您看到上述 "症状2详细信息" 部分提到的错误详细信息:

导航到 " 设置"、" 自定义",然后单击 " 解决方案"。 选择你尝试升级的现有已安装解决方案,然后单击 " 应用解决方案升级"。 

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