桌面流程疑难解答使用 AAD 帐户时出现无效凭据错误

症状

使用 AAD 帐户运行的流失败,并出现 "InvalidConnectionCredentials" 或 "WindowsIdentityIncorrect" 错误代码。

InvalidConnectionCredentials 错误

Windows 标识错误消息

原因

使用 AAD 帐户时,可能会出现此错误的多种原因:

  • 输入到连接中的帐户凭据可能与计算机上的帐户凭据不匹配

  • 设备可能未进行 AAD 联接(或混合 AAD 联接)以支持 AAD 身份验证。

  • AAD 帐户可能未同步到计算机

解决方案

首先,确保设备已进行 AAD 联接或加入域:

  1. 打开命令提示符

  2. 运行命令 "dsregcmd/status"

  3. 检查 "设备状态" 部分

运行 dsregcmd/status 时命令提示符中的设备状态

请确保 "DomainJoined" 或 "AzureAdJoined" 值之一为 "是"。

如果不是这样,则不能使用 AAD 帐户,除非设备已加入,有关 如何加入设备的说明,请参阅 Microsoft 文档。

第二,标识要在计算机配置中使用的 AAD 帐户: 

  1. 打开 "设置",然后选择 "帐户"。

  2. 选择 "访问工作或学校"

  3. 请确保你看到的文本显示为 "已连接到 <your_organization> Azure AD" 等内容。  它所连接的帐户可以在连接中使用。

第三,同步设备上的 AAD 帐户。 为此,请执行以下操作:

  1. 在 "访问工作或学校" 屏幕中选择您的 Azure AD 连接时,单击 "信息" 按钮。

  2. 这将打开一个屏幕,描述连接信息和设备同步状态。  在此期间,将出现 "同步" 按钮-单击此按钮,然后等待此过程完成。

第四步,检查配置的 AAD 帐户是否可以登录到设备:

  1. 尝试使用上述步骤中标识的 AAD 帐户登录到计算机。

  2. 设备登录必须成功才能在连接中使用。

最后,确保已正确配置流的正确用户名和密码。 这与您计算机上的帐户非常匹配。

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