使用 Gmail 配置 Server-Side 同步时,无法发送或接收Email
本文提供了使用 Gmail 配置 Server-Side 同步时发生的错误的解决方案。
适用于:Microsoft Dynamics CRM 2013、Microsoft Dynamics CRM 2015、Microsoft Dynamics CRM 2016、Microsoft Dynamics CRM 2016 Service Pack 1
原始 KB 编号: 3185281
症状
如果Microsoft Dynamics CRM配置为使用 Server-Side 与 Gmail 同步,则可能会收到以下错误消息之一:
无法接收邮箱<的Email邮箱名称>。 请确保邮箱中指定的凭据正确无误,并且有足够的权限来接收电子邮件。 然后,启用邮箱以处理电子邮件。
发送电子邮件“测试邮件”时出现未知错误。 邮箱 <邮箱名称> 未同步。 已通知关联的电子邮件服务器配置文件<的所有者Email服务器配置文件名称>。
原因
出现错误的原因有以下其中一种:
原因 1
Microsoft Dynamics CRM邮箱记录中的电子邮件地址、用户名或密码不正确。
原因 2
未在 Microsoft Dynamics CRM Email 服务器配置文件记录中配置正确的端口。
原因 3
未在 Gmail 邮箱上启用 POP。
原因 4
Gmail 中的设置阻止 Server-Side 同步对 Gmail 邮箱进行身份验证。
解决方案
解决方法 1
验证Microsoft Dynamics CRM邮箱记录中的“Email地址”、“用户名”和“密码”字段的值。
解决方法 2
打开Email服务器配置文件,然后选择“高级”。 将“传入端口”设置为 995,将“传出端口”设置为 587。
解决方法 3
按照 Gmail 说明 启用 POP。
解决方法 4
在 Gmail 邮箱中查看有关阻止登录尝试的电子邮件。 该消息将包括有关如何取消阻止访问的步骤。 按照这些步骤操作后,再次尝试在 CRM 中测试并启用邮箱。
如果问题仍然存在,请参阅 排查登录问题,其中包括从应用启用电子邮件访问可能需要的其他步骤。
更多信息
警报的详细信息部分可能包括以下文本:
“错误:System.Net.Mail.SmtpException:语法错误,命令无法识别。 服务器响应为:
at System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End (IAsyncResult 结果)
at System.Net.Mail.SmtpClient.ConnectCallback (IAsyncResult 结果) ”
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