电子邮件不能在 Dynamics 365 中创建与 NoRecipientMatch 同步错误

症状

查看已通过 Dynamics 365 分析自动升级的电子邮件,看失败与NoRecipientMatch同步错误或错误代码-2147218683 Dynamics 365 中创建的电子邮件。

原因

当 Dynamics 365 计算您的邮箱中的电子邮件时,多个条件的评估以确定是否应自动创建邮件作为电子邮件活动中 Dynamics 365。如果计算会导致NoRecipientMatch错误,这表明以下条件之一:

  1. N上到一个电子邮件地址或电子邮件的抄送行是用户或队列中 Dynamics 365。

    • 答: 示例您收到电子邮件,因为它被发送到通讯组,并且是该通讯组的成员。电子邮件地址存储在 Dynamics 365 不实际上在收件人或抄送行的电子邮件。

    • 示例 b: 您有多个电子邮件地址 (如 paul@contoso.com 和 paul.cannon@contoso.com) 对同一个邮箱,但收件人的电子邮件地址或电子邮件的抄送行中不匹配 Dynamics 365 中的用户记录中存储的电子邮件地址。

  2. 没有用户或队列收件人或抄送行的电子邮件,但下列条件存在:

    • 由用户或队列的电子邮件地址位于 Dynamics 365 中的其他记录。例如: 用户具有电子邮件地址 paul@contoso.com,但该电子邮件地址也存在于另一个电子邮件启用实体,如用户、 队列、 联系人、 潜在顾客或客户的电子邮件地址字段之一。

    • 您的组织配置为保留电子邮件为无法解析的地址值,如果找到多个匹配项。 上面提到的两个条件的组合会导致电子邮件无法解析为用户或队列记录。

  3. 用户或队列的电子邮件地址是在电子邮件的密件抄送。 示例:您收到电子邮件,因为您的电子邮件地址的电子邮件的密件抄送行上。除非您在个人选项中 Dynamics 365 配置为跟踪"所有的电子邮件",将不会跟踪该电子邮件。除非在收件人或抄送的电子邮件地址的电子邮件的行匹配 Dynamics 365 中存储的电子邮件地址或 Dynamics 365 中的个人选项配置为跟踪"所有电子邮件",不会跟踪该电子邮件。

  4. 在收到该电子邮件的用户或队列邮箱 EmailSearchBase 表中没有行。 寻找匹配的用户或队列记录,当 Dynamics 365 查询名为 EmailSearchBase 的表。此表应自动拥有每个启用的电子邮件记录,包括用户和队列的电子邮件地址的行。极少数 occassions 在此表可能会丢失可导致 Dynamics 365,若要为用户或队列的电子邮件上的查询表时,未找到匹配的行的行。 您可以打开一个 web 浏览器并动态 365 Web API 用于验证行是否存在的用户或队列接收电子邮件的电子邮件地址。使用下面的语法: https://<Your 组织 URL > /api/data/v9.1/emailsearches?$filter=emailaddress eq< 电子邮件地址的用户或队列 > 例如: https://contoso.crm.dynamics.com/api/data/v9.1/emailsearches_qM _ $ 筛选器 = 电子邮件地址 eq 'paul@contoso.com' 如果没有记录返回,这将指示某行不存在该电子邮件地址 EmailSearchBase 表中。

解决方案

查看电子邮件的特征,哪个选项您已配置了您的个人选项中跟踪的电子邮件。

1.为了验证 Dynamics 365 中存储的电子邮件地址:

  1. 导航到设置,然后单击电子邮件配置

  2. 单击邮箱

  3. 打开您的邮箱记录并验证电子邮件地址在收件人或抄送行的电子邮件与邮箱记录中找到的电子邮件地址。

注意: 如果您对您的邮箱有多个电子邮件地址,您可以单击关于查阅并将其他电子邮件地址添加到其它电子邮件地址域中的一个,在您的用户记录。

2.如果存在多个记录的用户或队列的电子邮件地址 (如另一个用户、 队列、 潜在顾客、 客户、 联系人、 等等...),删除其他记录的电子邮件地址,或者为未解析的值更改设置将设置为抄送、 密件抄送字段的,如果多个传入电子邮件中找到匹配的no。您可以通过导航到设置电子邮件配置,然后单击电子邮件配置设置中找到此设置。在设置电子邮件表单选项部分中,找到设置名为"设置为,抄送,密件抄送字段为无法解析的值如果传入的电子邮件中找到多个匹配项。"

3.要查看或更改您的电子邮件跟踪设置:

  1. 通过单击设置 (在右上角的齿轮图标),然后单击选项来访问您的个人选项中 Dynamics 365。

  2. 单击电子邮件选项卡。

  3. Under 选择电子邮件跟踪在 Microsoft Dynamics 365 部分定位跟踪的设置。

  4. 调节根据哪些电子邮件应跟踪 Dynamics 365 在自动控制中的选项。

例如: 如果您希望每封电子邮件,收到时,发件人,无论自动创建电子邮件活动中 Dynamics 365 为选择"所有电子邮件"。

有关电子邮件相关的详细信息,请参阅电子邮件消息的筛选和关联

4.如果没有找到记录时使用原因 # 4 中的步骤,请执行以下步骤:

  1. 在 Dynamics 365 打开的用户或队列记录。

  2. 更改为其他内容的电子邮件地址值,并单击保存。

  3. 然后将电子邮件地址值更改回正确的值并单击保存。通常,这将重新创建丢失的行。

需要更多帮助?

扩展你的技能
了解培训
抢先获得新功能
加入 Microsoft 内部人员

此信息是否有帮助?

谢谢您的反馈意见!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×