在 Microsoft Dynamics 365 for Outlook 中跟踪电子邮件时,字典中不存在给定键错误

本文提供了在 Microsoft Dynamics 365 for Outlook 中跟踪电子邮件时发生的错误的解决方案。

适用于:Microsoft Dynamics 365
原始 KB 编号: 4010462

症状

尝试在 Dynamics 365 for Outlook 中跟踪电子邮件时,会收到以下错误:

“字典中不存在给定的键。”

如果选择详细信息,则会看到以下其他详细信息:

“字典中不存在给定的键。
at System.Collections.Generic.Dictionary2.get_item (Tkey 键)
at Microsoft.Crm.AppIication.SMWrappers.AttachmentForOutIook.Get...clientOrganizationContext、 IDynamicEntityCoIIectionForOutIook dynamicEntityCoIIectionAttachments)
atMicrosoft.Crm.AppIicationSMWrappers.EmaiIForOutIook.Microsoft....messageld、字符串主题、 String from、String to、String cc、String bcc、Double receivedon、String submitted8y、String importance、String body、IDynamicEntityCoIectionForOutIook attachments、Int32 attachmentCount、IDynamicEntityForIook extraProperties、String entityXmI、String regardingld、Int64 有关ObjectType、String crmld、Int32& notification) ”

原因

对于以下情况之一,可能会发生此错误:

  1. 电子邮件包含的附件大于Dynamics 365中允许的大小。
  2. 电子邮件包含一个带有文件扩展名的附件,Dynamics 365阻止该附件。

解决方案

解决方案 1
如果电子邮件包含超过大小限制的附件,请删除附件或增加Dynamics 365中允许的附件大小。 默认最大大小为 5 MB。

如果在 Dynamics 365 中具有系统管理员角色,则可以通过导航到“设置”、“管理”,然后选择“系统设置”来查看和修改此设置。 选择“Email”选项卡,然后在“设置附件文件大小限制”标题下找到“最大文件大小 (以千字节为单位) 设置”。

解决方案 2
如果电子邮件包含扩展名被Dynamics 365阻止的附件,请删除附件或修改Dynamics 365阻止的文件扩展名。

如果在 Dynamics 365 中具有系统管理员角色,则可以通过导航到“设置”、“管理”,然后选择“系统设置”来查看和修改此设置。 在“ 常规 ”选项卡上,找到设置附件 阻止的文件扩展名