"文件已存在"的错误配置 Microsoft Dynamics CRM for Microsoft Office Outlook 时

症状

在尝试配置 Microsoft Dynamics CRM for Microsoft Office Outlook,您会收到以下错误︰

"没有与 Microsoft Dynamics CRM 服务器通信时出现问题。服务器可能不可用。稍后再试。如果问题仍然存在,请与您的系统管理员联系。

文件已存在。请尝试使用其他数据库名称。[文件名称 = C:\Users\ < 用户 > \AppData\Local\Microsoft\MSCRM\Client\MetadataCache-5243bc89-09f7-4d12-b578-8efd890f5d7c.sdf]..."

原因

如果数据库文件从以前的配置已经存在您的 CRM 实例,会出现此错误。

解决方案

选项 1 (在线 CRM)

1.如果您正在使用 CRM Online,您可以运行的Microsoft 技术支持和恢复助手这可以为您解决此问题。

2.选择Dynamics CRM Online选项,然后单击"遇到的安装、 连接,或启用凭据 (Outlook 客户端) 的问题"。

3.继续执行向导。"所用的凭据缓存文件中删除"操作应该出现,并将错误信息中引用的现有文件。

4.再次运行 Microsoft Dynamics CRM 配置向导。



选项 2 (手动)

如果您没有使用 CRM Online 或更喜欢手动解决此问题,请完成以下步骤。

1.关闭 Outlook

2.打开 Windows 资源管理器,然后定位 < 安装目录 >: < 您用户 > \Users\ \AppData\Local\Microsoft\MSCRM\Client

示例︰ C:\Users\terryadams\AppData\Local\Microsoft\MSCRM\Client

注意︰ 默认情况下隐藏的应用程序数据文件夹。您可以更改的视图设置来显示隐藏项目,或可以复制并粘贴到您的文件夹路径的路径如下︰

%localappdata%\Microsoft\MSCRM\Client

3.删除错误详细信息中引用的文件。

4.再次运行 Microsoft Dynamics CRM 配置向导。

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