配置Microsoft Dynamics CRM for Microsoft Office Outlook时文件已存在错误
本文提供了配置Microsoft Dynamics CRM for Microsoft Office Outlook时发生的错误的解决方案。
适用于:Microsoft Dynamics CRM Online、Microsoft Dynamics CRM 2016、Microsoft Dynamics CRM 2015、Microsoft Dynamics CRM 2013、Microsoft CRM client for Microsoft Office Outlook
原始 KB 编号: 3183053
症状
尝试配置Microsoft Dynamics CRM for Microsoft Office Outlook时,会收到以下错误:
“与 Microsoft Dynamics CRM 服务器通信时出现问题。 服务器可能不可用。 请稍后重试。 如果问题仍然存在,请与系统管理员联系。
文件已存在。 尝试使用不同的数据库名称。 [ 文件名 = C:\Users\<USER>\AppData\Local\Microsoft\MSCRM\Client\MetadataCache-5243bc89-09f7-4d12-b578-8efd890f5d7c.sdf ]...”
原因
如果 CRM 实例已存在以前配置的数据库文件,则会发生此错误。
解决方案
选项 1 (CRM Online)
- 如果使用的是 CRM Online,则可以运行Microsoft 支持部门和恢复助手,这可以解决此问题。
- 选择 Dynamics CRM Online 选项,然后选择 安装、连接或启用 Outlook CRM 时遇到问题, (Outlook 客户端) 。
- 继续完成向导。 应显示“删除 CRM for Outlook 使用的缓存文件”操作,并将删除错误中引用的现有文件。
- 再次运行Microsoft Dynamics CRM配置向导。
选项 2 (手动)
如果不使用 CRM Online 或希望手动修复问题,请完成以下步骤。
关闭 Outlook。
打开 Windows 资源管理器并导航到
<install directory>:\Users\<Your User>\AppData\Local\Microsoft\MSCRM\Client
。例如:
C:\Users\<username>\AppData\Local\Microsoft\MSCRM\Client
注意
默认情况下,AppData 文件夹处于隐藏状态。 可以更改“查看”设置以显示“隐藏的项目”,也可以将以下路径复制并粘贴到文件夹路径中:
%localappdata%\Microsoft\MSCRM\Client
删除错误详细信息中引用的文件。
再次运行Microsoft Dynamics CRM配置向导。
反馈
https://aka.ms/ContentUserFeedback。
即将发布:在整个 2024 年,我们将逐步淘汰作为内容反馈机制的“GitHub 问题”,并将其取代为新的反馈系统。 有关详细信息,请参阅:提交和查看相关反馈