UnknownIncomingEmailIntegrationError -2147220891异常错误出现在 Microsoft Dynamics 365的邮箱警报中

本文提供了 Microsoft Dynamics 365邮箱警报中发生的错误的解决方案。

适用于:Microsoft Dynamics 365
原始 KB 编号: 4466423

症状

在 Dynamics 365 中查看邮箱记录中的警报部分时,会看到以下邮件之一:

  • “通过邮箱”邮箱名称>“<接收电子邮件时发生未知错误。 已通知关联的电子邮件服务器配置文件 <名称> 的所有者。 系统稍后将尝试再次接收电子邮件。

    Email服务器错误代码:Exchange 服务器返回了 UnknownIncomingEmailIntegrationError -2147220891 异常。”

  • “同步邮箱”邮箱名称>“<的约会、联系人和任务时发生内部 Microsoft Dynamics 365错误。 已通知关联的电子邮件服务器配置文件 <名称> 的所有者。 系统将稍后重试。

    Email服务器错误代码:Crm.80040265.ISV 代码中止了操作。”

原因

错误代码80040265和 -2147220891 指示 IsvAborted 错误。

如果看到“ 症状 ”部分中列出的第一封邮件,则通常是由创建电子邮件记录时运行的工作流或自定义插件引起的。

如果看到 症状部分中列出的 第二条消息,则通常是由在创建约会、联系人或任务记录时运行的工作流或自定义插件引起的。

解决方案

检查是否有任何自定义插件或工作流在创建错误中提到的记录类型时同步运行 (例如电子邮件、约会、联系人或任务) 。 如果插件或工作流在创建记录期间导致错误,Server-Side 同步无法成功创建记录。 以下步骤可帮助你确定组织中是否存在在创建电子邮件期间运行的任何工作流或插件。 如果创建失败的记录类型,则可以对约会等其他实体使用相同的步骤:

工作流

  1. 在Dynamics 365 Web 应用程序中,导航到“设置”,然后选择“进程”。

  2. 将视图更改为 “激活的进程”。

  3. 在“主要实体”列上排序,并查找Email作为主要实体和工作流作为类别的任何行。

    相反,可以使用网格中的筛选选项筛选类别 = 工作流主实体 = Email

  4. 打开找到满足上述条件的每个工作流, (是否有任何) 。

  5. 如果选择了“创建记录时选项时启动”选项,并且未选择“在后台运行此工作流 (建议) ”选项,则可能是导致此工作流的原因。

  6. 选择页面左侧的“ 处理会话 ”部分,并查找与未成功创建的电子邮件相关的任何失败。

插件

  1. 在 Dynamics 365 Web 应用程序中,导航到“设置”、“自定义”,然后选择“自定义系统”。
  2. 选择“ Sdk 消息处理步骤”。
  3. 在“主要对象类型代码” (SdkMessage 筛选器) 列中排序,并查找Email实体的任何行。
  4. 如果发现任何行并且执行模式为同步,则可能干扰电子邮件的创建。

如果问题一致地重现,并且可以暂时禁用工作流或插件作为测试,则可以确定工作流或插件是否是原因。