Microsoft Dynamics CRM 2011 Outlook 客户端无法配置到外部 IFD Web 地址
本文解决了以下问题:用户无法将 outlook 客户端Microsoft Dynamics CRM配置到外部 Web 地址,并且出现错误“无法连接到Microsoft Dynamics CRM服务器,因为我们无法对凭据进行身份验证”。
适用范围:Microsoft Dynamics CRM 2011
原始 KB 编号: 2912175
症状
使用 Active Directory 证书服务 (ADFS) 为面向 Internet 的部署 (IFD) 配置 Microsoft Dynamics CRM 2011 部署时,用户在尝试将 Microsoft Dynamics CRM Outlook 客户端配置为外部 Web 地址时,可能会收到以下错误:
无法连接到Microsoft Dynamics CRM服务器,因为我们无法对凭据进行身份验证。 检查连接或联系管理员以获取更多帮助。
查看配置日志时,还会捕获以下异常:
连接到 URL 时出错:
https://crmorg.domain.com/XRMServices/2011/Discovery.svc
异常:System.ServiceModel.EndpointNotFoundException:没有侦听的https://adfs.domain.com/adfs/services/trust/13/username
终结点可以接受消息 。
但是,用户仍可以通过 Web 浏览器访问外部 URL,而不会出错。
原因
可以启用 /adfs/services/trust/13/username 终结点。 启用此终结点后,客户端将无法访问 usernamemixed 和 kerberosmixed 终结点,这会导致身份验证失败。
解决方案
禁用 /adfs/services/trust/13/username 终结点并重启 ADFS 服务。 若要执行此操作,请参阅以下步骤:
- 打开 AD FS 管理控制台。
- 在左侧导航窗格中,展开“ 服务”,然后选择“ 终结点”。
- 在终结点列表中,找到并右键单击 /adfs/services/trust/13/username 终结点。
- 选择 “禁用”。
- 重启 AD FS 服务。