Microsoft Dynamics CRM 2011 Outlook 客户端无法将配置为 IFD 外部 web 地址

症状

当 Microsoft Dynamics CRM 2011年部署配置为互联网面临部署 (IFD) 使用活动目录证书服务 (ADF) 时,用户可能会尝试配置 Microsoft Dynamics CRM Outlook 客户端的外部 web 地址时收到以下错误︰

"无法连接到 Microsoft Dynamics CRM 服务器因为我们无法验证您的凭据。检查您的连接或与您的管理员联系以获得帮助。

当查看配置日志,也会捕获以下异常︰

在连接到 URL 错误︰ https://crmorg.domain.com/XRMServices/2011/Discovery.svc 例外︰ System.ServiceModel.EndpointNotFoundException︰没有在 http://adfs.domain.com/adfs/services/trust/13/username,可以接受消息侦听终结点。

但是,用户仍可以通过 web 浏览器没有错误访问的外部 URL。

原因

可以启用 /adfs/services/trust/13/username 终结点。当启用此终结点时,客户端将不能达到 usernamemixed 和 kerberosmixed 的终结点,这会导致身份验证失败。

解决方案

禁用 /adfs/services/trust/13/username 端点并重新启动 ADFS 服务。若要执行此操作,请参阅以下步骤︰

  1. 打开AD FS 管理控制台

  2. 在左侧的导航窗格中,展开服务,然后单击终结点。

  3. 在终结点列表中,找到并右键单击/adfs/services/trust/13/username终结点

  4. 选择禁用

  5. 重新启动 AD FS 服务。


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