症状

Power Automate 桌面控制台不会在"我的流"列表中显示任何桌面流。

验证问题

  1. 在 Power Automate 桌面控制台中,按"刷新"按钮以确保桌面流仍未显示。

  2. 转到 Power Automate 门户,确保"我的流"和"桌面流"部分>桌面流。

  3. 请确保代理服务器对用户的 Active Directory 帐户使用自动身份验证,例如 (身份验证。 Kerberos、Negotiate、NTLM) 。

  4. 确保不必每次需要向代理服务器进行身份验证时都输入凭据。

  5. 验证代理服务器是否不在 Socks 代理服务器中。

原因

运行 Power Automate Desktop 的虚拟机使用需要身份验证的代理服务器。 Power Automate 不会在与 Power Automate 通信时向代理服务器进行身份验证,因此通信失败。 

解决方法

请确保你拥有管理员权限或具有此类权限的某人可用。 

导航到 Power Automate Desktop 安装文件夹 ("C:\Program Files (x86) \Power Automate Desktop') "。

备份这 2 个文件PAD.Designer.Host.exe.config"和"PAD.Console.Host.exe.config",以便出现问题时恢复它们。 

对于这两个文件,执行以下操作: 

使用管理员权限编辑每个文件,在根 xml 节点的末尾 (<配置>) 添加 以下子 xml 节点: 

     <system.net>

          <defaultProxy enabled="true" useDefaultCredentials="true"> 

          </defaultProxy> 

     </system.net>

保存文件。

从系统托盘图标重启 Power Automate Desktop (右键单击系统任务栏中的 PAD 图标,并单击"退出") 。 

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