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常规步骤

若要确保安装成功,请确保:

  • 你使用的是 Power Automate Desktop 的最新安装程序

  • 你有管理员权限:安装程序会要求你提供管理员权限,如果你选择否,安装程序会失败

  • 你已重启计算机:某些 Windows 更改需要重新启动才能生效,并且可能会阻止安装

  • 你运行的是受支持的 Windows 操作系统的最新版本:Windows 10 (家庭版、专业版或企业版) 或Windows Server 2016或更高版本

已知安装问题和解决方法

Power Automate 服务无法启动:计算机本地存储中没有证书

原因

安装失败,因为计算机不允许将 Power Automate Desktop 与本地数据网关配合使用所需的证书。 可以在事件查看器中找到此错误:

事件查看器错误

需要解决 (安装程序版本 2.32 或更高版本)

从 2023 年 5 月版 PAD 开始,可以通过使用 /SkipGatewaySupport 参数从命令行运行安装来跳过本地数据网关连接支持所需的安装步骤。

从 cmd 运行安装程序

Power Automate 服务启动:无法加载 DLL“uiflowsclient.dll”

原因

安装失败,因为 Power Automate Windows 服务无法启动,并且事件查看器日志显示它无法启动的原因是“System.DllNotFound 异常:无法加载 DLL'uiflowsclient.dll'

解决方法

卸载 Microsoft Visual C++ 2015-2019 可再发行组件

转到“设置>应用>应用&功能”并卸载它,然后重新安装 Power Automate Desktop。 Power Automate Desktop 安装程序将重新安装 C++ 可再发行组件。 卸载 Visual C++

Power automate 服务无法启动:无法枚举会话

安装失败,因为 Power Automate 服务在启动时崩溃,并在事件查看器中出现此错误:

原因

安装程序向 Power Automate 服务授予枚举计算机上的用户会话的权限。 这些权限可能需要重启计算机才能生效。

需要解决 (安装程序版本 2.18 或更高版本)

此问题可以通过在安装过程中跳过启动 Power Automate 服务并在安装后立即重启计算机来解决此问题。 这可以通过将 /SKIPSTARTINGPOWERAUTOMATESERVICE 参数传递给安装程序来完成:

如果成功,你将看到 Power Automate Windows 服务在计算机重启后成功运行,并且不再崩溃并发出事件日志中出现的“枚举会话失败”错误。

Power automate 服务无法启动:服务帐户错误

安装失败,因为 Power Automate 服务在启动时崩溃,事件查看器会显示以下两个错误:

原因

计算机可能存在问题,无法在安装过程中创建 Power Automate 服务的 Windows 帐户 (NT Service\UIFlowService) 。

可以通过再次运行安装,并在安装程序尝试启动 Power Automate 服务时检查帐户是否存在来确认这一点。 应在此处的注册表中找到帐户的配置文件:“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-5-80-3017052307-2994996872-1615411526-3164924635-3391446484

如果此注册表项不存在,则计算机不允许创建服务用户帐户。 请注意,如果未安装Power Automate 桌面,则预计密钥不存在,需要在安装期间检查其是否存在。

需要解决 (安装程序版本 2.18 或更高版本)


有一种解决方法需要提供将运行服务的 Windows 用户帐户,而不是默认帐户。 此帐户需要是远程桌面用户组的成员,并且需要具有“以服务身份登录”权限。

可以通过从命令行运行 Power automate 服务并传递 /SKIPSTARTINGPOWERAUTOMATESERVICE 参数来运行安装程序并跳过启动 power automate 服务

安装成功后,运行 Power Automate 计算机运行时应用,并使用故障排除菜单更改服务帐户。

Power Automate 服务无法启动:验证是否具有足够的权限来安装系统服务

若要确认这是你遇到的问题,请在事件查看器中查找以下事件:

以及Power Automate 桌面服务不存在崩溃,如果发现任何类似以下捕获的错误,则崩溃的原因是阻止安装的原因:

原因

用于启动 Power Automate 服务的帐户无法启动该服务,因为“拒绝作为服务登录”策略会阻止该服务。

默认情况下,UIFlowService 在安装过程中作为 NT SERVICE\UIFlowService 运行。 UIFlowService 使用的帐户稍后可以更改,但出于安装目的,不得阻止它登录。

解决方法

更新“拒绝作为服务登录”策略,以删除阻止 NT SERVICE\UIFlowService 作为服务登录的帐户或组。

示例:每个人

无法启动 LanmanServer 服务

在安装程序日志 (请参阅下面的 收集诊断信息 部分,) 可以找到此错误消息:

“启动 LanmanServer 服务时引发的异常:System.InvalidOperationException: 无法在计算机上启动服务 LanmanServer”

原因

Power Automate 安装程序依赖于 LanmanServer 服务,如果它尚未运行,则会尝试启动它。 如果服务无法启动,则依赖于该服务的安装步骤将失败,并且安装也会失败。

解决方法

在服务管理器 (Windows 密钥 + R services.msc 或“开始”菜单) 的服务中,找到名为“服务器”的服务,右键单击它并选择属性。 在“常规”选项卡中,确保其启动模式未禁用, (默认情况下应自动) 。 单击“应用”以更新启动模式。
然后,可以通过在服务管理器工具中右键单击服务并选择“启动”来手动启动该服务。 服务运行后,可以再次尝试安装。

未能绑定 SSL 证书

若要确认这是你遇到的问题,请查看安装程序日志 (请参阅下面的 收集诊断信息 部分,) “在 SetServiceUrlAcl 时引发异常”。

原因

安装 Power Automate 时,将 SSL 证书绑定到 Power Automate 使用的 http 端口失败。

解决方法

仅本地数据网关连接需要 SSL 证书,如果不需要该证书,则从 2023 年 5 月版本 (版本 2.32 或更高版本) 开始,可以使用 /SkipGatewaySupport 参数从命令行运行安装,跳过本地数据网关连接支持所需的安装步骤。

从 cmd 运行安装程序

如果确实需要网关支持,可以获取有关根本原因的更多详细信息,请运行以下 PowerShell 命令。 其中一个应失败并显示特定的错误代码,这将提供有关如何缓解该问题的更多见解:

$sslport = 4723
$applicationId = [string]::Format("{{{0}}}", "33BEDDD1-E697-4606-B306-C5DFE7AE0AAE")
$serviceUser = "[USER account]" # TODO: fill with domain\alias
$thumb = "[Certificate thumbprint to bind - certificate located in LocalMachine\My cert store]" # TODO: fill certificate thumbprint

function ExitIfError {
    if ($LASTEXITCODE -ne 0) {
        exit 1
    }
}

Write-Host port: $sslport; thumb: applicationId=$applicationId

Write-Host [2] Adding all IP addresses to the IP listen list
netsh http add iplisten ipaddress=0.0.0.0

Write-Host [3] Trying to remove the previous certificate on port $sslPort
netsh http delete sslcert ipport=0.0.0.0:$sslPort

Write-Host [4] Binding port $sslPort to certificate with thumbprint $thumb
netsh http add sslcert ipport=0.0.0.0:$sslPort certhash=$thumb appid=$applicationId verifyclientcertrevocation=disable
& netsh http show sslcert ipport=0.0.0.0:$sslPort # displaying the cert binding
ExitIfError

Write-Host [5] Giving access to https://+:$sslPort/UiFlowDispatcher/ to user $serviceUser
netsh http add urlacl url=https://+:$sslPort/UiFlowDispatcher/ user=$serviceUser

收集诊断信息

为了最好地了解和修复安装,以下数据可能会有所帮助:

  • 安装程序日志:可以在安装用户的 %temp% 文件夹中找到这些日志, (文件资源管理器的地址栏中键入“%temp%”,然后按 enter) 。 可以使用以下格式获取两个文件:Power_Automate_Desktop_*.log Power_Automate_Desktop_*_*_MicrosoftFlowRPA.log,可以按“修改日期”对文件进行排序,以便更轻松地查找它们。  PAD 安装程序日志 Power_Automate_Desktop_*.log 文件链接在安装程序的故障结束屏幕上,并包含安装失败的一般原因。 Power_Automate_Desktop_*_*_MicrosoftFlowRPA.log 文件包含有关安装的更详细的日志。

  • 事件查看器日志:当 Windows 服务无法启动时,这些日志将非常有用。 打开 Windows 事件查看器,导航到 “Windows 日志>应用程序”,并查找错误 事件查看器日志

  • 程序数据日志:有我们在计算机上安装的组件的日志。 可以在以下路径中找到这些日志: %programdata%\Microsoft\Power Automate Desktop\Logs 这些日志需要将管理员权限复制到另一个文件夹。 需要先复制它们,然后才能打开它们,此文件夹的内容是只写的。

如果需要联系支持人员,请将以下 4 个项目作为 zip 文件与票证一起发送:

  1. Power_Automate_Desktop_*.log

  2. Power_Automate_Desktop_*_*_MicrosoftFlowRPA.log

  3. 事件查看器日志

    • 选择“筛选当前日志”以仅捕获正确的日志 (例如过去一小时)

    • 右键单击所选错误

    • 选择“将筛选的日志文件另存为”,并另存为 evtx 文件

  4. %programdata%\Microsoft\Power Automate Desktop\Logs 文件

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