在 Outlook 中專門或 ITAR Office 365 環境中的 「 安全性憑證的名稱不正確,或與網站名稱不相符 」 錯誤

適用於: Microsoft Business Productivity Online DedicatedMicrosoft Business Productivity Online Suite Federal

症狀


在專用或手臂規定 (ITAR) Microsoft Office 365 環境中的國際流量,會提示使用者,由安全性警訊對話方塊包含下列的錯誤訊息: 
安全性憑證的名稱不正確或不符合的站台名稱。
例如,[安全性警訊] 對話方塊類似下列:在下列情況下,可能會發生這個問題:
  • 使用者嘗試在 Microsoft Office Outlook 中建立新的設定檔。
  • 使用者嘗試啟動 Outlook 用戶端。
  • Outlook 用戶端投影片時,問題會間歇性地發生。
如果使用者按一下 [] 時,使用者可以繼續作業。 不過,如果使用者按一下 [],自動探索查閱將會失敗。 如預期般,自動探索查閱失敗會防止下列功能無法正常運作:
  • 自動建立 Outlook 設定檔,使用自動探索
  • 郵件答錄機 (OOF) 助理員]
  • 空閒/忙碌資訊

原因


通常,當您嘗試存取的 URL 不會列出主旨或網站的安全通訊端層 (SSL) 憑證主旨替代名稱 (SAN) 中時,就會發生這個問題。 雖然不同的組織設定可能會稍有不同,這個問題通常是由於組織的自動探索網域名稱系統 (DNS) 記錄設定不正確。

解決方案


若要解決這個問題,您可能要變更自動探索 DNS 記錄 (內部、 外部、 或兩者)。 不過,這些變更應該經過輕忽,因為自動探索功能無法運作,如果 DNS 記錄設定不正確。變更自動探索 DNS 記錄之前,您應該瞭解 Outlook 用戶端會找出自動探索服務的方式。 Outlook 用戶端會嘗試使用下列基礎作業的順序來找出自動探索服務。 不過,在步驟自動探索服務所在而有所不同部署。 這個位置取決於是否先方案中有共存且什麼特定先電子郵件環境為 (例如,先 Microsoft Exchange Server 上場所 Lotus Notes 中或另一個環境)。下表會顯示基礎的 Outlook 用戶端如何找出自動探索服務的作業順序:
1
  1. 服務連線點 (SCP) 物件-只使用內部的連線。
  2. Outlook 用戶端會嘗試找出 A 記錄,由 SCP 物件所傳回的 url。
2
  1. 使用者的 SMTP 網域。 (例如,https://proseware.com)
  2. Outlook 用戶端會嘗試找出使用者的 SMTP 網域 A 記錄。
3
  1. 使用者的 SMTP 網域都會加上自動探索。 (例如,https://autodiscover.proseware.com)
  2. Outlook 用戶端會嘗試尋找 A 記錄會附加具有自動探索的 url。
4
  1. Outlook 用戶端著尋找 DNS 服務符合使用者的 SMTP 網域的 DNS 區域的自動探索服務 (SRV) 記錄。 (例如,_autodiscover._tcp.proseware.com)
  2. SRV 記錄在某種解析記錄必須存在,例如 A 記錄或 CNAME 記錄,則會傳回另一個的 URL。
5 結果 如果自動探索服務找不到任何一種方法,自動探索就會失敗。
總之,或許可以解決自動探索服務使用 A 記錄 」、 「 CNAME 記錄或 「 SRV 資料錄。 如果要判斷目前使用的記錄,請在命令提示字元,或在 Windows PowerShell 中執行下列命令:
  1. 若要找出 A 記錄,請執行下列命令。 請確定您用下方的SMTPDomain.com值的網域替代頂端的憑證錯誤。
nslookup 
set type=A 
Autodiscover.SMTPDomain.com 
  1. 若要尋找的 SRV 記錄,請執行下列命令:
nslookup 
set type=SRV 
_autodiscover._tcp.SMTPDomain.com 
在下列範例中,Outlook 用戶端可以找出自動探索服務,在上表中的步驟 3 中所述,使用 A 記錄的自動探索 URL: 
autodiscover.proseware.com
不過,如我們所述 < 原因=""> 一節中,這個 URL 的 SSL 憑證由自動探索服務 SAN 中未列出。 例如,請參閱下列的螢幕擷取畫面:若要解決這個問題,請使用下列方法。 

取代現有資料錄,藉由使用 SRV 記錄指向已存在的 SSL 憑證 SAN 中的命名空間

這是慣用的解決方法,在目前的服務設計,因為現有的 SSL 憑證並沒有更新及部署。 本章節中稍早所列的作業基礎的順序,根據組織可能使用受控制和測試的方法,可以避免中斷的自動探索服務來實作新資料錄。如果要解決這個問題,請依照下列步驟執行:
  1. 建立新的 SRV 記錄。 與使用者的 SMTP 網域相符的 DNS 區域中,就應該建立 SRV 記錄。 SRV 記錄應該有下列屬性:
    • 服務: _autodiscover
    • 通訊協定: _tcp
    • 連接埠: 443
    • 主應用程式: 重新導向的 URL。 這個 URL 可能是 Outlook Web Access (OWA) URL,因為已解析的 IP 應該是與自動探索服務相同。 此外,這可能會不同部署。
  2. 您可以移除現有的資料錄之前,新的 SRV 記錄應該進行檢測,藉由變更重新導向目前使用者的主應用程式檔案到不正確的 IP 資料錄。 這項測試可以驗證新的 SRV 記錄正在如預期般在部署至整個組織的新的 DNS 記錄之前。 注意: 當 Outlook 用戶端使用 SRV 記錄時,使用者可能會收到下列訊息,指示即將發生的重新導向的使用者。 我們建議使用者選取 [不要再問我一次此網站有關的核取方塊,這樣還是沒有出現的訊息。  
  3. 當如預期般運作的 SRV 記錄時,您可以移除現有的 DNS 中的資料錄。

其他相關資訊


如需有關自動探索服務的詳細資訊,請前往下列 Microsoft TechNet 網站: