當您嘗試升級 MARS 代理程式時發生錯誤:Microsoft Azure 復原服務代理程式更新失敗

本文說明當您嘗試從舊版升級至較新版本或版本的 Microsoft Azure 復原服務 (MARS) Agent 時所發生問題的徵兆和解決方式。

原始產品版本:Azure Site Recovery
原始 KB 編號: 4020490

徵狀

當您嘗試使用 Microsoft Azure 復原服務代理程式升級精靈升級 MARS 代理程式時,升級會失敗,而且您會收到下列錯誤訊息:

Microsoft Azure 復原服務代理程式更新失敗。
錯誤:無法啟動 RecoveryServicesManagementAgent 服務。 卸載修補程式
問題:更新安裝失敗,發生錯誤 1612

原因

發生此問題的原因是升級在 Windows Installer 快取中找不到 MARS 代理程式的來源安裝程式。 需要來源安裝程式,才能順利完成升級。

解決方案

若要修正此問題,請確定來源安裝程式存在於 Windows Installer 快取中。 如果要執行這項操作,請依照下列步驟執行:

  1. 結束 Microsoft Azure 復原服務代理程序升級精靈。

  2. 開啟位於資料夾中的 C:\Windows\Temp OBPatch.log檔案。

  3. 在搜尋「警告:本機快取套件」的OBPatch.log檔案中找出錯誤描述行。

  4. 找出類似下列的行:警告:

    本機快取套件 『C:\Windows\Installer\Unique_ID.msi 遺失。

  5. 請注意theUnique_IDvalue以供日後參考。

  6. 按兩下MARS代理程式更新安裝程式 (.exe) 檔案。 這會將所有安裝程式相關的二進位檔和安裝程式檔案複製到計算機上的暫存位置,並開啟 Microsoft Azure 復原服務代理程式升級精靈。

    注意 讓精靈保持開啟狀態,直到步驟 12。

  7. 開啟位於 「C:\Windows\Temp」 資料夾中的 OBInstaller0Curr.errlog 檔案。

  8. 搜尋 在 「SetupLaunchScreen 的目錄路徑」文字中,然後找出具有最新時間戳的行,其類似下列內容:SetupLaunchScreen 的目錄路徑:C:\Temp_ID

  9. 移至檔案 C:\Temp_ID\Installers 夾。

  10. 在此資料夾中,找出 OBSAGENT.msi 檔案並複製到 C:\Windows\Installer 資料夾。 將目的地檔案重新命名為 Unique_ID.msi

  11. 關閉MARS代理程序升級精靈。

  12. 執行升級安裝程式以安裝升級。 如果問題持續發生,請連絡 Microsoft 支援服務。

與我們連絡,以取得說明

如果您有問題或需要相關協助,請建立支援要求,或詢問 Azure community 支援。 您也可以將產品意見反應提交給 Azure 意應見反社群