當您嘗試列印的報表,在 Microsoft Dynamics CRM 3.0 中的錯誤訊息: 「 無法載入用戶端的列印通訊協定 」


狀況


當您嘗試列印的報表,在 Microsoft Dynamics CRM 3.0 中時,您會收到下列錯誤訊息︰
無法載入用戶端的列印通訊協定。

原因


如果未安裝的 ActiveX 元件,可能會發生這個問題。

解決方案


若要解決這個問題,請啟用 Windows Internet Explorer 中的 ActiveX 設定。接著,加入至 [近端內部網路] 區域的下列 URL:
  • 電腦正在執行 Microsoft Dynamics CRM 伺服器 URL
  • 正在執行 Microsoft SQL Server 報告服務的電腦的 URL
若要執行這項操作,請參考下列步驟:
  1. 啟動 Windows Internet Explorer。
  2. 在 [工具] 功能表上按一下 [網際網路選項]。
  3. 在 [安全性] 索引標籤中,按一下 [近端內部網路,,然後按一下 [網站
  4. 按一下 [進階]。
  5. 輸入在此將網站新增到該區域] 方塊中,執行 Microsoft Dynamics CRM 伺服器電腦的 URL,,然後按一下 [新增]
  6. 輸入的 URL,在此將網站新增到該區域] 方塊中,執行 Microsoft SQL Server 報告服務,然後按一下 [新增的電腦。
  7. 按一下 [關閉] 以關閉 [近端內部網路] 對話方塊中,並按一下[確定]
  8. 按一下 [安全性] 索引標籤的 [自訂層級]。
  9. 為每個被列在ActiveX 控制項及外掛程式的元件,按一下 [啟用]。
  10. 按一下[確定]以關閉 [網際網路選項] 對話方塊。
  11. 結束 Windows Internet Explorer,,然後再啟動 [Microsoft Dynamics CRM 3.0。
  12. 請嘗試列印的報表。

    如果您持續遇到 < 徵狀=""> 一節所述的問題,請手動安裝的 ActiveX 元件。若要執行這項操作,請參考下列步驟:
    1. 找出報表的 Server\bin 資料夾。

      注意事項
      • 如果您執行 Microsoft SQL Server 2000年報告的服務時,會將這個資料夾位於下列位置︰
        C:\Program 必要 SQL Server\MSSQL\Reporting Services\ReportServer\bin
      • 如果您執行 Microsoft SQL Server 2005年報告的服務時,會將這個資料夾位於下列位置︰
        C:\Program 必要 SQL Server\MSSQL.4\Reporting Services\ReportServer\bin
    2. RSClientPrint.cab檔案中,按一下滑鼠右鍵,然後按一下 [解壓縮。展開到資料夾,在步驟 12a 中的檔案。
    3. 您在步驟 12b 中,展開RSClientPrint.inf檔案上按一下滑鼠右鍵,然後按一下 [安裝
    4. 請試著列印報表。

更多的資訊


SQL Server 報告服務會使用 ActiveX 列印控制項列印功能在 Windows Internet Explorer 中。如果正在執行 Microsoft Dynamics CRM 3.0 的電腦上未安裝的 ActiveX 元件,您會收到 < 徵狀=""> 一節所述的錯誤訊息。