修正︰ 當您嘗試安裝商務伺服器 2009年正在執行 Windows Server 2008 R2 的電腦上安裝失敗

適用於: Commerce Server 2009 EnterpriseCommerce Server 2009 Standard

狀況


當您嘗試在執行 Windows Server 2008 R2 的電腦上安裝 Microsoft 商務伺服器 2009年時,安裝就會失敗。此外,您會收到下列錯誤訊息︰
.NET Framework 3.5 sp1 不存在於電腦上。您必須安裝.NET Framework 3.5,有了 sp1 之後,若要繼續這項安裝。

注意即使您有 [.NET Framework 3.5 Service Pack 1 (SP1)] 或 [安裝的.NET Framework 的更高版本,就會發生這個問題。

原因


在安裝期間商務伺服器 2009 年,安裝程式會搜尋特定的登錄機碼找不到.NET Framework 3.5 SP1。不過,與 Windows Server 2008 R2 整合的.NET Framework 版本並沒有登錄機碼有問題。因此,安裝程式會停止回應。

解決方案


若要解決這個問題,請套用下列 hotfix 安裝商務伺服器 2009年之前,先執行 Windows Server 2008 R2 的電腦上。

此 hotfix 不會更新您的電腦上的任何檔案。此 hotfix 會建立所需的商務伺服器 2009年安裝程式的登錄項目。如果所需的登錄項目已經存在,則系統會顯示下列訊息︰
您不需要套用此補充程式到這台電腦。
我們強烈建議您移除此 hotfix 之後您已順利安裝商務伺服器 2009年。您可以使用 [控制台] 中的 [程式和功能的項目來解除安裝 hotfix。

Hotfix 資訊

支援的 hotfix 可從 Microsoft 取得。不過,此 Hotfix 僅用於修正本文中所述的問題。此 Hotfix 只適用於發生此特定問題的系統上。

如果 hotfix 可供下載,在此知識庫文件頂端將出現「可用的 Hotfix」區段。如果這個區段不會出現,將要求提交給 Microsoft 客戶服務及支援取得 Hotfix。

注意如果發生其他問題,或如果需要進行疑難排解,您可能必須建立個別的服務要求。收取支援費用會套用到其他支援問題和此特定 hotfix 無法解決的問題。如需完整的清單,以及 Microsoft 客戶服務支援電話號碼,或如果您要建立個別的服務要求,請造訪下列 Microsoft 網站:-注意「 下載 Hotfix 」 表單會顯示 hotfix 可用的語言。如果看不到您的語言,是因為未提供該語言的 Hotfix 。

先決條件

您必須套用此 hotfix 之後所安裝的 Windows Server 2008 R2。

重新啟動需求

您不必套用此 hotfix 之後,重新啟動電腦。

Hotfix 取代資訊

此 hotfix 不會取代任何其他 hotfix。

狀態


Microsoft 已確認這是<套用>一節所列出的 Microsoft 產品的問題。

更多的資訊


支援適用於執行 Windows Server 2008 R2 Commerce Server 下列版本︰
  • Commerce Server 2009
  • 商務伺服器 2007 Service Pack 2 (SP2)

當您從 Windows Server 2008 升級到 Windows Server 2008 R2 時,Microsoft 商務 Server 2007 SP2 和商務伺服器 2009年如預期般運作。