使用 Microsoft Dynamics 365 App for Outlook 登入時發生錯誤
本文可協助您修正使用 Microsoft Dynamics 365 App for Outlook 時,發生「登入時發生錯誤」錯誤的問題。
適用於:Microsoft Dynamics 365
原始 KB 編號: 4035750
徵狀
在 Outlook 桌面中使用 outlook Dynamics 365 App 時,您會遇到下列錯誤:
登入有問題嗎?
登入時發生錯誤。 請嘗試將下列 URL 新增至您的信任網站:
https://*.dynamics.com
https://login.microsoftonline.com
如果問題持續發生,請連絡您的系統管理員。」
原因
使用 Dynamics 365 App for Outlook 所需的部分 URL 位於不同的 Internet Explorer 安全性區域 (例如因特網、信任的網站或近端內部網路) 。
在 Outlook 桌面中使用 Dynamics 365 App for Outlook 時,Internet Explorer 可用來顯示內容,並視需要重新導向您進行驗證。 不同的安全性區域可能會使用不同的完整性層級,視區域是否啟用受保護模式而定。 如果以不同的完整性層級載入不同的 URL,則會防止驗證成功從驗證 URL 傳遞至 Dynamics 365。
解決方案
請確定 Dynamics 365 所使用的 URL 以及您的驗證 URL 使用相同的完整性層級。 使用下列其中一個解決方法:
選項 1 - 將每個 Dynamics 365 URL 和驗證 URL 新增至 Internet Explorer 中的相同安全性區域
在 Internet Explorer 中,按一下 [工具] 按鈕,然後按一下 [網際網路選項]。
按兩下 [ 安全性] 索引標籤,按兩下 [ 信任的網站 ] 區域,然後按兩下 [ 網站]。
在 [ 將此網站新增至區域] 中,一次輸入一個下列 URL:
*.dynamics.com
*.microsoftonline.com
https://login.windows.net
重要事項
如果您使用同盟驗證來存取 Dynamics 365 使用公司認證,您也需要新增公司所使用的驗證 URL。 例如:如果您的公司使用 Active Directory 同盟服務 (ADFS) 的驗證 URL
https://adfs.contoso.com/...
,請將此 URL 新增至相同的區域,或確定這兩個區域具有相同的受保護模式設定。按兩下 [新增],按兩下 [ 關閉],然後按兩下 [ 確定]。
按兩下 [確定 ] 關閉 [因特網選項] 對話框。
選項 2 - 在每個 Internet Explorer 安全性區域上啟用受保護模式
藉由在每個 Internet Explorer 安全性區域上啟用受保護模式,每個 URL 都會載入相同的完整性層級。
- 在 Internet Explorer 中,按一下 [工具] 按鈕,然後按一下 [網際網路選項]。
- 按一下 [安全性] 索引標籤。
- 選取每個區域 (因特 網、近端 內部網路和 信任的網站) 。
- 選取每個區域時,請確認已選取 [ 啟用受保護模式] 複 選框。
- 按兩下 [確定 ] 關閉 [因特網選項] 對話框。
其他相關資訊
當安全性區域啟用受保護模式時,URL 會以低完整性層級載入, (最安全的) 。 當安全性區域的受保護模式停用時,URL 會載入中等完整性層級。 如果 URL 未新增至 信任的網站 或 近端內部網路 區域,則預設會在預設啟用受保護模式的因特網區域中載入。
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