以其他使用者身分傳送電子郵件時發生「您無法以選取的使用者身分傳送電子郵件」錯誤

本文可協助您修正當您在 Microsoft Dynamics CRM 中以其他使用者身分傳送電子郵件時,收到「您無法以選取的使用者身分傳送電子郵件」錯誤的問題。

適用於:Microsoft Dynamics CRM Online、Microsoft Dynamics CRM 2016、Microsoft Dynamics CRM 2015、Microsoft Dynamics CRM 2013、Microsoft Dynamics CRM 2011 年
原始 KB 編號: 3184980

徵狀

當您嘗試將 [件者] 字段設定為 Microsoft Dynamics CRM 中的另一位使用者來傳送電子郵件時,您會收到下列錯誤訊息:

「您無法以選取的使用者身分傳送電子郵件。 選取的用戶不允許這麼做,或者您沒有足夠的許可權可以這麼做。 請連絡您的系統管理員以取得協助。」

原因

如果存在下列其中一個條件,就會發生此問題:

  • 您在 Microsoft Dynamics CRM 中的安全性角色遺漏 [以另一個使用者身分傳送 Email] 許可權。

    注意事項

    如果您使用工作流程規則來傳送電子郵件,則工作流程規則的擁有者需要此許可權。

  • 您嘗試以 身分傳送的使用者尚未啟用允許其他使用者以他們身分傳送電子郵件的選項。

解決方案

若要解決此問題,請採取下列步驟來確認您的安全性角色包含 [以另一個使用者身分傳送 Email] 許可權。

  1. 以具有系統管理員角色的使用者登入 Microsoft Dynamics CRM。

  2. 流覽至 [設定],然後選取 [ 安全性安全>性角色]

  3. 開啟指派給收到錯誤訊息之使用者的安全性角色。

  4. 選取 [ 商務管理] 索引 標籤。

  5. 確認使用者具有 [傳送 Email 為另一個使用者] 許可權

    注意事項

    [以另一個使用者身分傳送 Email 許可權具有不同層級的深度。 使用者在此許可權中需要足夠的深度,以符合他們嘗試以身分傳送的使用者。 例如,如果您嘗試以 Dynamics CRM 內不同業務單位的使用者身分傳送,則擁有此許可權的業務單位層級存取權並不夠,因為這隻會讓您以相同業務單位中的其他使用者身分傳送。

  6. 選取 [儲存]

您也需要採取下列步驟來確認您嘗試傳送的使用者是否已啟用選項,以允許其他使用者以他們身分傳送電子郵件。

  1. 以您嘗試以身分傳送電子郵件的使用者身分登入 Microsoft Dynamics CRM。
  2. 選取右上角的齒輪圖示,然後選取 [ 選項]
  3. 選取 [Email] 索引標籤。
  4. 確認已選取 [允許其他 Microsoft Dynamics CRM 使用者代表您傳送電子郵件] 選項。
  5. 選取 [確定]

其他相關資訊

當您選取 [ 下載記錄檔] 按鈕時,[ 訊息 ] 區段會顯示下列資訊:

<訊息>用戶沒有傳送身分許可權。</消息>