在 Microsoft 中測試和啟用信箱時,收到電子郵件錯誤時發生一般信箱存取錯誤 Dynamics 365

本文提供當您嘗試在 Microsoft Dynamics 365 中測試和啟用信箱時所發生錯誤的解決方案。

適用於:Microsoft Dynamics 365
原始 KB 編號: 4092736

徵狀

當您嘗試在 Microsoft Dynamics 365 中測試並啟用信箱時,您會收到下列錯誤:

「接收電子郵件時發生一般信箱存取錯誤。 信箱 <信箱名稱> 未同步處理。 已通知相關聯電子郵件伺服器配置檔配置檔 <名稱> 的擁有者。
Email 伺服器錯誤碼:套接字傳回例外狀況 TimedOut」。

如果您選取 [ 詳細資料] 區段,您可能也會看到更多詳細數據,例如下列文字:

「錯誤:System.Net.Sockets.SocketException (0x80004005) :連線嘗試失敗,因為連線方在一段時間后未正確回應,或已建立的連線失敗,因為連線的主機無法回應 <IP 位址><埠>
在 System.Net.Sockets.TcpClient.Connect (字串主機名,Int32 埠)
at Microsoft.Crm.Asynchronous.EmailConnector.Pop3Client.Connect () ”

原因

如果電子郵件伺服器配置檔 [進階] 區段內的埠值不正確,就會發生此錯誤。

解決方案

  1. 流覽至 [設定]Email [組態],然後選取 [Email 伺服器配置檔]

  2. 開啟信箱所使用的 Email 伺服器設定檔,以符合此錯誤。

    注意事項

    您也可以在錯誤訊息中選取 Email 伺服器設定檔的名稱。 它會顯示為超連結,這會開啟正確的 Email 伺服器配置文件記錄。

  3. 選取 [進階]

  4. 確認 [ 傳入埠 ] 和 [ 傳出埠 ] 值,然後選取 [ 儲存]

    注意事項

    請參閱電子郵件提供者的檔,以取得連線到 SMTP 服務時要使用的正確埠。 針對 Gmail,傳入 POP3 埠為 995,傳出 SMTP 埠為 587。

  5. 選取 [信箱] ,然後選取收到錯誤的信箱。

  6. 選取 [ 測試 & 啟用信箱] 按鈕。

  7. 測試完成之後,開啟信箱記錄,如果結果未顯示為成功,請檢視 [ 警示 ] 區段。

協力廠商資訊免責聲明

本文提及的協力廠商產品是由與 Microsoft 無關的獨立廠商所製造。 Microsoft 不以默示或其他方式,提供與這些產品的效能或可靠性有關的擔保。