很抱歉。 您的伺服器無法使用或不支援此應用程式。 在 iPad 或 iPhone 上連線到 CRM 應用程式時發生錯誤

本文提供將 iPhone 或 iPad 連線到 Dynamics CRM 應用程式時所發生錯誤的解決方案。

適用於:Microsoft Dynamics CRM 2013 Microsoft Dynamics CRM 2015
原始 KB 編號: 3069747

徵狀

嘗試將 iPhone 或 iPad 連線到 Dynamics CRM 應用程式時,您可能會收到錯誤:

「很抱歉。 您的伺服器無法使用或不支援此應用程式。」

原因

在 iPhone 或 iPad 上設定 CRM 應用程式時,某些外部證書頒發機構單位所產生的 SSL 憑證可能會有整個受信任憑證鏈結的問題。

其他相關資訊

透過 Web 應用程式存取 Microsoft Dynamics CRM 網站將會正確運作。 不過,在 iOS 裝置上,針對 AD FS 和 CRM 設定的 SSL 憑證可能會被視為不受信任。 使用使用UIWebViews和 WKWebViews 轉譯網頁的 iOS 應用程式時,您會看到類似的憑證相關錯誤。

iOS 裝置記錄會顯示:

驗證:驗證中斷。

當 SSL 憑證是整個網域的通配符憑證時,例如 *.contoso.com, 之類的 https://contoso.com 根域運作正常。 之類的 https://crm.contoso.com 子域無法如預期般運作。 這可能是因為與列出通配符主體別名的 iOS 裝置和憑證相容。 建議您使用其根層級包含CRM子域的憑證進行測試,例如 *.crm.domain.com