回退 App-V 伺服器升級時,可能會導致用戶端收到 xxxxxx-xxxxxx0A-00002002 錯誤

徵狀

當您將 Microsoft Application Virtualization (App-v)用戶端版本4.5 或更新版本連線到舊版的 Softgrid 伺服器(亦即執行4.5 之前的版本)時,您可能會收到下列錯誤:伺服器不允許連線且沒有有效的 NTLM 認證。請將下列錯誤碼報告給您的系統管理員。錯誤碼: xxxxxx-xxxxxx 0A-00002002

原因

如果您的 App-v 4.5 和4.6 用戶端連線到 app v 管理伺服器,而該應用程式是透過卸載 App-v 4.5 並重新安裝較舊的版本,就會發生這種情況。 這是因為在卸載 app-v 4.5 伺服器期間,不會移除 Spn (服務主要名稱)。 

解決方案

您可以輸入命令 belowsetspn hostname (其中 hostname 是 Softgrid 伺服器的名稱)來檢查這些 SPN 剩餘部分。[Spn] 會採用下列格式:-Softgrid/Hostname-Softgrid/FQDNIf Spn 都存在,您可以使用 SETSPN-D 命令來手動移除它們。

其他相關資訊

版本4.5 之前的 Softgrid 伺服器不支援 Kerberos 進行驗證。

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×