問題

將使用者的信箱從內部部署的 Microsoft Exchange Server 環境移至 Microsoft Office 365 之後,使用者就無法使用 Microsoft Outlook 存取信箱。 不過,使用者可以使用 Outlook Web App.In 存取信箱,在 Exchange 管理主控台中,您可能會看到類似下列的錯誤訊息:已失敗的遠端信箱移動:

<日期> <時間> [] <日期> <時間> [] 無法將來源信箱 [主要(00000000-0000-0000-0000-000000000000) \] 轉換為已啟用郵件功能的使用者。 嘗試6/6。 錯誤: UpdateMovedMailboxPermanentException。

原因

如果您在內部部署 Active Directory 架構中的目標使用者上停用許可權繼承,可能會發生這個問題。因此,即使使用者的內部部署信箱標示為在 Exchange 伺服器中移動,也不會如預期的方式轉換為遠端使用者信箱。 使用者的內部部署信箱會繼續包含一般已啟用信箱的使用者。

如果要解決這個問題,請依照下列步驟執行:

  1. 找出信箱上的所有使用者屬性,然後將此資訊儲存為文字檔。 若要這樣做,請開啟 Exchange 管理命令介面,然後執行下列命令:

    Get-Mailbox <UserMailbox> | fl | Out-File C:\UserMailbox.txt 
  2. 停用使用者的內部部署信箱。 若要解決此問題,請使用下列其中一種方法:

    • 使用 Exchange 管理主控台來停用使用者的內部部署信箱。

    • 使用 Exchange 管理命令介面來停用使用者的內部部署信箱。 若要這樣做,請執行下列 Exchange 管理命令介面命令:

      Disable-Mailbox <UserMailbox> 

      如需此 Cmdlet 的詳細資訊,請移至下列 Microsoft TechNet 網站:

      停用信箱

  3. 將使用者的內部部署信箱轉換為遠端使用者信箱。 若要這樣做,請執行下列 Exchange 管理命令介面 Cmdlet:Enable-RemoteMailbox -Identity <UserName> -RemoteRoutingAddress <UserName@domain.mail.onmicrosoft.com>

  4. 在已提供遠端信箱之後,請修改您想要且未由電子郵件地址原則指派給使用者帳戶的任何自訂信箱屬性(例如, legacyExchangeDN ] 屬性)。

其他相關資訊

注意: 在 Microsoft Exchange 2010 中,遠端信箱是由存在於內部部署 Active Directory 中的已啟用郵件的使用者以及存在於雲端服務中的相關信箱所組成。如需本文所述 Cmdlet 的詳細資訊,請移至下列 Microsoft TechNet 網站:

停用-信箱

Enable-RemoteMailbox

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