徵狀

當使用 [測試連線] 選項,從電子郵件伺服器的設定檔中的 Dynamics 365,測試就會失敗,您可能會看到類似下列的範例錯誤:

「 遠端伺服器錯誤: (401) 未經授權。請確定您輸入的密碼與使用者名稱無誤,然後再試一次。"

「 System.Net.WebException: 作業已經逾時 在 System.Net.HttpWebRequest.GetResponse() 在 Microsoft.Crm.Asynchronous.EmailConnector.ExchangeConnectivityDiscoverer.ValidateServerUrl (EmailDirectionCode emailDirection)"

原因

會造成 1:使用者名稱或密碼不正確。

會造成 2:如果您連線到 Exchange 先使用 Dynamics 365 (線上),如果您的防火牆不允許連線從 Dynamics 365 到您的 Exchange 伺服器時,會發生此錯誤。

會造成 3:在某些情況下,即使是正確的認證和連線沒有問題,可能會失敗測試連接。請參閱解決方案的一節中的解決方法 3。

解決方案

解決方式 1:請檢查使用者名稱和密碼是否正確。

注意: 使用者名稱值必須處於 UPN 格式。例如 username@contoso.com 而不是 contoso\username。

解決方法 2 : 如果您使用 Exchange 先使用 Dynamics 365 (線上),請確認您的防火牆允許連線的 IP 範圍記錄這裡包括參考的 Azure IP 範圍清單:

https://support.microsoft.com/help/2728473 

解析度 3:測試連接結果並不一定可靠。如果相同的使用者名稱和密碼的運作方式執行測試連接,從https://testconnectivity.microsoft.com時,使用中 Dynamics 365 測試與啟用信箱的選項,而非 [測試連線] 選項。如果測試及啟用您的信箱成功時,您可以忽略 [測試連接] 對話方塊的結果。

注意: 如果使用測試及啟用信箱] 按鈕時,發生任何失敗,請參閱信箱資料錄中的 [警示] 索引標籤,然後檢視 [所包含的任何 [說明] 連結。

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