無法在 Internet Explorer 中列印網頁或是檢視網頁的預覽列印

症狀

當您在 Internet Explorer 中嘗試列印網頁或是檢視網頁的預覽列印時,網頁無法列印或是無法正確預覽列印,且可能會收到指令碼錯誤。

原因

此問題可能是因為下列一或多個情況所造成:

案例 1: 您的視訊卡或視訊驅動程式已過期或損毀。 注意 過期或損毀的印表機驅動程式也可能會在從 Internet Explorer 列印時造成指令碼錯誤

案例 2: 系統可能未指派印表機權限給您

案例 3: 已啟用網頁的網際網路安全性區域的受保護模式

案例 4: 使用者帳戶的暫存資料夾發生問題,且 %TEMP% 位置下方的 [Low] 資料夾已刪除

解決方案

若要解決此問題,請依照順序執行下列方法。 如果方法 1 無法解決問題,請繼續執行下一個方法。

方法 1: 解決印表機問題,並將驅動程式更新到最新版本

完成下列教學單元,以協助您識別並修正 Windows 中常見的印表機問題:



過期的印表機驅動程式可能會在 Internet Explorer 列印時造成錯誤,請嘗試更新為最新的印表機驅動程式,如果要執行這項操作,請按一下您 Windows 版本的專屬連結,然後依照該文章中的步驟執行:







重要: 在某些情況下,可能無法透過 Windows Update 取得更新的驅動程式版本。 您可能必須移至製造商網站,尋找、下載和安裝最新的印表機驅動程式。

如果更新印表機驅動程式無法解決問題,請繼續進行方法 2。

方法 2: 嘗試以管理員身份列印運行 Internet Explorer 的網頁

嘗試在以系統管理員身份運行 Internet Explorer 時列印網頁;這有助於判斷是否存有權限問題。

  1. 開啟「日期和時間」對話方塊。

    1. 按一下 [開始]

    2. [開始搜尋] 方塊或 [搜尋程式及檔案] 方塊中輸入下列命令,然後按下 ENTER:

      timedate.cpl [日期和時間] 對話方塊隨即開啟。
      The Date and Time dialog box opens

  2. [日期和時間] 對話方塊中,按一下 [變更日期和時間][使用者帳戶控制] 對話方塊開啟後,請按一下[繼續]
    Click Change date and time in the Date and Time dialog box. When the User Account Control dialog box opens, click Continue.

  3. 現在,依據您按一下 [繼續] 時發生的狀況,執行下列其中一項操作:

    • 如果您的電腦並未提示您輸入密碼
      您已使用系統管理員帳戶登入。 按兩次 [取消] 以關閉 [日期和時間] 對話方塊,然後就可以準備繼續執行此工作。

    • 如果您的電腦提示您輸入密碼
      您未使用系統管理員帳戶登入。


注意 您必須使用具有系統管理員權限的帳戶,才能將帳戶類型從標準變更為系統管理員。

如果要以系統管理員身分啟動 Internet Explorer,請依照下列步驟執行:

  1. 關閉所有 Internet Explorer 視窗。

  2. 按一下 [開始],按一下 [所有程式],在 [Internet Explorer] 上按一下右鍵,並選取 [以系統管理員身分執行]。

  3. 瀏覽至網站,然後嘗試以系統管理員身分執行測試列印網頁。

如果以系統管理員身分執行 Internet Explorer 來列印網頁無法解決問題,請繼續進行方法 3。

方法 3: 停用保護模式後嘗試列印 嘗試在停用 [保護模式] 之後嘗試列印網頁,為此,請執行下列步驟:

  1. 按一下 Internet Explorer 中的 [工具] 圖示

  2. 按一下 [安全性] 標籤,然後取消選取 [啟用保護模式(需要重新啟動 Internet Explorer)] 旁邊的核取方塊

  3. 按一下 [套用],然後按一下 [確定]。

  4. 關閉所有開啟的 Internet Explorer 視窗,然後重新啟動 Internet Explorer。

  5. 瀏覽至網站,然後嘗試以系統管理員身分執行測試列印網頁。

如果停用受保護模式無法解決問題,請繼續進行方法 4。

  1. 關閉所有 Internet Explorer 執行個體。

  2. 按一下 [開始]windows icon,在 [開始搜尋] 方塊中輸入%Temp%,然後在清單中按一下 [Temp] 資料夾。

  3. 如果執行的是 Windows Vista,請按一下 [組織] 功能表上的 [新資料夾]

    如果執行的是 Windows 7,請按一下主功能表上的 [新資料夾]

  4. 為資料夾名稱輸入 Low,然後按下 ENTER。

  5. 關閉 Windows Explorer 視窗,啟動 Internet Explorer,然後列印或預覽列印網頁。


如果此方法無法解決問題,請繼續進行下一個方法。

  1. 依次按一下 [開始] windows icon[所有程式],然後按一下 [附屬應用程式]

  2. 以滑鼠右鍵按一下 [命令提示字元],然後按一下 [以系統管理員身分執行]

  3. 輸入下列命令並按下 ENTER:

    ICACLS "%userprofile%\AppData\Local\Temp\Low" /setintegritylevel (OI)(CI)low

  4. 重新啟動電腦。

  5. 列印或預覽列印 Internet Explorer 中的網頁。

其他相關資訊 如果是特定印表機製造商的列印問題,請按一下製造商的相關連結:

如果您已安裝特定 Canon 印表機驅動程式,則某些 Canon 印表機可能會發生此問題。 如需詳細資訊,請造訪下列 Microsoft 網站:

如需關於 Canon 印表機的協助,請造訪以下 Canon 網站:

印表機疑難排解教程:
如需可協助您找出和修正常見印表機問題的逐步教學課程,請造訪下列 Microsoft 網站:

要在嘗試於 Internet Explorer 中列印網頁時解決指令檔錯誤,請造訪以下 Microsoft 網站:

要自動掃描和修復列印問題及列印錯誤,請造訪以下 Microsoft 網站:

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×