檔案在設定 Microsoft Dynamics CRM for Microsoft Office Outlook 時已存在錯誤

本文提供您設定 Microsoft Dynamics CRM for Microsoft Office Outlook 時所發生錯誤的解決方案。

適用於:Microsoft Dynamics CRM Online、Microsoft Dynamics CRM 2016、Microsoft Dynamics CRM 2015、Microsoft Dynamics CRM 2013、Microsoft CRM client for Microsoft Office Outlook
原始 KB 編號: 3183053

徵狀

嘗試設定 Microsoft Dynamics CRM for Microsoft Office Outlook 時,您會收到下列錯誤:

「與 Microsoft Dynamics CRM 伺服器通訊時發生問題。 伺服器可能無法使用。 請於稍後再試一次。 如果問題持續發生,請連絡您的系統管理員。

檔案已經存在。 請嘗試使用不同的資料庫名稱。 [ 檔案名 = C:\Users\<USER>\AppData\Local\Microsoft\MSCRM\Client\MetadataCache-5243bc89-09f7-4d12-b578-8efd890f5d7c.sdf ]...”

原因

如果您的CRM實例已有先前組態中的資料庫檔案存在,就會發生此錯誤。

解決方案

選項 1 (CRM Online)

  1. 如果您使用 CRM Online,您可以執行 Microsoft 支援服務 和修復小幫手,這可為您修正此問題。
  2. 選擇 [Dynamics CRM Online ] 選項,然後選取 [ 我無法安裝、連線或啟用適用於 Outlook 的 CRM (Outlook 用戶端)
  3. 繼續進行精靈。 [移除 CRM for Outlook 的快取檔案] 動作應該會出現,並且會移除錯誤中參考的現有檔案。
  4. 再次執行 Microsoft Dynamics CRM 組態精靈。

選項 2 (手動)

如果您不是使用CRM Online,或想要手動修正問題,請完成下列步驟。

  1. 關閉 Outlook。

  2. 開啟 Windows 檔案總管並瀏覽至 <install directory>:\Users\<Your User>\AppData\Local\Microsoft\MSCRM\Client

    範例:C:\Users\<username>\AppData\Local\Microsoft\MSCRM\Client

    注意事項

    根據預設,AppData 資料夾是隱藏的。 您可以變更 [檢視] 設定以顯示 [隱藏的專案],也可以將下列路徑複製並貼到資料夾路徑中:
    %localappdata%\Microsoft\MSCRM\Client

  3. 刪除錯誤詳細數據中參考的檔案。

  4. 再次執行 Microsoft Dynamics CRM 組態精靈。