在 2011 Microsoft Dynamics CRM 開啟特定檢視時,數據表別名別名名稱不是唯一的

本文提供在 2011 Microsoft Dynamics CRM 更新匯總 12 之後,您可能無法開啟檢視的問題解決方案。

適用於:Microsoft Dynamics CRM 2011 年
原始 KB 編號: 2907665

徵狀

使用者可能無法在更新匯總 12 之後開啟檢視。 當進階尋找檢視類型的檢視修改為將相關實體的欄位新增至顯示數據行時,就會發生此問題。 問題可透過「現用」或自定義實體來識別。

原因

修改檢視時,鏈接實體節點可以使用兩次。 但對於單一類型的鏈接實體節點,它只能使用一次。

解決方案

安裝 Microsoft Dynamics CRM 2011 更新匯總 15 可解決安裝更新匯總 15 之後修改之檢視的問題。 安裝擲回錯誤的更新匯總 15 之前所識別的現有檢視必須手動修正。

以下範例示範如何修正現有中斷檢視上的問題:

其說明如何重現問題:

  1. 流覽至 [設定],選取 [自定義],選取 [自定義系統],指向 [ 實體],選取 [ 帳戶],然後選取 [ 檢視]
  2. 啟 [帳戶進階尋找檢視] ,然後選取 [ 新增數據行]
  3. 在 [記錄類型] 下拉式清單 (選取 [聯繫人) 相關實體]。
  4. 核取 [ 全名 ] 旁的複選框,然後選取 [ 確定]
  5. 取 [儲存 並關閉]。
  6. 取 [發佈所有自定義]
  7. 開啟 [非使用中帳戶] 檢視,然後選取 [編輯篩選準則]
  8. 新增/修改/刪除任何篩選準則 (將 Status = Inactive 變更為 Status = Active) ,選取 [ 確定 ],然後選取 [ 儲存 並關閉]。
  9. 取 [發佈所有自定義]
  10. 同樣地,在 [ 非使用中帳戶] 檢視中,選取 [ 編輯篩選準則 ],然後新增/修改/刪除任何篩選準則 (將 [狀態 = 作用中] 變更為 [狀態 = 非作用中) 。
  11. 選取 [確定]
  12. 取 [儲存 並關閉]。
  13. 取 [發佈所有自定義]
  14. 移至 [進階尋找],然後選取 [尋找:] 下拉式清單中的 [帳戶],然後在 [使用已儲存的檢視] 下拉式清單中選取 [非作用中帳戶]。
  15. 選取 [結果]

以下是修正問題的方式 (使用上述用來重現問題的範例) :

  1. 啟動CRM 2011應用程式。

  2. 流覽至 [ 設定],指向 [ 自定義],然後選取 [ 解決方案]

  3. 建立新的解決方案,並將帳戶實體新增至其中,而不需新增任何相依性。

  4. 現在儲存解決方案,並將其匯出為非受控解決方案。

  5. 儲存 Unmanaged 方案 zip 檔案之後,請解壓縮檔案。

  6. 在 Visual Studio 2012 等 XML 編輯器中開啟 customizations.xml 檔案,然後選取鍵盤上的 CTRL+M+M 以折疊完整的 XML。

  7. 搜尋擲回錯誤的檢視名稱。 在此情況下,它是 非作用中的帳戶 ,而且在整個檔案中只會出現一次。

  8. 它只會在 XML 中展開一個已儲存的查詢。

  9. 在本節中,展開 <fetchxml> 項目並尋找 <Link-entity>

  10. 您會看到下列 XML 重複:

    <link-entity name="contact" from="contactid" to="primarycontactid" visible="false" link- type="outer" alias="a_410707b195544cd984376608b1802904">
    
    <attribute name="fullname" />
    
    <attribute name="emailaddress1" />
    
    </link-entity>
    

    它應該只會出現一次。

  11. 從customizations.xml 檔案中移除這個 XML 的一個專案,並儲存變更。

  12. 現在,使用已編輯的 customizations.xml[content_Types].xml 和solution.xml,再次壓縮檔案。

  13. 將此 zip 檔案匯入 CRM 應用程式,併發布所有自定義。

  14. 它會修正帳戶非作用中檢視的問題。 這可讓您修正擲回此錯誤的所有其他檢視。