使用 Server-Side 同步處理時,Smtp 伺服器傳回 530 MustIssueStartTlsFirst 例外狀況

本文可協助您修正在 Microsoft Dynamics 365 中搭配 POP3/SMTP 配置檔使用 Server-Side 同步處理時,收到「Smtp 伺服器傳回 530 MustIssueStartTlsFirst 例外狀況」錯誤的問題。

適用於:Microsoft Dynamics CRM 2016 年
原始 KB 編號: 3214706

徵狀

當您在先前稱為 Dynamics CRM Online) Dynamics 365 (中測試和啟用信箱時,您會在 [警示] 區域中遇到下列其中一個錯誤:

無法傳送電子郵件訊息「測試訊息」,因為建立與電子郵件伺服器的安全連線時發生錯誤。 信箱 <信箱名稱> 未同步處理。 已通知電子郵件伺服器設定檔 Email 伺服器設定檔<名稱>的擁有者。

Email 伺服器錯誤碼:Smtp 伺服器傳回 530 MustIssueStartTlsFirst 例外狀況。

ActivityId: <GUID>
>錯誤:System.Net.Mail.SmtpException:SMTP 伺服器需要安全連線,或用戶端未通過驗證。 伺服器回應為:需要 5.5.1 驗證。 深入瞭解
在 System.Net.Mail.SendMailAsyncResult.End (IAsyncResult 結果)
在 System.Net.Mail.SmtpTransport.EndSendMail (IAsyncResult 結果)
在 System.Net.Mail.SmtpClient.SendMailCallback (IAsyncResult 結果)

無法為信箱<接收 Email信箱名稱>。 請確定信箱中指定的認證正確無誤,而且有足夠的許可權可接收電子郵件。 然後,啟用信箱以進行電子郵件處理。

無法為信箱<接收 Email信箱名稱>。 請確定信箱中指定的認證正確無誤,而且有足夠的許可權可接收電子郵件。 然後,啟用信箱以進行電子郵件處理。

原因

如果您使用 POP3/SMTP 電子郵件伺服器設定檔,且存在下列其中一個問題,就會發生此錯誤:

  1. 用戶名稱或密碼不正確。
  2. 如果您使用 Gmail,則會停用允許較不安全應用程式的選項。

解決方案

  1. 確認信箱記錄上的 [用戶名稱] 和 [密碼] 值是否正確 Dynamics 365。 此錯誤包含 Dynamics 365 中信箱記錄的連結。

  2. 如果您使用 Gmail,請確認已啟用 [ 允許較不安全的應用程式 ] 選項:

    Google 帳戶 & 較不安全的應用程式

變更上述任何設定之後,再次按下信箱記錄上的 [ 測試 ] 和 [ 啟用 ]。

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