Microsoft Dynamics CRM 2011 Outlook 用戶端無法設定外部 IFD 網址

狀況

當 Microsoft Dynamics CRM 2011年部署設定的網際網路面向部署 (IFD) 使用使用中目錄的憑證服務 」 (ADF) 時,使用者可能會收到下列錯誤,當您嘗試設定外部的網址 Microsoft Dynamics CRM Outlook 用戶端時︰

「 無法連線到 Microsoft Dynamics CRM 伺服器因為我們無法驗證您的認證。檢查您的連線或連絡您的管理員以獲得協助 」。

檢閱時設定記錄檔,則下列的例外狀況也會擷取︰

連線至的 URL 時發生錯誤︰ https://crmorg.domain.com/XRMServices/2011/Discovery.svc 例外狀況︰ System.ServiceModel.EndpointNotFoundException︰沒有任何 http://adfs.domain.com/adfs/services/trust/13/username,可以接受該訊息在接聽的端點。

不過,使用者仍然可以存取的外部 URL,透過 web 瀏覽器不會發生錯誤。

原因

可能啟用 /adfs/services/trust/13/username 端點。當啟用此端點時,用戶端將無法到達的 usernamemixed 和 kerberosmixed 的結束點,這會導致驗證失敗。

解決方案

停用 /adfs/services/trust/13/username 端點,並重新啟動 ADFS 服務。如果要執行這個動作,請參閱下面步驟︰

  1. 開啟的AD FS 管理主控台

  2. 在左邊的瀏覽] 窗格中,展開 [服務],然後按一下端點。

  3. 在 [結束點] 清單中,找出,並以滑鼠右鍵按一下/adfs/services/trust/13/username端點

  4. 選取 [停用

  5. 重新啟動 AD FS 服務。


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