Unable to customize form for published content types

Symptoms

Unable to customize form on a list that has a default content type published from a content type hub.

Cause

When you publish a content type from a content type hub, the content type gets marked as Read-Only on the destination site. This causes you not to be able to use the customize form button on the list as it will generate the following error:

Customizing the form for this content type is not supported"

Resolution

On the destination site where you published the content types, follow these steps:

1. Open the list with the published content type
2. Click on the "List" menu in the ribbon
3. Click on "List Settings"
4. In the content type section click on the content type you want to create a customized form for
5. Click on advanced settings under the Settings menu
6. Set the option "Should this content type be read only?" to 'No'
7. Click OK on the popup
8. Click OK on the advanced settings page
9. Browse back to the list

You should now be able to use the Customize Form button successfully.

內容

文章識別碼:2717706 - 最後檢閱時間:2012年6月13日 - 修訂: 1

意見反應