由於 RPC 加密要求,Outlook 與 Exchange 郵箱的連接問題

適用於: Exchange Server 2016 Enterprise EditionExchange Server 2016 Standard EditionExchange Server 2013 Enterprise

本文僅適用于由 RPC 加密要求引起的 Outlook 連接問題。
關於 RPC 加密選項的螢幕截圖

徵狀


當您使用在運行 Microsoft Exchange Server 2010、微軟 Exchange 伺服器 2013 或 Microsoft Exchange Server 2016 的伺服器上包含郵箱的設定檔啟動 Microsoft Office Outlook 時,您可能會收到以下錯誤訊息:
無法啟動 Microsoft Office Outlook。無法打開 Outlook 視窗。無法打開資料夾集。
無法打開預設電子郵件資料夾。微軟 Exchange 伺服器電腦不可用。要麼存在網路問題,要麼 Microsoft Exchange 伺服器電腦停機進行維護。
與 Microsoft Exchange 伺服器的連接不可用。Outlook 必須連線或已連接才能完成此操作。
無法打開預設電子郵件資料夾。無法打開資訊存儲。
Outlook 無法登錄。檢查以確保已連接到網路並使用正確的伺服器和信箱名稱。與 Microsoft Exchange 伺服器的連接不可用。Outlook 必須連線或已連接才能完成此操作。
此外,如果您使用的是緩存的模式設定檔,Outlook 不會顯示錯誤。相反,您可能會遇到以下症狀:
  • Outlook以"已中斷連線"狀態啟動(Outlook 視窗的右下角顯示"已中斷連線",狀態的螢幕截圖如下所示)。
    Outlook 視窗右下角的螢幕截圖
  • Outlook 啟動,您可以發送和接收電子郵件。但是,在"Microsoft Exchange 連接狀態"中只看到兩個連接,您可能會看到"類型目錄"顯示為"已中斷連線/已連接"。
    此症狀的螢幕截圖
當您嘗試為運行 Exchange 2010 或 Microsoft Exchange Server 2013 的伺服器上的郵箱創建新的 Outlook 設定檔時,您可能會收到以下錯誤訊息:
無法完成該操作。與 Microsoft Exchange 伺服器的連接不可用。Outlook 必須連線或已連接才能完成此操作。
無法解析名稱。與 Microsoft Exchange 伺服器的連接不可用。Outlook 必須連線或已連接才能完成此操作。
Outlook 無法登錄。檢查以確保已連接到網路並使用正確的伺服器和信箱名稱。與 Microsoft Exchange 伺服器的連接不可用。Outlook 必須連線或已連接才能完成此操作。
無法解析名稱。無法完成該操作。
無法解析您的伺服器或信箱名稱。

解決方案


備註如果使用的是自動化方法之一(群組原則或 .prf 檔),請確保在大規模部署該方法之前對其進行完全測試。

方法 1:使用 RPC 加密更新或創建 Outlook 設定檔

手動更新現有設定檔

要手動更新現有 Outlook 設定檔,使其使用 RPC 加密,請按照以下步驟操作:
  1. 在"控制台"中,打開"郵件"專案。
  2. 選擇"顯示設定檔"。
  3. 選擇您的個人資料,然後按一下"屬性"。
  4. 選擇"電子郵件帳戶"。
  5. 選擇Microsoft Exchange(預設情況下從此帳戶發送)帳戶 >更改
  6. 在包含郵箱伺服器和使用者名的對話方塊中,選擇"更多設置"。
  7. 在"微軟交換"對話方塊中,選擇"安全"選項卡。
  8. 選擇"加密 Microsoft Office Outlook 和 Microsoft Exchange > OK"之間的資料(可在此處看到此步驟的螢幕截圖)。
    此步驟的螢幕截圖
  9. 選擇"下一步>完成"。
  10. 選擇"關閉>關閉>確定"。

部署群組原則設置以使用 RPC 加密更新現有 Outlook 設定檔

從用戶端的角度來看,部署 Outlook-Exchange 加密設定可能是具有許多 Outlook 用戶端的組織最簡單的解決方案。此解決方案涉及伺服器上的單個更改(網域控制站),並且用戶端在將策略下載到用戶端後會自動更新。

方法 2:禁用所有 CAS 伺服器上的加密要求

重要Microsoft 強烈建議您在伺服器上保持加密要求,並使用本文中列出的其他方法之一。本文僅針對無法立即在 Outlook 用戶端上部署必要的 RPC 加密設定的情況提供了方法 2。如果使用方法 2 允許 Outlook 用戶端在沒有 RPC 加密的情況下進行連接,請儘快在 CAS 伺服器上重新啟用 RPC 加密要求,以保持最高級別的用戶端到伺服器通信。要禁用 Outlook 和 Exchange 之間所需的加密,請按照以下步驟操作:
  1. 在 Exchange 管理命令程式中運行以下命令:
    Set-RpcClientAccess –Server <Exchange server name> –EncryptionRequired:$False 
    備註Exchange_server_name預留位置表示具有用戶端存取伺服器角色的 Exchange 伺服器的名稱。 您必須為運行 Exchange Server 2010 或更高版本的所有用戶端存取伺服器運行此 Cmdlet。
  2. 為具有用戶端存取伺服器角色的每個 Exchange 伺服器重新運行此命令。該命令還需要在包含公用資料夾存儲的每個郵箱伺服器角色上運行。來自 MAPI 用戶端的公用資料夾連接直接轉到郵箱伺服器上的RPC 用戶端存取服務。
  3. 使用啟用與 Exchange 的加密 RPC 通信的設置更新 Outlook 用戶端後(請參閱下面提供的步驟),您可以在具有用戶端存取伺服器角色的 Exchange 伺服器上重新啟用 RPC 加密要求。 要在具有用戶端存取伺服器角色的 Exchange 伺服器上重新啟用 RPC 加密要求,請在 Exchange 管理命令程式中運行以下命令:
    Set-RpcClientAccess –Server <Exchange server name> –EncryptionRequired:$True –EncryptionRequired:$True 
    備註Exchange_server_name預留位置表示具有用戶端存取伺服器角色的 Exchange 伺服器的名稱。 您必須為運行 Exchange Server 2010 或更高版本的所有用戶端存取伺服器運行此 Cmdlet。

原因


其中一個可能的原因是您正在使用 Microsoft Office Outlook,並且禁用了 Microsoft Office Outlook 和 Microsoft Exchange 設定檔設置之間的加密資料。Exchange Server 2013 的預設配置要求來自 Outlook 用戶端的 RPC 加密,這可以防止用戶端進行連接。備註預設的 Exchange 伺服器 2010 版本到製造 (RTM) 配置需要 RPC 加密。此行為是 Microsoft Exchange Server 2010 服務包 1 的更改,預設情況下禁用 RPC 加密要求。但是,在 Service Pack 1 之前部署或升級到 Service Pack 1 的任何用戶端存取伺服器 (CAS) 將保留現有的 RPC 加密要求設置,該設置仍可能阻止用戶端進行連接。