如何使用合併列印功能在 Word 中,若要建立,然後列印使用 Excel 工作表之資料的套印信件


摘要


本文說明如何建立和使用 Microsoft Excel 工作表的資料來列印套印信件,請在 [Microsoft Word 中使用合併列印功能。

當您使用 Word 合併列印功能時,Word 會將與收件者清單來產生一組輸出文件主文件合併:
  • 主文件會包含基本的輸出文件中的所有相同的文字。它可能包含信紙信頭、 文字和中來插入文字 (例如收件者姓名和地址) 的合併欄位到另一個不同輸出文件而異的指示進行。
  • 收件者的清單是包含要合併到輸出文件的資料的資料庫。例如,收件者的清單是 Microsoft Access 資料庫檔案或 Excel 工作表。

    此資料庫通常是一份名稱、 地址、 電話號碼,以及其他的個人資訊的類別。
  • 輸出文件是合併列印的結果。輸出文件中的文字可以在所有的輸出文件相同,但您可以將格式套用至特定的文件。

步驟 1: 設定 Excel 資料檔案

繼續進行合併列印精靈之前,請確定,您的 Excel 工作表完善,適合此用途。請注意資料表的下列需求:
  • 第一列應該包含欄位名稱的每個資料行中-例如,標題、 問候語、 名字、 中間名、 姓氏、 Address1 及地址 2。
  • 每個欄位名稱必須是唯一的。
  • 每個資料列應該提供特定項目的相關資訊。例如,在郵件清單中,每個資料列可能包括特定的收件者的相關資訊。
  • 資料表應包含不得有空白列。
建立 Excel 資料檔案,並再加以排列,使用您想要使用您的信件,如下列的範例資料檔案中所示的欄位。

建立 Excel 資料檔案之後,儲存,然後關閉資料檔案。

如需有關如何建立 [合併列印通訊清單的詳細資訊,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文件:

294688如何設計及設定在 Word 2002 和更新版本的 Word 中的 [合併列印通訊清單

步驟 2: 設定主文件

  1. 在 Microsoft Office Word 2003 和舊版的 Word 中,指向 [工具] 功能表中,[信件與郵件,,然後按一下 [合併列印精靈

    在 Microsoft Office Word 2007 中,按一下 [郵件] 索引標籤上的 [啟動 [合併列印] 群組中的 [啟動合併,然後按一下Step by Step 由 [合併列印精靈
  2. 按一下 [選取文件類型] 底下的 [信件]。

    使用中文件就會變成主文件。主文件包含的文字和圖形合併的文件的每個版本的相同。例如,回覆地址和問候語套印信件中的也適用於每個版本。
  3. 按一下 [下一步: 開始文件
  4. 使用下列方法之一:
    • 目前文件視窗中顯示的文件的開頭。若要這麼做,請按一下 [使用目前的文件]。

      您可以接著在文件視窗中鍵入的字母或等到精靈會提示您執行這項操作在接下來的步驟。
    • 從範本開始。若要執行這項操作,請參考下列步驟:
      1. 按一下 [從範本開始]。
      2. 按一下 [選取範本
      3. [合併列印] 索引標籤中,選取 [選取範本] 對話方塊中您想要的範本,然後按一下[確定]
    • 現有的文件的開頭。若要執行這項操作,請參考下列步驟:
      1. 按一下 [從現有的文件開始]。
      2. 在 [自現有啟動] 方塊中,選取您想要的選項,文件,然後按一下 [開啟
      3. 如果看不到文件,請按一下 [更多檔案,然後按一下 [開啟。在 [開啟] 對話方塊中,找出您想要的選項,文件,然後按一下 [開啟
  5. 按一下 [下一步: 選擇收件者

步驟 3: 指定 Excel 資料來源

  1. 按一下 [選取收件者] 底下的 [使用現有清單]。
  2. 按一下 [瀏覽]。
  3. 在 [選取資料來源] 對話方塊中,找出,然後按一下您想要使用的 Excel 工作表。

    根據預設,Word 會開啟 「 我的資料來源] 資料夾。
  4. 按一下 [開啟]。
  5. 如果 Excel 工作表包含多個索引標籤的相關資訊,請選取包含您想要的選項,使用的資訊] 索引標籤,然後按一下[確定]
  6. 資料來源中的所有項目會出現在[合併列印收件者] 對話方塊中。在這裡,您也可以改善合併中要包含的收件者清單。

步驟 4: 選取收件者

  1. [合併列印收件者] 對話方塊中,選取您想要包含的收件者。若要這樣做,請使用下列其中一種方法:
    • 您可以使用 [核取方塊來指定收件者。

      這個方法是最有用,如果是簡短的清單。按一下以選取您想要包含,收件者旁邊的核取方塊,然後按一下以清除您想要排除的收件者旁邊的核取方塊。

      注意如果您知道想要大部分清單納入合併,請按一下 [全選],然後按一下以清除特定記錄。同樣地,如果您想要包含少許的記錄清單中,按一下 [全部清除],然後選取您想要的記錄。
    • 排序清單中的項目。

      這個方法是很有用,如果您想要查看依字母或數字順序的項目。按一下您想要排序的項目之欄位標題。例如,如果您想要依姓氏的字母順序顯示清單中,按一下 [姓氏] 欄標題。
    • 篩選清單中的項目。

      這個方法會很有用,如果清單中包含您知道您不想要查看或納入合併的記錄。在篩選清單之後,您可以使用核取方塊,來包含或排除記錄,如先前所述即可。若要篩選清單,請依照下列步驟執行:
      1. 按一下您要據以篩選的項目之欄位標題旁邊的箭號。
      2. 按一下下列其中一項:
        • (空白): 這個選項會顯示對應的欄位是空白的所有記錄。
        • (非空白): 這個選項會顯示其中對應欄位包含資訊的所有記錄。
        • 如果資料來源包含共用相同的資訊,記錄,且資料行中有 10 個或更少的唯一值,您可以篩選由特定的資訊。例如,如果它們都列出澳大利亞作為國家/地區有多個地址,您可以篩選由澳洲
    • [合併列印收件者] 對話方塊會顯示指定的記錄。若要再次顯示所有記錄,請按一下 [ (全部)]。
    注意事項
    • 進行進階排序或篩選,請按一下任何資料行名稱] 旁的箭號,,然後按一下 [ (進階)]。若要設定排序或篩選您要的查詢中使用 [篩選] 及 [資料排序記錄] 索引標籤。
    • 如果您已安裝地址驗證軟體,請按一下 [驗證[合併列印收件者] 對話方塊來驗證收件者的地址。
  2. 按一下[確定]回到 [合併列印精靈]。

    Word 會使用您指定的收件者進行合併。
  3. 按一下 [下一步: 撰寫信件

步驟 5: 完成信件,並將合併欄位

如果您尚未這樣做,請輸入您想要出現在每個的套印信件主文件中的文字。

插入合併欄位

將想要合併名稱、 地址及其他資訊,從資料來源的合併欄位。若要插入合併欄位,請依照下列步驟執行:
  1. 在主文件中,按一下您想要插入欄位的位置。
  2. 插入下列其中一項:
    • 使用名稱、 地址和其他資訊的地址區塊:
      1. 按一下 [地址區塊]。
      2. 在 [插入地址區塊] 對話方塊中,選取您想要包含的地址元素及所需格式,,然後按一下[確定]。如需某個選項的說明,請按一下問號,,,然後按一下 [選項。

      3. 如需某個選項的說明,請按一下問號,,,然後按一下 [選項。如果 [符合欄位] 對話方塊出現時,Word 可能找不到某些地址區塊所需要的資訊。接下來按一下箭號
        (不適用),然後選取您對應到 [合併列印所需之欄位的資料來源中的欄位。
    • 招呼語列:
      1. 按一下 [祝賀行]。
      2. 選取祝賀行格式,包括問候語、 名稱格式以及後續的標點。
      3. 選取您想要在其中,Word 無法解譯收件者名稱的情況下顯示的文字。例如,Word 無法解譯的名稱,當資料來源包含沒有姓氏或名字,收件者,但只包含公司名稱。
      4. 按一下 [確定]
      5. 如果 [符合欄位] 對話方塊出現時,Word 可能找不到某些所需問候行資訊。按一下 [ (不適用),旁邊的箭號,然後從您對應到 [合併列印所需之欄位的資料來源中選取的欄位。
    • 其他資訊欄位:
      1. 按一下 [更多的項目
      2. 使用下列方法之一:
        • 按一下以選取從會自動對應到相對應的欄位,在您的資料來源中的地址欄位,即使資料來源的欄位不一定相同的名稱與您的欄位的地址欄位]。
        • 按一下以選取的欄位,都需要在資料庫中的 [直接從資料行的資料的資料庫欄位]。
      3. 在 [欄位] 方塊中,按一下您想要的欄位。
      4. 按一下 [插入],然後按一下 [關閉]。
      5. 如果 [符合欄位] 對話方塊出現時,Word 可能無法找到一些所需插入欄位的資訊。按一下 [ (不適用),旁邊的箭號,然後從您對應到 [合併列印所需之欄位的資料來源中選取的欄位。

        注意如果您從資料庫欄位] 清單中,插入一個欄位,而且如果您稍後切換到沒有相同名稱的資料行的資料來源時,Word 無法將該欄位資訊插入合併的文件。
    • 電子郵資:

      若要新增電子郵資,您必須先安裝電子郵資程式,例如您可以從 Web 上的第三方提供者購買的其中一個程式。若要使用電子郵資,請依照下列步驟執行:
      1. 按一下 [電子郵資]。

        如果您沒有安裝電子郵資程式,會提示您安裝其中一個,and 提議您連線到下列的 Microsoft Office Web 網站:
      2. 插入電子郵資,根據程式的指示。
    • 若要新增電子郵資,您必須先安裝電子郵資程式,例如您可以從 Web 上的第三方提供者購買的其中一個程式。若要使用電子郵資,請依照下列步驟執行: 郵件條碼: 您必須選取支援 POSTNET 條碼的字母或信封類型。若要使用郵件條碼,請依照下列步驟執行:
      1. 按一下 [郵件條碼]。
      2. 在 [插入郵件條碼] 對話方塊中,選取適當的地址欄位。

        注意 [郵件條碼] 選項,僅會在您使用英文版的 Word 時出現。
      3. 重複步驟和所有您想要插入的欄位 b。附註
        • 您不能輸入合併欄位字元 ("") 或使用 [插入] 功能表上的 [符號] 指令來插入這些。
        • 如果出現如 {MERGEFIELD 縣/市},大括號內的合併欄位 Word 顯示功能變數代碼,而不是功能變數結果。這不會影響合併,但如果您想要顯示其結果,以滑鼠右鍵按一下功能變數代碼,然後按一下快顯功能表上的 [切換功能變數代碼
      例如,藉由使用前面所示的範例資料庫,您的信件,可能會包含 [時會括在箭頭 」 和 「 祝賀] 欄位中,而因此您第一頁就會出現類似下列:
      2002 年 2 月 26 日

      時會括在箭頭

      祝賀

      輸入您的信件。

      敬祝商琪,

      輸入您的名稱

    注意您也可以使用[合併列印] 工具列來插入合併欄位、 使用 [合併列印主文件,或者執行合併列印。若要顯示[合併列印] 工具列,指向 [工具] 功能表中,[信件與郵件] ,然後按一下 [顯示合併列印工具列


    [合併列印] 工具列提供不會包含在合併列印精靈] 工作窗格中的其他命令。例如,您可以使用[合併列印] 工具列上的 [插入 Word 功能變數] 功能表,插入 Word 功能變數來控制合併處理序。例如,您可以插入 IF 功能變數,在特定合併欄位具有指定的值時,才插入文字。

    或者,您可以按一下 [檢查錯誤,才能讓 Word 執行合併列印並報告所包含的任何錯誤主文件中。

變更合併資料的格式

若要格式化合併的資料,您必須在主文件中的合併欄位格式化。不要格式化的資料來源中的資料,因為它的格式設定時不會保留您的資料合併到文件。若要變更合併資料的格式,請依照下列步驟執行:
  1. 在主文件中,選取包含您要格式化的資訊的欄位,包括封入的合併欄位字元 (<> <>)。
  2. 在 Word 2003 和舊版的 Word 中,請按一下 [字型],請在 [格式] 功能表上,然後選取您想要的選項。

    在 Word 2007 中,按一下 [首頁] 索引標籤上的 [字型] 群組中的 [佈景主題字型] 方塊中您想要的選項。

使用功能變數代碼的格式

若要控制其他方面的格式,請按 ALT + F9 以顯示功能變數代碼,然後再新增參數的合併欄位。當您使用欄位時,參數是會導致發生的特定動作的特殊別指令。一般而言,交換器會新增至欄位來修改結果。

如何使用參數的範例如下所示:
  • 若要顯示為$ 34,987.89的數字的34987.89 ,新增數值顯示格式參數 (\ #)。
  • 如果要列印用戶端名稱以大寫的字母,請新增格式參數 (\ *)。
  • 如果要確定合併的資訊都有相同的字型和您將套用至合併欄位的點數大小,請新增 Charformat 參數 (\ *)。

步驟 6: 儲存文件

在完成主文件並插入所有合併欄位之後,請確定您已儲存文件,再繼續。若要執行這項操作,請參考下列步驟:
  1. 在 Word 2003 和舊版的 Word 中,請按一下 [檔案] 功能表 [另存新檔]。

    在 Word 2007 中,按一下Microsoft Office] 按鈕,,然後按一下 [另存新檔
  2. 命名的文件,然後按一下 [儲存
  3. 按一下 [下一步: 預覽信件

步驟 7: 預覽信件並修改以調整收件者清單

當精靈顯示 [步驟 5 郵件合併] 工作窗格時,「 精靈 」 會取代每個合併欄位,在主文件中有實際的文字從收件者清單中的第一個項目。因此,您可以看到第一個的輸出文件的外觀。

例如,如果您要繼續使用前面所示的範例資料庫,第一頁看起來應該像下列網頁在您按下後下一步: 預覽信件:
2002 年 2 月 26 日

安德路福樂
908 工時首都的方法
Tacoma 98401

親愛的安德路福樂

輸入您的信件。

敬祝商琪,

輸入您的名稱
若要預覽其他項目,請使用下列方法之一:
  • 若要預覽順序中的項目,請按一下向左或向右鍵按鈕。
  • 若要尋找並預覽特定的項目,按一下 [尋找收件者],然後在 [尋找項目] 對話方塊中輸入搜尋準則。
如果您想要請修改以調整收件者的清單。若要這樣做,請使用下列其中一種方法:
  • 若要從合併列印作業中排除特定的收件者,請按一下 [排除此收件者]。
  • 若要變更收件者清單,請按一下 [編輯收件者清單],然後在[合併列印收件者] 對話方塊中進行變更。

步驟 8: 完成合併

若要完成合併時,使用下列方法之一。

個人化個別信件

若要個人化個別項目,您可以真正完成合併,並再編輯產生的合併文件中您想要的資訊。若要執行這項操作,請參考下列步驟:
  1. 按一下 [編輯個別信件]。
  2. 在 [合併到新的文件] 對話方塊中,選取您想要合併的記錄。
  3. 按一下 [確定]

    Word 會建立,並開啟新的合併文件。主文件仍然保持開啟,而且如果您想要變更的所有文件,您可以切換回它。
  4. 捲動到想要編輯,然後進行變更的資訊。
  5. 列印或儲存文件,就像對一般文件一樣。

列印信件

若要列印信件,請使用下列方法之一:
  • 如果您的個人化項目,且合併的文件正在使用中,請依照下列步驟執行:
    1. 在 Word 2003 和舊版的 Word 中,請按一下 [檔案] 功能表上的 [列印]。

      在 Word 2007 中,按一下 [ Microsoft Office] 按鈕,再列印
    2. 選取您想要的選項。
  • 如果您想要直接從 [合併列印精靈列印,請依照下列步驟執行:
    1. 在步驟 6 中的 [合併列印精靈 ([完成合併),按一下 [列印]。
    2. 在 [合併到印表機] 對話方塊中,使用下列方法之一,然後按一下[確定]:
      • 若要列印所有文件,按一下 [所有]。
      • 若要列印的文件,您看到文件視窗中,按一下 [目前的記錄]。
      • 若要列印文件範圍,請按一下 [],然後在 [ FromTo ] 方塊中鍵入記錄編號。
    3. 在 [列印] 對話方塊中,選取您想要的選項。

儲存供稍後使用的合併的信件

如果您想要編輯合併的信件,或將它們儲存以供日後使用,您可以將信件集中到一份文件。若要執行這項操作,請參考下列步驟:
  1. 按一下 [編輯個別信件]。
  2. 在 [合併到新的文件] 對話方塊中,使用下列方法之一,然後按一下[確定]:
    • 要合併所有文件,請按一下 [全部]。
    • 要合併您在文件視窗中看到的文件,請按一下 [目前的記錄]。
    • 若要合併的文件的範圍,請按一下 [],然後在 [ FromTo ] 方塊中鍵入記錄編號。
  3. Word 會開啟一份新文件包含所有個別的字母。然後,您可儲存文件以供日後使用,就像對一般文件一樣。

參考


如需詳細資訊,按一下下面的文件編號,以檢視「Microsoft 知識庫」中的文件:

318117如何在 Word 中建立標籤時,用於從 Excel 工作表的地址

318115如何使用 Word 2002 中從 Access 資料庫的資訊建立套印信件

318112如何在 Word 2002 中建立標籤時,用於從 Access 2002 資料庫的地址

294686如何使用 [合併列印建立依類別在 Word 2002 和更新版本的 Word 中排序的清單

290408有關在 Word 2002 中的 [合併列印的常見問題集

294688如何設計及設定在 Word 2002 和更新版本的 Word 中的 [合併列印通訊清單

294693如何使用合併列印功能在 Word 2002 和更新版本的 Word 中建立目錄

294683如何使用合併列印功能在 Word 2002 和更新版本的 Word 中建立套印信件