在 2019 年 1 月 8 日左右大量授權的 Windows 7 KMS 客户端上出現啟動失敗和「非正版」通知

適用於: Windows 7 ProfessionalWindows 7 Enterprise

摘要


本文適用於使用金鑰管理服務 (KMS)並且安裝 KB 971033更新之大量授權 Windows 7 裝置。 從 2019年 1 月 8 日 10:00 UTC 起,某些用户可能會收到 Windows 啟用或「windows 不是正版」通知。

2019 年 1 月 9 日, 我们還原了對 Microsoft 啟動和驗證服務器所做的變更。 對於繼續回報啟用和「非正版」通知的裝置,您應按照「解決方案」部分的步驟移除KB 971033

支援大量授權啟用的 Windows 版本包括:

  • Windows 7 專業版
  • Windows 7 專業版 N
  • Windows 7 專業版 E
  • Windows 7 企業版
  • Windows 7 企業版 N
  • Windows 7 企業版 E

對於並非因 2019 年 1 月 8 日左右的 Microsoft 啟用和驗證伺服器變更而導致的「not genuine」錯誤的 Windows 版本,我们建議您遵循一般的啟用疑難排解。

徵狀


  1. 登入後,您會收到 Windows is not genuine 的錯誤訊息。
     
    螢幕擷取畫面 文字說明
    錯誤
    對話方塊標題: Windows 啟用
    Windows 不是正版
    您的電腦可能正在執行盜版拷貝的 Windows。
    現在取得正版
    稍後詢問
    0xC004F200

     
  2. 在 Windows 桌面的黑色背景上顯示This copy of windows is not genuine 浮水印。
     
    螢幕擷取畫面 文字描述
    錯誤
    在 Windows 桌面右下角的黑色背景中顯示「This copy of Windows is not genuine」浮水印。

     
  3. slmgr /dlv 輸出回報錯誤 0xC004F200。

    螢幕擷取畫面 文字描述
    錯誤
    注意:選取已清除欄位移除 PII。

    Name: Windows(R) 7,企業版
    說明: windows 作業系統 - Windows(R) 7 VOLUME_KMSCLIENT 管道
    啟用 ID:ae2ee509-1b34-41c0-acb7-6d4650168915
    應用程式識別碼: 55c92734-d682-4d71-983e-d6ec3f16059f
    延伸的 PID: <removed>
    安裝 ID: <removed>
    部分產品金鑰: HVTHH
    授權狀態: 通知
    通知原因: 0xC004F200(非正版)。
    Windows 重設授權剩餘次數: 2
    信任時間: <removed>
    請使用 slmgr.vbs /ato 啟用並更新 KMS 客戶資料,以更新值。

     
  4. 使用 slmgr /ato 啟用的指令失敗,並回報下列訊息: 「Windows 在非正版通知期間內執行。 執行 'slui.exe' 以上線並啟用 Windows。」
     
    螢幕擷取畫面 文字描述
    錯誤
    啟用 Windows(R) 7 企業版 (ae2ee509-1b34-41c0-acb7-6d4650168915) …...
    錯誤: Windows 在非正版通知期間內運作。 執行「slui.exe」連線並啟用 Windows。

     
  5. 在事件日誌中記錄以下事件。
     
    事件記錄檔 事件來源 事件識別碼 描述
    應用程式 Microsoft-Windows-Security-SPP 8209 正版狀態設為非正版 (0x00000000) 應用程式 Id 55c92734-d682-4d71-983e-d6ec3f16059f
    應用程式 Microsoft-Windows-Security-SPP 8208 獲取模板 Id 66c92734-d682-4d71-983e-d6ec3f16059f 的正版票證失敗 (hr=0xC004C4A2)
    應用程式 Windows 啟用技術 13 Genuine validation result: hrOffline = 0x00000000, hrOnline =0xC004C4A2
    應用程式 Microsoft-Windows-Security-SPP 8196 授權驗證排程(sppuinotiy.dll)無法自動啟用。 錯誤碼:  0xC004F200:

原因


最近的 Microsoft 啟用與驗證更新無意中在已安裝 KB 971033 的大量授權 Windows 7 客戶端引發 「not genuine」錯誤。已於 2019 年 1 月 8 日 10:00:00 UTC 引入此變更,並於 2019 年 1 月 9 日 4:30:00 UTC 還原。

注意:此計時於 2019 年 1 月 8 日星期二發佈,與 2019 年 1 月發佈的「1B」更新 (KB 4480960KB 4480970) 同時發布。 這些事件互不相關。

Windows 7 裝置已安裝 KB 971033,但在變更時間 (2019 年 1 月 8 日 10:00:00 UTC) 與還原時間 (2019 年 1 月 9 日 4:30:00 UTC) 之間沒有遇到這個問題,就應當不會遇到本文所述的問題。

KB 971033 (「Windows 啟動技術更新說明」) 包含下列文字

注意:對於使用金鑰管理服務 (KMS) 或使用多次啟用金鑰 (MAK) 大量啟動的企業客戶,我們通常不建議在參照映像或已部署的電腦中安裝此更新。 此更新針對使用零售啟用的 Windows 客戶安裝。

強烈建議您在所有大量授權的 Windows 7 裝置上解除安裝 KB 971033。包括目前不受「問題」一節所述問題影響的裝置。

解決方案


要判斷是否已安裝 KB 971033,請使用下列其中一個方法。

  • 開啟控制台的「已安裝更新」項目 (控制台 > Windows Update > 檢視更新記錄 > 已安裝更新),然後在清單中找尋 Update for Microsoft Windows (KB971033)
     
  • 以管理員身分在命令提示字元視窗中執行下列命令,然後在結果中找尋 Microsoft-Windows-Security-WindowsActivationTechnologies-package~31bf3856ad364e35~amd64~~7.1.7600.16395
     
    dism /online /get-packages
  • 在命令提示字元執行下列命令,然後是察看結果是否指示已安裝 KB 971033
     
    wmic qfe where HotFixID="KB971033"
  • 在 Windows PowerShell 中執行下列命令,然後查看結果是否指示已安裝 KB 971033
     
    Get-Hotfix -id KB971033


若目前已安裝 KB 971033,請使用下列其中一個方法刪除更新。 建議您在刪除更新後重新啟動系統。

  • 在控制台的「已安裝更新」項目 (「控制台」 > 「Windows Update」 > 「檢視更新記錄」 > 「已安裝更新」),用滑鼠右鍵按一下「Update for Microsoft Windows (KB971033)」,然後選取「解除安裝」
     
  • 以系統管理員身分在命令提示字元視窗中執行下列命令:
     
    wusa /uninstall /kb:971033
     
  • 以系統管理員身分在命令提示字元視窗中執行下列命令:
     
    dism /online /Remove-Package /PackageName:Microsoft-Windows-Security-WindowsActivationTechnologies-Package~31bf3856ad364e35~amd64~~7.1.7600.16395


解除安裝 KB 971033 或不再顯示為已安裝後,重建相關啟動檔案,然後以系統管理員身分在命令提示字元窗格中執行下列命玲,重新啟動系統:

net stop sppuinotifysc config sppuinotify start= disablednet stop sppsvcdel %windir%\system32\7B296FB0-376B-497e-B012-9C450E1B7327-5P-0.C7483456-A289-439d-8115-601632D005A0 /ahdel %windir%\system32\7B296FB0-376B-497e-B012-9C450E1B7327-5P-1.C7483456-A289-439d-8115-601632D005A0 /ahdel %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform\tokens.datdel %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform\cache\cache.datnet start sppsvccscript c:\windows\system32\slmgr.vbs /ipk <edition-specific KMS client key>cscript c:\windows\system32\slmgr.vbs /atosc config sppuinotify start= demand

注意:在第一個「cscript」命令中,將<版本特有的 KMS 客戶端金鑰>替換為實際金鑰。 如需詳細資訊,請參閱下列 Microsoft Docs 文章:

KMS 客戶端安裝識別碼

下表列出 Windows 7 各個版本的 KMS 客戶端金鑰。

作業系統版本

KMS 客戶端安裝識別碼

Windows 7 專業版

FJ82H-XT6CR-J8D7P-XQJJ2-GPDD4

Windows 7 專業版 N

MRPKT-YTG23-K7D7T-X2JMM-QY7MG

Windows 7 專業版 E

W82YF-2Q76Y-63HXB-FGJG9-GF7QX

Windows 7 企業版

33PXH-7Y6KF-2VJC9-XBBR8-HVTHH

Windows 7 企業版 N

YDRBP-3D83W-TY26F-D46B2-XCKRJ

Windows 7 企業版 E

C29WB-22CC8-VJ326-GHFJW-H9DH4


注意事項

  • 含 KMS 客戶端安裝識別碼的程式碼必須對應相應的作業系統版本。
  • 若服務未安裝KB 971033但仍遇到「問題」一節所提到的問題,您可以重建啟動相關檔案,並使用重新啟動命令清單中的指令碼重新啟動系統。