從「Windows 部署服務」或 System Center Configuration Manager 使用「開機前執行環境」(PXE) 映像啟動的裝置可能無法啟動,並出現錯誤 "0xc0000001"

適用於: Windows Server, version 1903Windows Server 2019, all versionsWindows Server version 1809

摘要


在「Windows 部署服務」(WDS) 伺服器安裝受影響的更新之後,從 WDS 或 System Center Configuration Manager (SCCM) 使用「開機前執行環境」(PXE) 映像啟動的裝置可能無法啟動,並出現錯誤「狀態: 0xc0000001,資訊: 未連接必要裝置或無法存取必要裝置」。

因應措施


若要在 SCCM 伺服器上防範這個問題:

  1. 確認「可變窗口擴充」已啟用 (Windows Server 2008 SP2 或 Windows Server 2008 R2 SP1 沒有這個設定)。
  2. [TFTP 區塊大小] 設定為 4096 並將 [TFTP 視窗大小] 設定為 1。 如需有關如何設定的指引,請參閱自訂支援 PXE 之發佈點的相關 RamDisk TFTP 區塊和視窗大小

注意:請先嘗試 [TFTP 區塊大小][TFTP 視窗大小] 的預設值,但依您的環境和整體設定而定,您可能必須為安裝程式調整設定。 此外,您也可以嘗試 [在不使用 Windows 部署服務的情況下啟用 PXE 回應程式] 設定。 如需有關此設定的詳細資訊,請參閱在 Configuration Manager 中安裝及設定發佈點

若要在沒有 SCCM 的情況下防範 WDS 伺服器上的這個問題:

  1. 在 WDS TFTP 設定中,確認「可變窗口擴充」已啟用 (Windows Server 2008 SP2 或 Windows Server 2008 R2 SP1 沒有這個設定)。
  2. 在匯入的映像的開機設定資料 (BCD) 中,將 RamDiskTFTPBlockSize 設定為 1456。
  3. 在匯入的映像的 BCD 中,將 RamDiskTFTPWindowSize 設定為 4。

注意:請先嘗試 RamDiskTFTPBlockSize 和 RamDiskTFTPWindowSize 的預設值,但依您的環境和整體設定而定,您可能必須為安裝程式調整設定。

後續步驟


此問題已在下列 2019 年 6 月 16 日以後發行的最新累積更新 (LCU) 或每月彙總套件預覽中解決:

  • KB4512941 適用於 Windows Server 1903 版的 LCU。
  • KB4512534 適用於 Windows Server 1809 版和 Windows Server 2019 的 LCU。
  • KB4512509 適用於 Windows Server 1803 版的 LCU。
  • KB4512494 適用於 Windows 10 1709 版的 LCU。
  • KB4512495 適用於 Windows Server 1607 版和 Windows Server 2016 的 LCU。
  • KB4512478 適用於 Windows Server 2012 R2 的每月彙總套件預覽。
  • KB4512512 適用於 Windows Server 2012 的每月彙總套件預覽。
  • KB4512514 適用於 Windows Server 2008 R2 SP1 的每月彙總套件預覽。
  • KB4512499 適用於 Windows Server 2008 SP2 的每月彙總套件預覽。

我們正在研究解決方案,將會在未來版本中為尚未解決問題的平台提供更新。

受影響的更新


2019 年 6 月 11 日以後針對受影響平台而發行的任何最新累積更新 (LCU) 和每月彙總套件,可能會遇到此問題:

  • KB4503293 適用於 Windows Server 1903 版的 LCU。
  • KB4503327 適用於 Windows Server 1809 版和 Windows Server 2019 的 LCU。
  • KB4503286 適用於 Windows Server 1803 版的 LCU。
  • KB4503284 適用於 Windows 10 1709 版的 LCU。
  • KB4503267 適用於 Windows Server 1607 版和 Windows Server 2016 的 LCU。
  • KB4503276 適用於 Windows Server 2012 R2 的每月彙總套件。
  • KB4503285 適用於 Windows Server 2012 的每月彙總套件。
  • KB4503292 適用於 Windows Server 2008 R2 SP1 的每月彙總套件。
  • KB4503273 適用於 Windows Server 2008 SP2 的每月彙總套件

2019 年 6 月 11 日針對受影響平台而發行的下列僅限安全性更新,可能會遇到此問題:

  • KB4503290 適用於 Windows Server 2012 R2 的僅限安全性更新。
  • KB4503263 適用於 Windows Server 2012 和 Windows Embedded 8 Standard 的僅限安全性更新。
  • KB4503269 適用於 Windows Server 2008 R2 SP1 的僅限安全性更新。
  • KB4503287 適用於 Windows Server 2008 SP2 的僅限安全性更新。