當您嘗試從 Microsoft 動態 RMS 儲存作業管理員連線到存放區資料庫伺服器的錯誤訊息: 「 要連線到這部伺服器您必須使用 SQL Server Management Studio 或 SQL Server 管理物件 」


狀況


當您嘗試從正在執行 Microsoft 動態零售管理系統 (RMS) 儲存作業管理員的用戶端連線到存放區資料庫伺服器時,您會收到下列錯誤訊息︰
若要連線到這部伺服器中,您必須使用 SQL Server Management Studio 或 SQL Server 管理物件 (SMO)。

原因


只要有下列原因之一成立,就會發生這個問題:
  • 在用戶端執行的 Microsoft SQL Server 的版本是早於 Microsoft SQL Server 的伺服器上的版本。
  • Microsoft SQL Server 不會安裝在用戶端中。
  • 用戶端上未安裝 Microsoft SQL Server 2005年回溯相容性。

解決方案


如果要解決這個問題,請安裝 Microsoft SQL Server 2005年回溯相容性獨立套件。若要執行這項操作,請參考下列步驟:
  1. 下載 Microsoft SQL Server 回溯相容性的獨立套件。若要執行這項操作,請造訪下列 Microsoft 網站:
  2. 按兩下您在步驟 1 所下載的 SQLServer2005_BC.msi 檔案,然後依照 「 Microsoft SQL Server 回溯相容性安裝精靈 」 來安裝 Microsoft SQL Server 回溯相容性。
  3. 若要在安裝 Microsoft SQL Server 回溯相容性之後,請重新啟動用戶端。