您目前已離線,請等候您的網際網路重新連線

WD97: 比較文件 reinserts 刪除段落標記

重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,而非使用人工翻譯而成。Microsoft 同時提供使用者人工翻譯及機器翻譯兩個版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,機器翻譯的文章可能不盡完美。這些文章中也可能出現拼字、語意或文法上的錯誤,就像外國人在使用本國語言時可能發生的錯誤。Microsoft 不為內容的翻譯錯誤或客戶對該內容的使用所產生的任何錯誤或損害負責。Microsoft也同時將不斷地就機器翻譯軟體進行更新。

按一下這裡查看此文章的英文版本:185483
本文已封存。本文係以「現狀」提供且不會再更新。
徵狀
當您比較原始文件和其修訂的對應項之間的編輯修訂版本 (在 [工具] 功能表上指向追蹤修訂,然後按一下 [比較文件),文件的版面配置可能會變更。例如,可能會出現額外的線條和分頁符號,而行換行可能會變更。

如需這種行為範例請參閱本文稍後 < 其他相關資訊 > 一節]。
發生的原因
這種行為是經過設計的 Microsoft Word。

如果修訂包含已刪除的段落標記] 或 [手動分行符號,請比較文件,時新行可能會出現,表示已刪除的行。Word 必須顯示以精確地顯示比較的文件之間差異已刪除任何段落標記。

而且,緊接在之前已刪除的段落標記] 或 [手動分行符號單字列為,修訂的一部份,,因此會出現兩次 (如被刪除,並且再新增回)。
其他可行方案
雖然您不能解決這個問題,可以快速地開啟修訂標記和關閉。若要執行此動作使用之一一個下列的方法。

方法 1: 建立一個巨集

Microsoft 僅,為了說明提供程式設計範例,不提供任何明示或默示的保證,包括但不是限於適售性以及適合某特定用途之默示擔保責任。本文假設您已熟悉我們所示範的程式設計語言,以及用來建立和偵錯程序的工具。Microsoft 技術支援工程師可以協助解釋特定程序的功能,但它們不會修改這些範例以提供附加功能或建構程序,以符合您的特定需求。
如果您有限制程式設計經驗,您可以連絡 Microsoft 認證合作夥伴或 Microsoft 諮詢服務。如需詳細資訊請造訪下列 Microsoft] 網站:

Microsoft 認證合作夥伴-https://partner.microsoft.com/global/30000104

Microsoft 摘要報告服務-http://support.microsoft.com/gp/advisoryservice

如需有關可用的支援選項,以及有關如何連絡 Microsoft 的詳細資訊,請造訪下列 Microsoft 網站: http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

取得更多資訊有關取得應用程式的說明與 Visual Basic 請參閱下列文件 「 Microsoft 知識庫 」 中:
163435VBA: 應用程式的 Visual Basic 程式設計資源

173707OFF97: 如何執行範例程式碼從眭舑恅梒
若要快速開啟修訂標記,開啟及關閉使用下列的範例 Visual Basic 應用程式的巨集:
   Sub ToggleShowRevisions()      ActiveDocument.ShowRevisions = Not ActiveDocument.ShowRevisions   End Sub				
您也可以將此巨集指派至工具列或功能表以便快速存取。

如需有關如何將指令新增到 [一] 功能表的詳細資訊,[說明] 功能表上按一下 [目錄及索引、 按一下 Word [說明] 中的 [索引] 索引標籤,鍵入下列文字
功能表
然後再連按兩下所選取的文字,以移至 [新增指令或其他項目至功能表] 的主題。如果您找不到您需要的資訊詢問 Office 小幫手。

方法 2: 使用醒目提示修訂命令

如果要手動開啟修訂標記和關閉,請依照下列步驟執行:

  1. 在 [工具] 功能表指向 [追蹤修訂],然後按一下 [反白提示修訂處]。
  2. 在 [反白提示修訂處] 對話方塊按一下以清除 (取消核取),或選取的 (檢查) 」 標示在螢幕上的修訂 」] 核取方塊。
其他相關資訊
下列的範例文字會示範這個行為。

注意: <p>代表段落標記。

之前修訂原始文件 (文件 1)-

標題 <p>
更多的標題 <p>
副標題 <p>

原始的文件 (文件 [2])-修訂後的複本

title.more 標題 <p>
副標題 <p>

之後比較文件

標題 (<-紅色刪除線: 刪除) <p>(<-Red: Deletion)
標題 (<-紅色底線: 考驗) 其他標題 <p>
副標題 <p>
注意: 雖然它不會在這裡顯示,已刪除的段落標記就會顯示成紅色,指定預設的追蹤修訂設定 (在 [工具] 功能表上按一下 [選項],然後按 [追蹤修訂] 索引標籤])。額外文字環繞已刪除的段落標記可能/顯示為刪除線或加上底線。

如果要重現此行為,請依照下列步驟執行:

  1. 在 Word 中, 建立新文件。
  2. 新空白文件中鍵入 「 標題.",然後按 ENTER。
  3. 輸入"其他標題.",然後按下 ENTER 鍵。
  4. 型別 」 副標題"。
  5. 將文件儲存為 Before.Doc。
  6. 刪除時按下 ENTER 鍵在步驟 1 中建立的段落標記。

    您的文字現在應該出現,如下所示:
    Title.MoreTitle。
    副標題。
  7. 將您所做的變更儲存為 After.Doc。
  8. 在 [工具] 功能表上指向 [追蹤修訂],然後按一下 [比較文件]。
  9. 在 「 選取檔案以比較方式目前文件"] 對話方塊選取"Before.Doc 「 您在步驟 5 中, 所建立,然後按一下 [開啟]。
如果顯示/隱藏亮應該會看到已刪除的段落標記。

如需詳細資訊請參閱下列文件 「 Microsoft 知識庫 」 中:
112165WD: 個別修改標示為單一的修訂

121919WD: 格式化/繪圖層變更 Unmarked 中比較
新增標記 redline redlining 移除檢閱修訂螢幕刪除線群組未標示先 untracked 看磁碟檔案標記

警告:本文為自動翻譯

內容

文章識別碼:185483 - 最後檢閱時間:10/08/2013 02:44:29 - 修訂: 2.3

Microsoft Word 97 Standard Edition

  • kbnosurvey kbarchive kbmt kbdtacode kbmacroexample kbprb KB185483 KbMtzh
意見反應