Outlook 的 [自動完成] 清單的相關資訊

Support for Office 2003 has ended

Microsoft ended support for Office 2003 on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

請注意--重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,且可能由 Microsoft Community 利用 Community Translation Framework技術或人工進行事後編修。翻譯過程並無專業譯者參與。Microsoft 同時提供使用者人為翻譯、機器翻譯及社群編修後的機器翻譯三種版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,所有翻譯文章都可能不盡完美,內容都可能出現詞彙、語意或文法上的錯誤。就翻譯內容之不正確或錯誤,或客戶因使用翻譯內容所產生的任何損害,微軟不負擔任何責任。Microsoft將依合理的商業努力不斷地更新機器翻譯軟體和工具,以期能為使用者提供更好的服務。

按一下這裡查看此文章的英文版本:2199226
結論
本文中的 [Microsoft Outlook 自動完成] 清單中 (也稱為 [Outlook 自動完成] 清單) 的概觀。除了描述的功能,本文還包含更多的資訊和適用於進階使用者管理清單的逐步指示。
其他相關資訊
Outlook 會維持自動完成] 清單。清單會使用自動名稱檢查功能,並自動完成功能。當您從 Outlook 傳送電子郵件訊息時,自動完成] 清單中,也就是暱稱快取,將自動產生。清單包含 SMTP 地址、 LegacyExchangeDN 項目,以及對您擁有先前傳送郵件的人的顯示名稱。

注意Outlook 的 [自動完成] 清單專屬於 [Outlook,並不共用的 Outlook Web App (OWA)。OWA 會維護它自己的自動完成] 清單。

下列章節提供自動完成功能的相關資訊。

限制的項目數目

Outlook 會限制您可以將它儲存在 [自動完成] 清單中的項目數目。達到此限制之後,Outlook 會使用內部演算法,來決定最佳的名稱,以從清單中移除。它會根據使用加權。因此,您可能會發現有些意外遭到移除您的暱稱快取的名稱。有兩種一般的方法,您可以使用來避免這種情形:
  1. 您可以主動移除您不再需要的自動完成清單項目。這是慣用的方法。如需有關如何執行這項操作的詳細資訊,請參閱下一節 < 如何一次移除自動完成清單項目一個 >。
  2. 您可以增加暱稱快取的限制。由於這種組態是未經測試,我們不建議使用。如果您有較大的暱稱快取,也可能會遺失大量的快取的項目,如果您的暱稱快取就會變成無法使用因為損毀。如需有關如何增加限制的詳細資訊,請參閱下一節 < 如何變更自動完成] 清單的限制 >。
限制如下所示:
  • Outlook 2016: 1000 項目
  • Outlook 2013: 1000 項目
  • Outlook 2010: 1000 項目
  • Outlook 2007: 2000 項目
  • Outlook 2003: 1000 項目

如何啟用自動完成 」 功能

本節將詳細說明如何啟用或停用自動完成 」 功能。
Outlook 2010,Outlook 2013 Outlook 2016
若要存取 [自動完成設定,請依照下列步驟執行:
  1. 按一下 [檔案] 功能表上的 [選項]。
  2. 選取 [郵件] 索引標籤。
  3. 大約一半向下捲動直到您看到 [傳送訊息。請確定已核取 [使用 [自動完成] 清單來建議當 [收件者]、 [副本] 和 [密件副本] 行輸入的名稱] 方塊中的色彩。

Outlook 2003 和 Outlook 2007
若要存取 [自動完成設定,請依照下列步驟執行:
  1. 按一下 [工具],然後按一下 [選項
  2. 按一下 [電子郵件選項 ] 按鈕。
  3. 按一下 [進階電子郵件選項] 按鈕。
  4. 請確定完成、 [副本] 和 [密件副本] 時建議名稱欄位核取方塊。(這個步驟的畫面之後)。螢幕擷取畫面,這個步驟。

如何.nk2 檔案匯入 Outlook 2010,Outlook 2013 Outlook 2016

Microsoft Office Outlook 2007年和較早版本儲存在磁碟上的別名 (.nk2) 檔案中的自動完成] 清單。Outlook 2010,Outlook 2013 Outlook 2016 儲存為隱藏的郵件,您主要的訊息存放區中的自動完成] 清單。Outlook 2010,Outlook 2013 Outlook 2016,可讓您匯入較舊的.nk2 檔案。

如需有關如何匯入 Outlook 2010.nk2 檔案的詳細資訊,請前往下列 Microsoft 網站:
如需有關如何匯入 Outlook 2013] 及 [Outlook 2016 中的.nk2 檔案的詳細資訊,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文件:
2806550如何.nk2 檔案匯入 Outlook 2013 或 Outlook 2016

如何複製 theAutoComplete 清單

匯出和匯入 [自動完成] 清單中的步驟會有所不同,您所使用的 Outlook 版本。
Outlook 2010,Outlook 2013 Outlook 2016
若要複製 Outlook 2010、 Outlook 2013 和 Outlook 2016 中的自動完成] 清單,請依照下列步驟執行:

步驟1

若要匯出 [自動完成] 的 [信箱] 訊息,請依照下列步驟執行:
  1. 結束 Outlook,,然後關閉 Outlook Web Access 或 Outlook Web App (OWA) 連線到您的信箱的所有工作站上。
  2. 下載並安裝從 MFCMAPI http://mfcmapi.codeplex.com.
  3. 執行 mfcmapi.exe。
  4. 工作階段] 功能表中,按一下 [登入]。
  5. 如果提示您的設定檔時,請選取您想要的設定檔名稱,,,然後按一下 [ [確定]
  6. 在上方窗格中,找出對應到您的信箱,那一行,然後按兩下它。
  7. 在左邊瀏覽] 窗格中,展開根容器,然後再展開頂端的資訊儲存庫IPM_SUBTREE
  8. 以滑鼠右鍵按一下 [收件匣] 資料夾中,,,然後按一下 [開啟相關聯的內容資料表。這個動作會開啟新的 MFCMAPI 視窗,其中包含各種屬性。
  9. 在 [主旨] 欄中,以滑鼠右鍵按一下該項目有主旨IPM。Configuration.Autocomplete,然後按一下 [匯出的訊息。這個動作會開啟郵件儲存至檔案] 視窗中的色彩。
  10. 在下拉式清單中,選取訊息檔案 (UNICODE)],然後按一下[確定]
  11. 選取您要將郵件,儲存的資料夾位置,然後按一下 [儲存。請注意此位置。
步驟 2

要匯入 [自動完成] 的 [信箱] 訊息,請依照下列步驟執行。
  1. 結束 Outlook,,然後關閉 Outlook Web Access 或 Outlook Web App (OWA) 連線到您的信箱的所有工作站上。
  2. 下載並安裝從 MFCMAPI http://mfcmapi.codeplex.com
  3. 執行 mfcmapi.exe。
  4. 工作階段] 功能表中,按一下 [登入]。
  5. 如果提示您的設定檔時,請選取您想要的設定檔名稱,,,然後按一下 [ [確定]
  6. 在上方窗格中,找出對應到您的信箱,那一行,然後按兩下它。
  7. 在左邊瀏覽] 窗格中,展開 [根目錄-信箱,然後展開頂端的資訊儲存庫IPM_SUBTREE
  8. 以滑鼠右鍵按一下 [收件匣] 資料夾中,,,然後按一下 [開啟相關聯的內容資料表。這個動作會開啟新的 MFCMAPI 視窗,其中包含各種屬性。
  9. 若要避免重複的項目,您必須刪除現有的 「 自動完成 」 訊息。

    注意之前,您要刪除IPM。Configuration.Autocomplete訊息,您必須藉由使用中的 < 如何匯出自動完成快取 > 一節的步驟匯出郵件。

    若要刪除現有的 「 自動完成 」 訊息,請依照下列步驟執行:

    1. 在 [主旨] 欄中,找出具有主旨IPM 的項目。Configuration.Autocomplete
    2. 項目,以滑鼠右鍵按一下,然後按一下 刪除郵件.如此會開啟 [刪除項目] 視窗。
    3. 在下拉式清單中,選取永久刪除 (如果支援的刪除項目保留刪除),然後按一下[確定]
  10. 在 [資料夾] 功能表上按一下 [匯入,,,然後按一下 [從訊息
  11. 找出您在步驟 11 的"如何來匯出自動完成清單"區段中,建立.msg 檔案,然後按一下[確定]
  12. 負載訊息出現的視窗中,在載入樣式] 清單中,選取 [載入訊息到目前的資料夾,然後按一下[確定]
從 IPM 匯入的 「 自動完成 」 資訊。Configuration.Autocomplete_<hexadecimal code=""></hexadecimal>.msg,讓版面配置區<hexadecimal code=""></hexadecimal>代表一長串數字和字母數。
Outlook 2003 和 Outlook 2007
若要複製自動完成] 清單,Outlook 2003 和 Outlook 2007 中的步驟會不同。這是因為 Outlook 2003 和 Outlook 2007 會自動完成] 清單儲存.nk2 檔案。

若要複製的自動完成] 清單,Outlook 2003 中,移至下列 Microsoft 網站:
若要在 Outlook 2007 中複製自動完成] 清單,請前往下列 Microsoft 網站:

如何移除自動完成清單項目一一次

從自動完成快取一個項目移除項目,一次,請依照下列步驟執行:
  1. 開啟新的電子郵件訊息。
  2. 輸入您想要移除自動完成項目的前的幾個字元。
  3. 在清單中的項目出現時建議名稱,將滑鼠指標的名稱上,直到它變成反白顯示,但是請勿按下的名稱。
  4. 反白顯示的名稱旁邊的"X"圖示出現,請按一下 [從清單中移除名稱的X ,或按鍵盤上的Delete鍵。

如何清除整份的自動完成清單

本節說明如何刪除自動完成] 清單。
Outlook 2010,Outlook 2013 Outlook 2016
您可以使用下列兩種方法之一來刪除 Outlook 2010、 Outlook 2013 和 Outlook 2016 中的 [自動完成] 清單。

方法 1
  1. 開啟 [Outlook]。
  2. 在 [檔案] 索引標籤上按一下 [選項]。
  3. 按一下 [郵件] 索引標籤。
  4. 按一下 [傳送訊息的 [空的自動完成清單]。


  5. 按一下 [是]

方法 2

啟動 Outlook 時使用 /CleanAutoCompleteCache 參數。若要執行這項操作,請依照下列步驟執行:
  1. 按一下 [開始],然後按一下 [執行]
  2. 型別Outlook.exe /CleanAutoCompleteCache

    注意如果 Outlook 未安裝在預設位置中,您必須指向 Outlook.exe 的路徑。
Outlook 2003 和 Outlook 2007
若要刪除自動完成] 清單,Outlook 2003 和 Outlook 2007 中的,您必須手動刪除.nk2 檔案。若要刪除.nk2 檔案,請依照下列步驟執行:
  1. 結束 Outlook。
  2. 按一下 [開始],然後按一下電腦
  3. 按一下 [組合管理],然後按一下 [資料夾和搜尋選項
  4. 按一下 [檢視] 索引標籤的 [顯示隱藏的檔案、 資料夾和磁碟機]。
  5. 按一下[確定]
  6. 按一下 [開始],按一下 [所有程式、 都按一下 [附屬應用程式],然後都按一下執行
  7. 在 [執行] 對話方塊中,輸入下列命令 (包括引號),然後按一下[確定]:

    「 C:\Users\使用者名稱\AppData\Roaming\Microsoft\Outlook"


    注意這個路徑中的使用者名稱會稱為名稱目前登入的 Windows 使用者。
  8. 以滑鼠右鍵按一下。NK2 有您想要重設],然後按一下 [重新命名的設定檔名稱的檔案。
  9. 重新命名為profilename.bak,檔案,然後按 Enter 鍵。
  10. tart 的 Outlook。

使用自動完成快取的問題

本章節說明可以使用自動完成快取中發生的已知的問題。自動完成快取可以經過一段時間損毀,而且可能無法儲存新的項目。如果發生這種情況,您可以嘗試從清單中移除個別的項目。若要執行這項操作,請參閱一節 < 如何一次移除自動完成清單項目一個 >。如果的操作無法解決問題,就可以重設整個的自動完成] 清單。若要執行這項操作,請參閱一節 < 如何清除整份的自動完成清單 >。

如何變更自動完成] 清單的限制

由於這種組態是未經測試,我們不建議使用。如果您有較大的自動完成] 清單,也可能會遺失大量的快取的項目,如果您的自動完成快取變成無法使用,因為損毀。有了這個免責聲明,您可以使用下列的登錄資料來增加 theAutoComplete 清單在 Outlook 中的限制。

重要這個章節、 方法或工作包含修改登錄的步驟。不過,如果您不當修改登錄,可能會發生嚴重的問題。因此,請務必小心執行這些步驟。為加強保護,請在修改前備份登錄。然後,您可以在發生問題時還原登錄。如需有關如何備份和還原登錄的詳細資訊,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文件:

322756 如何備份及還原 Windows 中的登錄
  1. 結束 Outlook。
  2. 啟動登錄編輯程式。
    • 在 Windows 中 8.x 版本,請按視窗鍵輸入regedit ,然後按Enter鍵。
    • 在 Windows 7] 和 [Windows Vista 中,按一下 [啟動類型 regedit 在 [開始搜尋] 方塊中,然後按Enter鍵。
  3. 找出並再選取下列登錄子機碼:

    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoNameCheck

    注意版面配置區 x.0 在這個登錄子機碼會代表您的 Microsoft Office 版本。使用適當的值,從下列清單。

    Outlook 2016 = 16.0
    Outlook 2013 = 15.0
    Outlook 2010 = 14.0
    Outlook 2007 = 12.0
    Outlook 2003 = 11.0
  4. 在 [編輯] 功能表中,指向 [新增],然後按一下 [ DWORD 值
  5. 型別 MaxNickNames然後按Enter鍵。
  6. 按一下 [編輯] 功能表的 [修改]。
  7. 輸入的限制,新的值,然後按一下[確定]

    注意事項
    • 請確定您在decimal 表單中輸入代碼。這是正確的格式,在其中鍵入的數字。
    • 請嘗試增加限制只臨界間距若要測試新的限制。例如,若要建立有百分之 20 的增加,Outlook 2013 的限制,您可以指定1200 MaxNickNames 的值。
  8. 結束登錄編輯程式。
  9. 啟動 Outlook。
注意MaxNickNames 的登錄值僅指定非預設限制。因此,您也可以使用這個值以降低暱稱快取的限制。

內容

文章識別碼:2199226 - 最後檢閱時間:10/29/2015 04:15:00 - 修訂: 6.0

Outlook 2016, Microsoft Outlook 2013, Microsoft Office Outlook 2003, Microsoft Office Outlook 2007, Microsoft Outlook 2010

  • kbmt KB2199226 KbMtzh
意見反應