當服務突然停止時,會顯示錯誤 1058

本文提供服務突然停止時發生「錯誤 1058」問題的解決方案。

適用於:Windows 10 - 所有版本、Windows 7、Windows Vista、Windows XP
原始 KB 編號: 241584

徵狀

當服務突然停止時,您可能會收到下列錯誤訊息:

錯誤 1058:無法啟動服務,可能是因為服務已停用,或是因為它沒有與其相關聯的已啟用裝置。

當您嘗試啟動服務時,也可能會收到此錯誤訊息。

原因

如果服務已停用,或您目前使用的硬體配置檔服務已停用,就會發生此問題。

Windows 10、Windows 7 和 Windows Vista 的解決方案

  1. 按兩下 [開始],搜尋 服務,然後在搜尋結果中按兩下 [ 服務 ]。

  2. 捲動直到您找到服務,然後按兩下服務。

    [本機計算機) ] 對話框中 [路由和遠端訪問屬性] ([一般] 索引標籤底下的 [啟動類型] 選項螢幕快照。

  3. 如果服務已停用,請按兩下 [ 啟動類型 ] 列表,然後選 取 [停用] 以外的選項。

  4. 按一下 [套用]

  5. 按兩下 [開始 ] 嘗試啟動服務。

  6. 按一下確定

Windows XP 的解析度

  1. 按一下 [開始],依序指向 [所有程式] 和 [系統管理工具],然後按一下 [服務]

  2. 捲動直到您找到停止或停用的服務為止。

  3. 按兩下未啟動的服務。

  4. 按一下 [登入] 索引標籤。

    [遠端過程調用 (RPC) 定位器屬性 (本機計算機) ] 對話方塊的 [登入] 索引卷標螢幕快照。

  5. 確認您所使用的硬體設定檔服務未停用。 如果硬體配置檔的服務已停用,請按兩下 [ 啟用]

  6. 按兩下 [ 一般] 索引標籤,然後在 [ 啟動類型 ] 方塊中確認服務未停用。 如果服務已停用,請按兩下 [ 自動 ],讓它在啟動電腦時啟動。

    [一般] 索引標籤中 [啟動類型] 方塊的螢幕快照。

  7. 按一下確定

其他相關資訊

如果服務設定為自動啟動,但您所使用的硬體配置檔服務已停用,則不會啟動服務,也不會產生任何錯誤訊息。