您目前已離線,請等候您的網際網路重新連線

.NET Framework 2.0 SP2 和 .NET Framework 3.0 SP2 的更新可能會鍵結安裝其他更新

Windows XP 支援已結束

Microsoft 於 2014 年 4 月 8 日結束對 Windows XP 的支援。此變更已影響您的軟體更新和安全性選項。 瞭解這對您的意義為何且如何持續受保護。

Windows Server 2003 的支援已於 2015 年 7 月 14 日結束

Microsoft 已於 2015 年 7 月 14 日結束對 Windows Server 2003 的支援。此變更已影響您的軟體更新和安全性選項。 瞭解這對您的意義為何且如何持續受保護。

徵狀
當您安裝部份 Microsoft .NET Framework 2.0 Service Pack 2 (SP2) 或 Microsoft .NET Framework 3.0 SP2 更新時,這些更新會鍵結安裝其他更新。系統必須安裝這些額外的更新才能滿足特定 .NET Framework 元件中的新相依性。
其他相關資訊
當您安裝 .NET Framework 2.0 SP2 或 .NET Framework 3.0 SP2 的特定更新時,這些更新會造成額外更新的安裝。之所以發生這個行為,是因為延伸保護資訊安全諮詢 引入新的延伸保護功能,其中包含與新引用「型別」的新相依性。這個新功能包括 .NET Framework 2.0 SP2 和 .NET Framework 3.0 SP2 功能層中的新功能。.NET Framework 3.0 SP2 功能層中的新 Windows Communication Foundation (WCF) 功能與 .NET Framework 2.0 SP2 功能層中對應的新功能和新「型別」之間有相依性。.NET Framework 2.0 SP2 功能層中的新 ASP.NET 功能也與 System.Net (網路堆疊) 中的新功能之間有新相依性。

.NET Framework 元件的更新是累積性的。因此,延伸保護資訊安全諮詢之後發行的 ASP.NET 元件更新將永遠包含有新 ASP.NET 功能,做為延伸保護之用。這個新功能必須與上述提及的功能相依性 (新「型別」之間) 相符。為滿足此相依性,WCF 和 ASP.NET 元件的更新必須鍵結安裝額外的更新。如果此相依性不相符,您可能會遇到下列「Microsoft 知識庫」文件所描述的問題:
2262911 在您安裝更新 982167 或 982168 後,出現「無法載入類型 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy'」例外狀況錯誤
  • 在 Windows XP 和 Windows Server 2003 中,.NET Framework 2.0 SP2 的 ASP.NET 元件更新也會安裝下列更新:
    980773 說明 Windows XP 和 Windows Server 2003 上的.NET Framework 3.5 Service Pack 1 和 .NET Framework 2.0 Service Pack 2 的 NCL 更新:2010 年 6 月 8 日
  • 在 Windows Vista SP1 和 Windows Server 2008 中,.NET Framework 2.0 SP2 的 ASP.NET 元件更新也會安裝下列更新:
    980843 說明 Windows Vista Service Pack 1 和 Windows Server 2008 Service Pack 1 的.NET Framework 3.5 Service Pack 1 適用 NCL 更新:2010 年 6 月 8 日
  • 在 Windows Vista SP2 和 Windows Server 2008 中,.NET Framework 2.0 SP2 的 ASP.NET 元件更新也會安裝下列更新:
    980842 說明 Windows Vista Service Pack 1 和 Windows Server 2008 Service Pack 2 的.NET Framework 3.5 Service Pack 2 適用 NCL 更新:2010 年 6 月 8 日
  • 在 Windows XP 和 Windows Server 2003 中,.NET Framework 3.0 SP2 的 WCF 元件更新也會安裝下列更新: 
    980773 說明 Windows XP 和 Windows Server 2003 上的.NET Framework 3.5 Service Pack 1 和 .NET Framework 2.0 Service Pack 2 的 NCL 更新:2010 年 6 月 8 日
    976765 說明 Windows XP 和 Windows Server 2003 的 .NET Framework 3.5 Service Pack 1 與 .NET Framework 2.0 Service Pack 2 適用 ASP.NET 更新:2010 年 6 月 8 日
  • 在 Windows Vista SP1 和 Windows Server 2008 中,.NET Framework 3.0 SP2 的 WCF 元件更新也會安裝下列更新:
    980843 說明 Windows Vista Service Pack 1 和 Windows Server 2008 Service Pack 1 的.NET Framework 3.5 Service Pack 1 適用 NCL 更新:2010 年 6 月 8 日
    976767 說明 Windows Vista Service Pack 1 和 Windows Server 2008 Service Pack 1 上的 .NET Framework 3.5 Service Pack 1 的 ASP.NET 更新:2010 年 6 月 8 日
  • 在 Windows Vista SP2 和 Windows Server 2008 中,.NET Framework 3.0 SP2 的 WCF 元件更新也會安裝下列更新:
    980842 說明 Windows Vista Service Pack 1 和 Windows Server 2008 Service Pack 2 的.NET Framework 3.5 Service Pack 2 適用 NCL 更新:2010 年 6 月 8 日
    976768 說明 Windows Vista Service Pack 1 和 Windows Server 2008 Service Pack 2 上的 .NET Framework 3.5 Service Pack 2 的 ASP.NET 更新:2010 年 6 月 8 日
內容

文章識別碼:2436257 - 最後檢閱時間:10/26/2010 10:25:00 - 修訂: 2.0

Microsoft .NET Framework 3.0 Service Pack 2, Microsoft .NET Framework 2.0 Service Pack 2, Windows 7 Enterprise, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Ultimate, Windows Server 2008 R2 Standard, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Datacenter, Windows Server 2008 Service Pack 2, Windows Server 2008 for Itanium-Based Systems, Windows Server 2008 Datacenter, Windows Server 2008 Enterprise, Windows Server 2008 Standard, Windows Web Server 2008, Windows Vista Service Pack 2, Windows Vista Service Pack 1, Microsoft Windows Server 2003 Service Pack 2, Microsoft Windows XP Service Pack 3

  • kbbug kbexpertiseinter kbsecbulletin kbsecurity kbsecvulnerability KB2436257
意見反應