使用 Microsoft 登入
登入或建立帳戶。
您好:
選取其他帳戶。
您有多個帳戶
選擇您要用來登入的帳戶。
英文
很抱歉,此文章目前沒有您所使用語言的版本。

Symptoms

Consider the following scenario:

  • You install a hotfix package for Microsoft BizTalk Server 2009 on a computer that is running BizTalk Server 2009.

  • You check the hardware inventory on the computer by using Microsoft System Center Configuration Manager 2007.

    Note This operation returns a list of names for installed software.

In this scenario, the name for the installed hotfix package contains some additional characters that are meaningless.

For example, the displayed name for the installed hotfix package resembles the following in the returned list for the hardware inventory. However, the correct name is "Microsoft BizTalk Server 2009 Hotfix [See KB article kbnumber for detail]LDR."

Microsoft BizTalk Server 2009 Hotfix [See KB article kbnumber for detail]LDR????r?*{FA7FA702-EFAD-4895-A95A-D4ECB383BF7D}\7.0.3300.0

Note kbnumber is a placeholder for a Microsoft Knowledge Base (KB) article number for the installed hotfix package.

Cause

This issue occurs because the registry entry does not contain a null-terminated string.

When Setup.exe for the hotfix installation runs, Setup.exe does not add a correctly formatted null-terminated string. Therefore, the hardware inventory operation in System Center Configuration Manager 2007 reads beyond the hotfix registry entry. Therefore, the hardware inventory contains some additional characters that are meaningless. 

Resolution

The hotfix that resolves this issue is included in cumulative update package 1 for BizTalk Server 2009.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2429050 Cumulative update package 1 for BizTalk Server 2009

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Workaround

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in WindowsTo work around this issue, edit the following registry key in Registry Editor:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Microsoft BizTalk Server 2009 Hotfix [See KB article kbnumber for detail]LDR
To edit the registry key, follow these steps:

  1. Open Registry Editor. To do this, use the appropriate method for your operating system. For example, use one of the following methods:

    • In Windows 2008, or in Windows Vista, click Start, type regedit in the Start Search box, and then press ENTER.

    • In Windows Server 2003, or in Windows XP, click Start, click Run, type regedit, and then click OK.

  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Microsoft BizTalk Server 2009 Hotfix [See KB article kbnumber for detail]LDR

  3. On the Edit menu, click Rename, do not make any changes, and then press Enter.

  4. Exit Registry Editor.

More Information

For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information about BizTalk Server hotfixes

需要更多協助嗎?

想要其他選項嗎?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

這項資訊有幫助嗎?

以下何者是您會在意的事項?
按下 [提交] 後,您的意見反應將用來改善 Microsoft 產品與服務。 您的 IT 管理員將能夠收集這些資料。 隱私權聲明。

感謝您的意見反應!

×