如何使用 Orca 資料庫編輯器來編輯 Windows 「 安裝程式檔案

重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,而非使用人工翻譯而成。Microsoft 同時提供使用者人工翻譯及機器翻譯兩個版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,機器翻譯的文章可能不盡完美。這些文章中也可能出現拼字、語意或文法上的錯誤,就像外國人在使用本國語言時可能發生的錯誤。Microsoft 不為內容的翻譯錯誤或客戶對該內容的使用所產生的任何錯誤或損害負責。Microsoft也同時將不斷地就機器翻譯軟體進行更新。

按一下這裡查看此文章的英文版本:255905
依現狀不再更新的知識庫內容免責聲明
本文旨在說明 Microsoft 不再提供支援的產品。因此,本文係依「現狀」提供,不會再更新。
結論
以現有的 Windows 安裝程式工具中的限制,因為您可能需要直接編輯 Windows 「 安裝程式封裝 (.msi) 檔案。Orca 資料庫編輯器是一個 Windows Installer SDK 中可用的表格編輯工具,而且它可以用來編輯.msi 檔案。Orca 編輯器編輯並建立合併模組 (.msm) 檔案內部一致性評估工具 (.cub) 檔案及補充程式建立檔案 (.pcp)。本文將告訴您如何使用 Orca 編輯器來修改您的.msi 檔案。
其他相關資訊
警告編輯 MSI 檔案可能會導致嚴重的問題,可能會讓您的系統處於不穩定的狀態。 Microsoft 無法保證從的 MSI 檔案編輯器使用不正確所造成的問題可以獲得解決。修改的 MSI 檔案的出貨產品應該只嘗試下直接從產品的廠商的指示。

安裝及執行 Orca

若要安裝和執行 Orca 編輯器,請依照下列步驟執行:
  1. 來自下列網頁下載 Windows Installer SDK 範例、 工具和文件:
  2. 藉由連按兩下 [Orca.msi Orca 編輯器 \Microsoft SDK\bin 資料夾中檔案的安裝。
  3. 按一下 [開始],指向 [程式集,然後再按一下 [Orca
  4. 在 [檔案] 功能表上按一下 [開啟舊檔,並瀏覽至您想編輯的.msi 檔案。

資料表

.msi 檔案中資料表會列在左窗格中。選取要編輯資料表。資料表的欄位出現在右窗格的頂端。 您可以展開和摺疊這些欄位。

若要將不會出現的標準資料表按一下 [表格] 功能表上的 [新增表格]。若要將資料表按一下 [表格] 功能表上的 [拖放表格]。您必須選取資料表出現在功能表上的 [拖放表格] 選項。

[匯出資料表] 和 [匯入資料表] 選項都位於 [表格] 功能表上。匯出資料表 選項會將資料表匯出至可使用如 「 記事本 」 的文字編輯器編輯的文字格式。匯出的資料表有一個.idt 副檔名。您可以匯入 Orca 編輯器的這些 IDT 表格,藉由使用 匯入資料表 的動作。

資料列

可在表格中新增一列按一下 [表格] 功能表上的 [加入資料列]。出現對話方塊以選取資料表的欄位。 以金色金鑰旁邊的欄位是為該資料表主索引鍵。欄位名稱會指出後面跟著欄位型別在編輯方塊上方。如果 「 必要 」 這個字後面欄位型別,這個欄位是必要的而且無法加入資料列直到值,會出現在此欄位中。

要移除資料列、 選取資料表資料列然後按一下 放置列 在 [表格] 功能表上。

若要編輯資料列中的現有欄位,請在 [按兩下] 到您想要編輯的欄位內。

驗證

驗證執行 Orca 編輯器中當您按一下 [驗證] 從 [工具] 功能表。如果您使用的包含在最新的 Windows 安裝程式 SDK Orca 編輯器,就可以執行可用的評估檔案的下拉式清單。

若要驗證檔案,請依照下列步驟執行:
  1. 從下拉式功能表 Orca 編輯器的最新的 Windows 安裝程式 SDK 中,選取 [可用的評估檔案套件]。
    • 選取要驗證與所有可用的驗證程式的 MSI 檔案的 完整 MSI 驗證套件
    • 選取要執行的驗證程式所使用的商標憑證子集的 Windows 2000 標誌程式套件
    • 選取要驗證的 MSM 檔的 合併模組驗證套件
  2. 按一下以清除 顯示 「 資訊 」 訊息 以避免不表示資料庫有問題的資訊性訊息。
  3. 按一下 []。
完成驗證之後,您可以將結果複製到文字編輯器進行檢視。

對話框

如果 Orca 編輯器中開啟的.msi 檔案包含使用者介面的對話方塊,使用 [工具] 功能表上的 [對話方塊預覽] 選項預覽這些對話方塊。您必須使用適當的資料表來編輯對話方塊。

摘要資訊

若要編輯摘要資訊,按一下 [檢視] 功能表上的 [摘要資訊]。

附註[產品編號] 欄位是.msi 檔案不是產品程式碼的封裝程式碼。產品代碼會儲存在 ProductCode 屬性的 「 屬性 」 資料表中。如果您要將.msi 檔案儲存在 Orca 編輯器中,封裝程式碼不會自動變更。您必須手動進行此變更。
参考
有關特定資料表或.msi 檔中的欄位的所有資訊] 都位於 [Windows 安裝程式 [說明] 檔案 (Msi.chm)。說明檔被安裝在 MsiIntel.SDK\Help 目錄中,Windows Installer SDK 安裝時。下列說明檔中的位置是標準的資料表資訊:

安裝程式 Database\Installer 資料庫 Reference\Database 表格。
若要安裝並執行 SDK 更新 ActiveX 控制項:

內容

文章識別碼:255905 - 最後檢閱時間:09/10/2005 00:43:28 - 修訂: 4.0

Microsoft Windows Installer 1.0, Microsoft Windows Installer 1.1, Microsoft Windows Installer 1.2, Microsoft Windows Installer 2.0

  • kbmt kbappsetup kbhowto KB255905 KbMtzh
意見反應