BUG:ADO 2.0 參照無法在安裝有 Visual Studio Service Pack 4 的 Visual Basic 6.0 中儲存

本文曾發行於 CHT276380
本文已封存。本文係以「現狀」提供且不會再更新。
徵狀
在安裝有 Visual Studio Service Pack 4 的 Visual Basic 6.0 中,無法儲存 Microsoft ActiveX Data Objects (ADO) 2.0 Library (msado20.tlb) 的參照。當專案重新開啟時,該參照會自動升級為 Microsoft ActiveX Data Objects (ADO) 2.5 Library (msado15.dll)。
解決方案
英文版的修正程式應該包括下列檔案:
   檔名   ---------   VBA6.DLL   VB6.EXE
狀況說明
Microsoft 已確認本篇文章開頭所列產品確實有上述問題。
其他相關資訊

重現問題的步驟



  1. 在 Visual Basic 中建立新的「標準執行檔」專案。Form1 會依預設建立。
  2. [專案] 功能表上,按一下 [設定引用項目],然後選取 [Microsoft ActiveX Data Objects 2.0 Library]。這會使 msado20.tlb 與專案產生關聯。
  3. 儲存並關閉專案。
  4. 重新開啟專案。
  5. [專案] 功能表,按一下 [設定引用項目],您可以看到現在已選取 [Microsoft ActiveX Data Objects 2.5 Library](msado15.dll) 。
注意:若專案使用或參照 adodc 控制項 (msadodc.ocx) 或資料環境設計器 (msderun.dll),則會自動從 ADO 2.0 升級到 ADO 2.5,因為這兩個元件都會需要 ADO 2.5。
参考
本文件是根據 Microsoft Knowledgebase 文件編號 Q276380 翻譯的. 若要參考原始英文文件內容, 請至以下網址:

內容

文章識別碼:276380 - 最後檢閱時間:02/24/2014 03:20:29 - 修訂: 2.0

  • Microsoft Visual Studio 6.0 Service Pack 4
  • kbnosurvey kbarchive kbado200 kbbug kbpending kbvbp600 kbvs600sp4bug KB276380
意見反應