FIX: Dapi.dll 為 Exchange 5.5 管理工具從 Exchange 2000 光碟片安裝的版本不正確

重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,而非使用人工翻譯而成。Microsoft 同時提供使用者人工翻譯及機器翻譯兩個版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,機器翻譯的文章可能不盡完美。這些文章中也可能出現拼字、語意或文法上的錯誤,就像外國人在使用本國語言時可能發生的錯誤。Microsoft 不為內容的翻譯錯誤或客戶對該內容的使用所產生的任何錯誤或損害負責。Microsoft也同時將不斷地就機器翻譯軟體進行更新。

按一下這裡查看此文章的英文版本:280136
本文已封存。本文係以「現狀」提供且不會再更新。
徵狀
Exchange 2000 CD 會提供選項來安裝 Exchange 5.5 管理工具。如果您選擇此選項時,會安裝的動態連結程式庫 (dll) 的 [目錄應用程式發展介面 (DAPI) 版本 6.0.4417 Exchange 2000 版本。這個版本的 DAPI DLL 不以程式設計方式支援針對 Exchange 5.x 伺服器。如果使用 DAPI 存取 Exchange 5.x 目錄您應該使用運送的 DAPI DLL 與 Exchange 5.x。

如需詳細資訊請參閱下面的 〈 參考 〉 一節]。
解決方案
如果要解決這個問題,取得最新的 Service Pack,Microsoft Exchange 2000 伺服器。如需詳細資訊按一下 [下面的文件編號,檢視 「 Microsoft 知識庫 」 中的發行項]:
301378取得最新的 Exchange 2000 Server Service Pack 的方式 XGEN:
狀況說明
Microsoft 已確認這是在本文開頭所列之 Microsoft 產品中的有錯誤。這個問題,首先已經在 Microsoft Exchange 2000 Server Service Pack 1 中獲得修正。
参考
如需有關如何安裝 DAPI 的詳細資訊,按一下面的文件編號,檢視 「 Microsoft 知識庫 」 中 「 文件:
169551使用 DAPI 所需的資訊: 項目
252886資訊: Exchange 2000 不支援 API 的目錄
DAPI

警告:本文為自動翻譯

內容

文章識別碼:280136 - 最後檢閱時間:10/21/2013 04:03:48 - 修訂: 3.3

Microsoft Exchange 2000 Server Standard Edition, Microsoft Exchange Server 5.0 Standard Edition, Microsoft Exchange Server 5.5 Standard Edition

  • kbnosurvey kbarchive kbmt kbbug kbfix kbmsg KB280136 KbMtzh
意見反應