POP/IMAP 用戶端驗證失敗時,如果 X MS-用戶端-應用程式中的 AD FS 宣告規則設定為 [Microsoft.Exchange.PopImap

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問題
請考慮下列情況:
  • 您的 POP 和 IMAP 用戶端存取驗證使用 Active Directory 聯盟服務 (AD FS)。
  • 您必須阻擋存取,如果宣告規則的值 X MS-用戶端應用 宣告型別不是 Microsoft.Exchange。PopImap.
這些設定之前已在如預期般運作。不過,您注意到最近的 POP 和 IMAP 用戶端無法驗證,即使使用正確的使用者名稱和密碼。

此外,如果您檢查 AD FS 存取記錄檔時,您可能會看到類似下列的項目:
[<Date><Time>]"POST /microsoftonline/ws-username HTTP/1.1"</Time></Date> 403 ..."Microsoft.Exchange。Imap"
[<Date><Time>]"POST /microsoftonline/ws-username HTTP/1.1"<b00> </b00> </Time></Date>403 ..."Microsoft.Exchange。快顯"
原因
已經有所變更最近服務中來分隔 POP 和 IMAP 驗證。而不是Microsoft.Exchange.PopImapX-MS-用戶端-應用程式標頭中傳送的值會是Microsoft.Exchange.ImapMicrosoft.Exchange.Pop
方案
在現有的宣告規則中, X-MS-用戶端-應用程式的值從變成Microsoft.Exchange.PopImapMicrosoft.Exchange.ImapMicrosoft.Exchange.Pop
更多的資訊
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文章識別碼:3107357 - 最後檢閱時間:10/28/2015 22:59:00 - 修訂: 2.0

Microsoft Exchange Online, Office 365 Identity Management

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