當您嘗試刪除 Microsoft Entra ID 中的 B2C 目錄時發生錯誤:無法刪除 '<contoso>'

本文說明當您嘗試刪除 Microsoft Entra ID 中的 B2C 目錄時發生錯誤的問題。

原始產品版本:Microsoft Entra ID
原始 KB 編號: 3112170

徵狀

在 Microsoft Entra 環境中,您會設定 B2C 目錄,然後嘗試刪除它。 不過,您會收到下列錯誤訊息:

無法刪除 '<contoso>'
下列問題 () 防止刪除目錄:
目錄包含一或多個由使用者或系統管理員新增的應用程式

原因

如果現有的 B2C 應用程式服務主體 (例如 CPIM、Ibiza 入口網站和 SSPR) 封鎖刪除,就會發生此問題。

解決方案

若要修正此問題,請使用 Azure 入口網站。

步驟 1:刪除 Azure AD B2C 儀錶板上列出的所有應用程式

如果要執行這項操作,請依照下列步驟執行:

  1. 具有 Azure AD B2C 目錄存取權的系統管理員身分登入 Azure 入口網站。

  2. 選取右上角的顯示名稱,然後選取您 B2C 目錄的目錄。

    注意事項

    如果您只有一個目錄,將會選取您的 Azure AD B2C 目錄。

  3. 若要尋找 Azure AD B2C 刀鋒視窗,請選取左下角的 [更多服務 (>) ] 按鈕,然後搜尋 “B2C”。

  4. 取 [Azure AD B2C]

  5. 選取 [所有設定],然後選取 [ 應用程式]

    應用程式設定的螢幕快照。

  6. 刪除所有應用程式。 若要這樣做,請選取應用程式,選取 [ 屬性],然後選取 [ 刪除] 按鈕。

    顯示如何刪除應用程式的螢幕快照。

步驟 2:刪除 Azure AD B2C 租使用者

如果要執行這項操作,請依照下列步驟執行:

  1. 在 Azure AD B2C 目錄中,找出並選取 Azure 入口網站 中的 [Microsoft Entra ID] 刀鋒視窗。

  2. 在 [ 概觀] 功能表上,選取 [ 刪除目錄]

  3. 請遵循入口網站中的指示。

與我們連絡,以取得說明

如果您有問題或需要相關協助,請建立支援要求,或詢問 Azure community 支援。 您也可以將產品意見反應提交給 Azure 意應見反社群