您目前已離線,請等候您的網際網路重新連線

如何使用 Visual Basic 升級精靈

重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,而非使用人工翻譯而成。Microsoft 同時提供使用者人工翻譯及機器翻譯兩個版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,機器翻譯的文章可能不盡完美。這些文章中也可能出現拼字、語意或文法上的錯誤,就像外國人在使用本國語言時可能發生的錯誤。Microsoft 不為內容的翻譯錯誤或客戶對該內容的使用所產生的任何錯誤或損害負責。Microsoft也同時將不斷地就機器翻譯軟體進行更新。

按一下這裡查看此文章的英文版本:317885
結論
本文將逐步說明如何建立簡單的Visual Basic 6.0 應用程式,然後再升級至 Visual Basic 應用程式.NET 或藉由使用 「 Visual Basic 升級精靈 」,在 Visual Studio 的.net 或 Visual Studio 2005年中的 Visual Basic 2005年。

附註Visual Basic 的.net 升級精靈會包含在視覺Studio.net 專業人員。

附註增強後的 Visual Basic 2005年升級精靈從舊版的 Visual Basic。 back to the top

需求

下列項目將說明建議的硬體的軟體,網路基礎結構、 技能、 知識和 service pack,您將需要:
  • Microsoft Windows 2000 專業版 (或伺服器),或Microsoft Windows XP 商用版 (或伺服器) 與.NET Framework安裝
  • Microsoft Visual Basic 6.0
  • Microsoft SQL Server 7.0 (含) 以後的北風資料庫中,適當的權限和使用者識別碼和密碼的值
所需的背景知識:
  • 如何建立應用程式使用的一般知識Visual Basic 6.0
back to the top

使用 Visual Basic 升級精靈

下列步驟將告訴您如何建立簡單的 Visual Basic6.0 的應用程式中,然後再升級到 Visual Basic 的.net 或 Visual Basic 2005年應用程式,藉由使用Visual Basic 升級精靈在 Visual Studio 的.net 或 Visual Studio 2005年中:
  1. 在 [開始] 功能表上指向 [程式集,指到 [ Microsoft Visual Studio 6.0中,,然後按一下Microsoft Visual Basic 6.0
  2. 在 [新增專案] 對話方塊中,按一下 [標準執行檔,,然後按一下開啟
  3. 此應用程式中的第一個表單會使用 ADO 擷取資料錄集,然後顯示在 Microsoft 的階層式 FlexGrid 中的資料錄集控制項。在 form1 的 [內容] 對話方塊的 [名稱] 欄位中,輸入frmADO.
  4. 如果工具箱尚未開啟,請在 [檢視] 功能表上按一下 [工具箱]。
  5. 從 [工具箱] 中,請將MSHFlexGrid放在表單上,使它填滿大部分表單中。留下足夠的空間若要將按鈕放在表單底部。

    附註: 如果看不到 [工具箱] 中的 [ MSHFlexGrid ] 圖示,請將它加入至工具箱。以滑鼠右鍵按一下在 [工具箱],然後按一下 [元件。在 [元件] 對話方塊中,按一下以從可用的元件清單中選取 [ Microsoft 階層式 FlexGrid 控制項 6.0 (OLEDB) ,然後按一下[確定]
  6. 從 [工具箱] 放置表單下方的 MSHFlexGrid 上的指令按鈕。在 [屬性] 對話方塊的 [標題] 欄位中,輸入 [確定].
  7. MADO,以滑鼠右鍵按一下,然後按一下 [檢視程式碼。加入下列程式碼中,這麼做會建立資料庫連接和傳回資料錄集,其中包含所有來自 Northwind 資料庫的 [產品] 資料表的資料。

    附註: 下列範例程式碼,您必須變更 使用者識別碼 =<username></username> 以及 密碼 =<strong password=""></strong> 若要正確的值。請確定使用者識別碼具有適當的權限,才能執行這項操作,在資料庫上。
    Private Sub Command1_Click()    Unload MeEnd SubPrivate Sub Form_Load()    Dim cn As Connection    Set cn = New Connection    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"    cn.Open        Dim rs As Recordset    Set rs = New Recordset    rs.CursorLocation = adUseClient    rs.Open "select * from products", cn        Set MSHFlexGrid1.DataSource = rsEnd Sub					
  8. 請按 CTRL + S 鍵來儲存表單。在 [檔案] 功能表上按一下 [另新檔]。在 [另新檔] 對話方塊中,按一下 [儲存]。
  9. 在 [專案總管] 中,以滑鼠右鍵按一下 [專案 1,按一下 [新增],然後按一下表單。按一下 [開啟]。
  10. 在 [屬性] 對話方塊的 [名稱] 欄位中,輸入 frmClipboard.
  11. 從 [工具箱] 中,請將文字方塊放在表單上。在 [文字] 欄位中,輸入 褐色狐狸跳透過延遲小狗.
  12. 放入文字方塊底下的[指令按鈕。在 [屬性] 對話方塊的 [標題] 欄位中,輸入 複製.
  13. 將第二個指令按鈕放在表單上。在 [屬性] 對話方塊的 [標題] 欄位中,輸入 貼上.
  14. FrmClipboard,以滑鼠右鍵按一下,然後按一下 [檢視程式碼。貼上下列程式碼的指令按鈕的 click 事件。這個程式碼使用剪貼簿取得物件,並貼上文字:
    Private Sub Command1_Click()    Clipboard.SetText Text1.SelTextEnd SubPrivate Sub Command2_Click()    Text1.SelText = Clipboard.GetTextEnd Sub					
  15. 請按 CTRL + S 鍵來儲存表單。
  16. 您必須在最後一個表單是應用程式的主要表單。在 [專案總管] 中,以滑鼠右鍵按一下 [專案 1、 按一下 [新增],按一下 [表單],然後按一下開啟
  17. 在 [屬性] 對話方塊的 [名稱] 欄位中,輸入 流顯示影像.
  18. 從 [工具箱] 放置流顯示影像的表單上的指令按鈕。在 [屬性] 對話方塊的 [標題] 欄位中,輸入 ADO.
  19. 將第二個指令按鈕放在表單上。在 [屬性] 對話方塊的 [標題] 欄位中,輸入 剪貼簿.
  20. 流顯示影像,以滑鼠右鍵按一下,然後按一下 [檢視程式碼。貼上下列程式碼的指令按鈕按一下事件以顯示兩種形式:
    Private Sub Command1_Click()    frmADO.ShowEnd SubPrivate Sub Command2_Click()    frmClipboard.ShowEnd Sub					
  21. 請按 CTRL + S 鍵來儲存表單。
  22. 在 [方案總管] 中,以滑鼠右鍵按一下 [專案 1,,然後按一下 [專案 1 的內容。在啟始物件] 欄位中,按一下 [流顯示影像,,然後按一下[確定]
  23. 若要新增 ADO 元件的參考,在 [專案] 功能表上,按一下 [參考]。在可用的項目清單中,按一下以選取Microsoft ActiveX 資料物件程式庫(2.0 (含) 以後的版本將待辦事項)。按一下[確定]
  24. 若要編譯此專案,在 [檔案] 功能表上的按一下進行 Project1.exe。在建立專案] 對話方塊中,按一下[確定] (接受預設檔名)。
  25. 請按 F5 執行應用程式在偵錯模式。

    附註: 您不需要確認舊式的 Visual Basic沒有任何問題的事件,是在升級之前執行的應用程式。
  26. 請關閉 Visual Basic 的開發環境。在提示若要將變更儲存至專案,請按一下[是]。使用預設名稱,然後儲存專案。
  27. 在 [開始] 功能表上指向 [程式集,指到 [ Microsoft Visual Studio 的.net,,然後按一下Microsoft Visual Studio 的.net
  28. 在 [啟動] 頁面上,按一下 [開啟專案]。找出 Visual Basic 6.0 專案所在的資料夾您剛建立的 (通常檔必要視覺化的檔案Studio\VB98)。按一下 [ Project1.vdp,,然後按一下 [開啟
  29. Visual Studio 的.net 偵測到這是傳統的視覺基本的專案,它會啟動 「 Visual Basic 升級精靈 」。此精靈會顯示當您每個步驟的描述進行的步驟,請在下列順序:
    • 建立新的專案中現有的專案升級使用中。
    • 將表單檔案和類別檔案複製到新的專案。
    • 提供一份升級報告,列出的元件成功升級的專案,以及未升級的元件成功。

  30. 下一步各步驟直到開始升級程序。[升級會花費大約 30-60 秒鐘才能完成。
  31. 在 [方案總管] 中,按兩下 [ _UpgradeReport.htm]。此報告會顯示升級的結果。請注意,所有一種格式除了 frmClipboard 升級毫無問題。
  32. 展開以檢視議題的frmClipboard.vbClipboard.SetTextGetText並未不正確地升級。按一下各連結,在 [描述],查看如何更正問題。
  33. 在 [方案總管] 中,記下的所有表單保留原來的名稱,但副檔名為.frm 從變更。 vb.
  34. 展開 [參考]。請注意,參考至所有所需的元件若要使用傳統的 Visual Basic 和 ado 兩者元件已加入是自動的。
  35. 以滑鼠右鍵按一下任何一種格式,然後再按一下 [檢視程式碼。展開 [升級支援] 區域。這個區域會顯示 Visual Studio 的.net 或 Visual Studio 2005年的設定方式各種屬性和支援升級的程式碼的變數。
  36. 在 [方案總管] 中, frmClipboard.vb,以滑鼠右鍵按一下,然後按一下 [檢視程式碼。請注意有沒有行之前放置註解無法升級。
  37. Command1_Click 」 和 「 Command2_Click事件變更如下:
    Private Sub Command1_Click(ByVal eventSender As System.Object, _    ByVal eventArgs As System.EventArgs) Handles Command1.Click        Clipboard.SetDataObject(Text1.Text)    End Sub    Private Sub Command2_Click(ByVal eventSender As System.Object, _    ByVal eventArgs As System.EventArgs) Handles Command2.Click        Text1.SelectedText = _            Clipboard.GetDataObject().GetData(GetType(System.String))    End Sub					
back to the top

完整的程式碼清單

完整程式碼清單 (frmADO.frm)

Private Sub Command1_Click()    Unload MeEnd SubPrivate Sub Form_Load()    Dim cn As Connection    Set cn = New Connection    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"    cn.Open        Dim rs As Recordset    Set rs = New Recordset    rs.CursorLocation = adUseClient    rs.Open "select * from products", cn        Set MSHFlexGrid1.DataSource = rsEnd Sub				
back to the top

完整程式碼清單 (frmClipboard.frm)

Private Sub Command1_Click()    Clipboard.SetText Text1.SelTextEnd SubPrivate Sub Command2_Click()    Text1.SelText = Clipboard.GetTextEnd SubComplete Code Listing (frmMain.frm)Private Sub Command1_Click()    frmADO.ShowEnd SubPrivate Sub Command2_Click()    frmClipboard.ShowEnd Sub				
back to the top

請確認應用程式可以運作

  1. 請按 F5 啟動應用程式。
  2. 系統提示儲存專案時,按一下 [確定]。
  3. 在 [Form1],按一下 [ ADO。表單隨即出現,其中包含在框格中的資料。關閉這表單。
  4. 在 [Form1],按一下 [剪貼簿]。
  5. 按一下 [複製]。
  6. 將插入點放在開頭的 [文字] 方塊文字,然後按一下 [。您應該會看到貼上的文字。
back to the top

疑難排解

從前一版的主要驅使力量,Visual Basic 的.net 是Visual Basic。對於多數專案中某些廣泛的一些準備工作,建議您您之前升級。請參閱下列文件中的 [可能的資訊幫助您更容易升級:
back to the top

參考

如需詳細資訊,請參閱下列的 Microsoft 開發人員網路 (MSDN) 文件: back to the top

警告:本文為自動翻譯

內容

文章識別碼:317885 - 最後檢閱時間:07/02/2012 05:33:00 - 修訂: 1.0

Microsoft Visual Basic 2005, Microsoft Visual Basic .NET 2003 Standard Edition, Microsoft Visual Basic .NET 2002 Standard Edition, Microsoft Visual Basic 6.0 Professional Edition, Microsoft .NET Framework 1.1

  • kbvs2005swept kbvs2005applies kbmigration kbhowtomaster kbmt KB317885 KbMtzh
意見反應