您目前已離線,請等候您的網際網路重新連線

在.NET Framework 1.1 版中修正: 「 HTTP 400-要求錯誤 」 錯誤訊息

重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,而非使用人工翻譯而成。Microsoft 同時提供使用者人工翻譯及機器翻譯兩個版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,機器翻譯的文章可能不盡完美。這些文章中也可能出現拼字、語意或文法上的錯誤,就像外國人在使用本國語言時可能發生的錯誤。Microsoft 不為內容的翻譯錯誤或客戶對該內容的使用所產生的任何錯誤或損害負責。Microsoft也同時將不斷地就機器翻譯軟體進行更新。

按一下這裡查看此文章的英文版本:826437
徵狀
當您執行 Microsoft.NET Framework 1.1 版中,然後再瀏覽的 URL,包含第二個冒號 (":"),您會收到下列錯誤訊息:
1.1-HTTP 400-錯誤的要求
針對範例中,將下列 URL 就會產生這個錯誤訊息:
http://伺服器/資料夾/頁面.aspx/http://www.wingtiptoys.com
附註您也可能會收到這個錯誤訊息,如果 URL 包含下列字元:
* % &
解決方案

服務套件資訊

重要這個章節、 方法或工作包含告訴您如何修改登錄的步驟。不過,如果您不當修改登錄,可能會發生嚴重的問題。因此,請確定小心執行這些步驟。為加強保護,請先備份登錄再進行修改。然後,您可以在發生問題時還原登錄。如需有關如何備份和還原登錄的詳細資訊,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文件:
322756 如何備份及還原 Windows 中的登錄


若要瀏覽包含字元的 「 徵狀 」 一節中所提及的 Url,請取得最新的 service pack 的 Microsoft.NET Framework 1.1 版。 如需詳細資訊,按一下下面的文件編號,檢視 Microsoft 知識庫中的文件:
885055如何取得 Microsoft.NET Framework 1.1 Service Pack 1

登錄資訊

重要如果您啟用此修正程式,您就會增加應用程式的攻擊面。除非應用程式需要的話,您不應該啟用此修正程式。

在您安裝 service pack 後,設定下列登錄機碼,以啟用此修正程式:
DWORD HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ASP.NET VerificationCompatibility = 1
狀況說明
Microsoft 已經確認這是 「 適用於 」 一節中所列的 Microsoft 產品中的問題。 在.NET Framework 1.1 Service Pack 1,第一次已修正這個問題。
其他相關資訊
如需有關軟體更新術語的詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
編號 824684用來描述 Microsoft 軟體更新標準術語的說明

警告:本文為自動翻譯

內容

文章識別碼:826437 - 最後檢閱時間:11/29/2012 07:27:00 - 修訂: 9.0

Microsoft ASP.NET 1.1

  • kbqfe kbhotfixserver kbnetframe110sp1fix kbfix kbbug kbmt KB826437 KbMtzh
意見反應