Office 2003 和 Office XP 的移除隱藏資料增益集

Support for Office 2003 has ended

Microsoft ended support for Office 2003 on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

本文已封存。本文係以「現狀」提供且不會再更新。
結論
當您在 Microsoft Office 程式中檢視文件時,「移除隱藏資料」增益集是一種工具,用來移除可能不會馬上顯示的個人或隱藏資料。

您可以從 Microsoft Office XP 程式或 Microsoft Office 2003 程式中,執行個別檔案上的「移除隱藏資料」增益集, 或是您可以從命令列,同時在多個檔案上執行「移除隱藏資料」增益集。 不論在何種情況下,您必須安裝用來建立文件的程式,才能執行該工具。

如需有關「移除隱藏資料」增益集工具,以及如何取得工具的其他相關資訊,請造訪下列 Microsoft 網站: 如需有關未包含 ReadMe 檔案之已知問題和主題的其他資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
834636 Known issues with the Remove Hidden Data add-in for Office 2003 and Office XP
其他相關資訊
下列為「移除隱藏資料」增益集的 ReadMe 檔案。在您安裝「移除隱藏資料」增益集後,此 ReadMe 檔案位於下列資料夾中:
path\Program Files\Microsoft Office\Remove Hidden Data Tool\1033

Microsoft Office 2003 ReadMe 檔案:「移除隱藏資料」增益集

© 2003 Microsoft Corporation. 版權所有。

本文提供了有關「 Microsoft® Office 2003 移除隱藏資料」增益集的最新資訊。<內容>一節列出所有包含在此檔案中的資訊;如需特定個別 Office 系統產品的最新資訊,請參閱該產品的 ReadMe 檔案。

「移除隱藏資料」是 Microsoft Office 2003 Editions 或 Microsoft Office XP 的增益集,讓使用者從 Microsoft Word、Microsoft Excel 和 Microsoft PowerPoint® 檔案中永久移除隱藏和共同作業的資料。

如何使用本文

如果要在畫面上檢視 ReadMe 檔案,請最大化瀏覽器視窗。如果要列印 ReadMe 檔案,請按一下工具列上的 [列印] 按鈕

內容

概觀

當您使用電子郵件分送 Office 文件時,該文件可能包含您不想要公開共用的資訊,像是指定為「隱藏」的資訊,或是允許您和其他使用者共同參與撰寫和編輯文件的資訊。

當您在 Microsoft Office 應用程式中檢視文件時,「移除隱藏資料」增益集是一種工具,用來移除可能不會馬上顯示的個人或隱藏資料。

您可以從 Office XP 或 Office System 2003 應用程式,在個別檔案上執行「移除隱藏資料」增益集。 或是您可以從命令列一次對多個檔案執行「移除隱藏資料」。不論在何種情況下,您必須建立安裝文件的應用程式,才能執行該工具。

注意
  • 當您準備要發佈檔案時,應該在檔案上執行「移除隱藏資料」增益集。這是因為 Office 會將工具移除的某些資料,使用在像是「追蹤修訂」、「註解」和「傳送檢閱」的共同作業功能上。
  • 「移除隱藏資料」增益集的設計目的,是從 Office 檔案中永久移除某些類型的資料。 依預設值,增益集會儲存至新的檔案名稱。
  • 您應該永遠儲存至新的檔案名稱,而不是使用新文件覆寫原始檔案,以便保留包含原始資料的副本。
  • 如果要變更「移除隱藏資料」增益集使用的語言,將有必要下載該語言之「移除隱藏資料」增益集的新副本。 在安裝正確的語言增益集後,您可以透過變更 Microsoft 2003 語系設定工具中的 UI 語言來進行存取。請注意命令列工具並不支援 Office 語系設定。然而,在任何語言中,所有「移除隱藏資料」增益集副本都包含英文版以支援命令列工具。
本工具無法從下列檔案類型中移除隱藏資料:
  • 使用權限管理的文件
  • 受保護的文件
  • 數位簽章的文件
  • 郵件合併/列印合併文件
  • 共用活頁簿
回到內容

系統需求

  • 支援作業系統:Microsoft Windows® XP
  • 此下載可以在下列 Office 應用程式上運作:
    • Microsoft Office Word 2003
    • Microsoft Office Excel 2003
    • Microsoft Office PowerPoint 2003
    • Microsoft Word 2002
    • Microsoft Excel 2002
    • Microsoft PowerPoint 2002
您必須建立安裝文件的應用程式才能執行增益集。同時您擁有的 Office 版本必須和想要執行「移除隱藏資料」增益集工具的文件版本相同或更新。例如,您可以在 Office 2003 中開啟 Office 2000 文件並執行這項工具,但是無法在 Office 2000 中開啟 Office 2003 文件並執行這項工具。

「移除隱藏資料」可以使用在 Word 文件、Excel 試算表、PowerPoint 投影片、網頁、單一檔案網頁,以及 Word、Excel 和 PowerPoint 建立的 XML 文件上。「移除隱藏資料」無法使用在其他文件格式上。

回到內容

此增益集可以移除的資料類型

  • 應用程式的「移除個人」資訊功能會移除所有資料。 如需有關此功能的其他相關資訊,請在應用程式「說明」中搜尋「移除個人資訊」項目。此資料會自動移除。
  • 註解。此資料會自動移除。
  • 之前的作者和編輯者。此資料會自動移除。
  • 使用者名稱。此資料會自動移除。
  • 個人摘要資訊。此資料會自動移除。
  • 頁首和頁尾。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。 依預設值,此資料會保留在原處。
  • 修訂記號。此資料會自動移除。
  • 刪除文字。此資料會自動移除。
  • 隱藏文字。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。依預設值,會移除此資料。
  • 隱藏資料列/資料欄。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。 依預設值,會移除此資料。
  • 樞紐分析表。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。 依預設值,某些資料會從樞紐分析表中移除。
  • 超連結。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。 依預設值,此資料會保留在原處。
  • 版本。此資料會自動移除。
  • 功能變數代碼。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。 依預設值,會解析功能變數代碼並保留在原處。
  • 範本名稱。此資料會自動移除。
  • VB 模組。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。 依預設值,此資料會保留在原處。
  • 檔案路徑。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。 依預設值,此資料會保留在原處。
  • 內嵌物件。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。依預設值,會移除 Office 文件中的內嵌物件,同時其他內嵌物件會保留在原處。

    注意 針對移除的那些內嵌物件,視覺上代表內嵌物件的圖片會保留在文件中,但是所有其他相關資料都會移除。
  • 隱藏工作表。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。依預設值,會移除此資料。
  • 自訂檢視。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。 依預設值,此資料會保留在原處。
  • SmartTags。這些資料會關閉,但是適當的文字會保留在原處。
  • 外部資料來源的連結。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。 依預設值,會移除此資料。
  • 自訂內容。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。依預設值,會移除此資料。
  • 為了將變更合併至原始文件,而用來識別文件的識別碼編號。此資料會自動移除。
  • 印表機路徑 (除了在「已知」中提到的問題之外)。此資料會自動移除。
  • 傳閱名單。此資料會自動移除。
  • 電子郵件標題。此資料會自動移除。
  • 情況註解。此資料會自動移除。
  • PowerPoint 投影片備忘稿。除非在命令列模式中,否則當找到此資料時,電腦將出現提示。 依預設值,會移除此資料。
  • PowerPoint off-slide 內容。依預設值,此資料會保留在原處。
  • 唯一識別碼 (僅適用 Office 97 文件)。此資料會自動移除。
回到內容

已知問題

  • Excel:在 Excel 2002 中,不會移除印表機路徑;但是在 Excel 2003 中會移除印表機路徑。
  • Excel:支援外部活頁簿的連結,可能不會從 Excel 單一檔案網頁清除。
  • Excel:在包含清單以及一個或更多自訂檢視的 Excel 活頁簿中,自訂檢視將不會移除。
  • Word 和 Excel: 如果多重物件交互分層於其他物件之上,使用者可能無法看見隱藏在上層物件之下的所有物件。
  • PowerPoint:在所有情況下都不會移除相同色彩的文字。
  • 如果檔案之前包含 VBA 巨集,則工具無法移除某些 VBA 巨集的追蹤。
  • 如果「移除隱藏資料」增益集意外關閉,記錄檔案可能會遺留在暫存目錄中。 如果要移除記錄檔案,請刪除本機設定資料夾中的暫存目錄內容。
  • 如果您在完成檢閱文件之前,關閉「移除隱藏資料」增益集,可能會遺留一個或更多的暫存檔案在目的目錄裡。 如果要移除這些檔案,請從目的目錄中刪除。
  • 此工具檢閱過的單一檔案網頁可能會在表單檔案:///c:/<number>/ 中包含隨機產生的暫時檔案名稱。 此名稱中使用的編號是根據單一檔案網頁的檔案名稱,並且無法反向追蹤至您的電腦。
  • PowerPoint:與其他支援 SmartTags 的 Office 程式不同。SmartTags 不會關閉,並且適當的文字會保留在原處。
回到內容

基本用法

在您安裝「移除隱藏資料」增益集後,請開啟您想要檢閱的文件,然後在 [檔案] 功能表上,按一下 [移除隱藏資料]

注意如果您看不到 [檔案] 功能表上的 [移除隱藏資料] 命令,請檢查下列項目:
  1. [工具] 功能表上,按一下 [選項],然後按下 [安全性] 索引標籤。
  2. [巨集安全性] 中,按一下 [巨集安全性]
  3. 按一下 [受信任的發佈者] 索引標籤。
  4. 選取 [信任所有安裝的增益集和範本] 核取方塊,然後按兩次 [確定]
一連串的對話步驟會導引您完成從文件移除隱藏資料的程序。 您可以選擇在文件移除隱藏資訊前,先出現評估的提示,或是可以選擇在不提示的情況下,自動執行工具。 如需詳細的資訊,請參閱此增益集可以移除的資料類型。

注意
  • 您應該永遠儲存至新的檔案名稱,而不是使用新文件覆寫原始檔案,以便保留包含原始資料的副本。
  • 「移除隱藏資料」增益集不支援將文件儲存為範本。
在指定檔名後,增益集將會開始檢閱文件。 如果您選取出現提示的選項,當增益集找到隱藏資料時,將會詢問您是否要保留或移除該資料。

回到內容

命令列

如果要從命令列執行「移除隱藏資料」增益集,請執行下列步驟:
  1. 在執行命令列工具之前,結束所有的 Excel、Word、Outlook 和 PowerPoint 的例項。
  2. [開始] 功能表上,按一下 [執行]
  3. 輸入 cmd,然後按下 ENTER。
  4. 切換至包含 OFFRHD.EXE 檔案的目錄。 依預設值,該目錄為安裝「移除隱藏資料」增益集的目錄。
  5. 在命令提示字元輸入想要執行的工作語法。
注意
  • 雖然看不到您的文件應用程式,但是應用程式是在背景執行。 如果應用程式執行對話方塊,「移除隱藏資料」增益集會暫停直到對話方塊關閉為止。如果對話方塊維持開啟超過 120 秒,應用程式會終止,而且「移除隱藏資料」增益集將繼續處理下一個檔案;或是如果已到達最後一個檔案,增益集便會關閉。
  • 您可以在參數之前輸入斜線 (/) 或虛線 (-) 當做標幟。標幟沒有區分大小寫。
  • 如果您輸入多個標幟,只會辨識第一個標幟。
  • 您必須先輸入 /source 參數,之後可以選擇性的增加 /destination 參數。其他所有參數順序可以任意排列。
OFFRHD.EXE 的語法如下所示:
OFFRHD [/?] source [destination] [/O] [/N:A] [/R] [/F:filetype] [/L: logfile] [/A] [/M]
Parameter說明
來源必要選項。指定您想要移除個人資訊的磁碟、目錄和檔案。可以是任何有效的完整路徑名稱。
目的地選用選項。指定欲掃瞄檔案的位置。如果您不指定此欄位,所有檔案會儲存在相同的目錄中,並使用尾碼來代表目前的日期。 例如,-C010503 代表 2003 年 1 月 5 日。如果目標檔案已存在,檔案將會被覆寫。
/O指定不顯示確定您想要覆寫現存檔案的提示。
/N:A指定不論預設值為何,該工具將移除所有潛在的隱藏資料。警告: 使用 /N:A 功能可能會造成文件中某些內容遺失。
/R指定將檢查來源目錄以及子目錄的內容。
/F:filetype指定目標檔案的格式。
/F:H指定 HTML。
/F:M指定 MHTML。
/F:B指定二進位文件格式。如果您不指定此參數,預設值將儲存與來源檔案相同的格式。
/L:logfile指定儲存記錄檔案的位置。如果您不指定此參數,當工具完成時會顯示記錄。
/A指定工具產生在檔案中找到的問題報表,但是不移除任何資料。
/M文件中所有巨集的指定會被移除。
/?顯示所有可用的參數清單。
回到內容

記錄檔

當「移除隱藏資料」增益集完成檢閱檔案時,記錄檔案會顯示檢閱程序的結果。 如果您想要稍後參考此檔案,可以將這個檔案儲存。
回到內容
內容

文章識別碼:834427 - 最後檢閱時間:12/08/2015 05:53:38 - 修訂: 1.1

Microsoft Office Excel 2003, Microsoft Office PowerPoint 2003, Microsoft Office Word 2003, Microsoft Excel 2002 Standard Edition, Microsoft PowerPoint 2002 Standard Edition, Microsoft Word 2002 Standard Edition

  • kbnosurvey kbarchive kbinfo KB834427
意見反應