您目前已離線,請等候您的網際網路重新連線

不支援您的瀏覽器

您必須更新瀏覽器,才能使用此網站。

更新至最新版本的 Internet Explorer

如何使用 Access 2003 或 Access 2007 中的資料庫中的通用對話方塊 API

Office 2003 支援已結束

Microsoft 於 2014 年 4 月 8 日結束對 Office 2003 的支援。此變更已影響您的軟體更新和安全性選項。 瞭解這對您的意義為何且如何持續受保護。

重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,而非使用人工翻譯而成。Microsoft 同時提供使用者人工翻譯及機器翻譯兩個版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,機器翻譯的文章可能不盡完美。這些文章中也可能出現拼字、語意或文法上的錯誤,就像外國人在使用本國語言時可能發生的錯誤。Microsoft 不為內容的翻譯錯誤或客戶對該內容的使用所產生的任何錯誤或損害負責。Microsoft也同時將不斷地就機器翻譯軟體進行更新。

按一下這裡查看此文章的英文版本:888695
簡介
本文將告訴您,如何使用 Microsoft Office Access 2003 中或在 Microsoft Office Access 2007 中的通用對話方塊 API 來取代包含只在 Microsoft Office 2000 開發 o 人 h 員 û 工 u 具 ã 版或 Microsoft Office XP 開發 o 人 h 員 û 工 u 具 ã 版的通用對話方塊功能。
其他相關資訊
Microsoft 僅,為了說明提供程式設計範例,不提供任何明示或默示的保證。這包括,但不限於適售性或適合某特定用途之默示擔保責任。本文假設您已熟悉使用我們所示範的程式設計語言以及建立和偵錯程序所使用的工具。Microsoft 技術支援工程師可以協助解釋特定程序的功能,但它們不會修改這些範例以提供附加功能或建構程序,以符合您特定需求。

若要取代通用型對話方塊功能的步驟

Microsoft Office Access 2003

  1. 在 Access 中,開啟樣本資料庫,名為 Northwind.mdb。

    附註Access 2003 Northwind.mdb 資料庫通常位於 C:\Program Files\Microsoft Office\OFFICE11\Samples 資料夾。
  2. 按一下 [北風資料庫] 視窗中 [物件,] 下的 [表單]。
  3. 資料庫視窗] 工具列按一下 [新增]。
  4. 在 [新增表單] 對話方塊按一下 [設計檢視],然後按一下 [[確定]
  5. Form1 中新增文字方塊,在文字] 方塊上按一下滑鼠右鍵,然後再按一下 [內容]
  6. 按一下 [全部] 索引標籤]、 按一下 [名稱]]、 輸入 文字 1,] 然後關閉 [內容] 對話方塊。
  7. [文字 1] 文字方塊中相關聯的標籤控制項上按一下滑鼠右鍵,並按一下 [內容],然後按一下 [全部] 索引標籤。
  8. 按一下 [標號]、 輸入 文字 1,然後關閉 [內容] 對話方塊。
  9. Form1 新增指令按鈕、 指令按鈕按一下滑鼠右鍵、 按一下 [內容]、 按一下 [名稱]、 輸入 Command1、 按一下 [標題,然後再輸入 Command1
  10. 按一下 [事件] 索引標籤、 按一下 [On Click] 清單中的 [[事件程序],然後按一下 [省略] 按鈕以啟動 Microsoft Visual Basic 編輯程式 」。
  11. 修改中 Command1_Click 程序,以下列程式碼:
    Private Sub Command1_Click()    Me!Text1 = LaunchCD(Me)End Sub
  12. On the Insert menu, click Module, and then insert the following code into Module1:
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _"GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As LongPrivate Type OPENFILENAME    lStructSize As Long    hwndOwner As Long    hInstance As Long    lpstrFilter As String    lpstrCustomFilter As String    nMaxCustFilter As Long    nFilterIndex As Long    lpstrFile As String    nMaxFile As Long    lpstrFileTitle As String    nMaxFileTitle As Long    lpstrInitialDir As String    lpstrTitle As String    flags As Long    nFileOffset As Integer    nFileExtension As Integer    lpstrDefExt As String    lCustData As Long    lpfnHook As Long    lpTemplateName As StringEnd TypeFunction LaunchCD(strform As Form) As String    Dim OpenFile As OPENFILENAME    Dim lReturn As Long    Dim sFilter As String    OpenFile.lStructSize = Len(OpenFile)    OpenFile.hwndOwner = strform.hwnd    sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _      "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)    OpenFile.lpstrFilter = sFilter    OpenFile.nFilterIndex = 1    OpenFile.lpstrFile = String(257, 0)    OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1    OpenFile.lpstrFileTitle = OpenFile.lpstrFile    OpenFile.nMaxFileTitle = OpenFile.nMaxFile    OpenFile.lpstrInitialDir = "C:\"    OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"    OpenFile.flags = 0    lReturn = GetOpenFileName(OpenFile)        If lReturn = 0 Then            MsgBox "A file was not selected!", vbInformation, _               "Select a file using the Common Dialog DLL"         Else            LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1))          End IfEnd Function
  13. 在 [偵錯] 功能表上按一下 編譯北風,然後關閉 [Visual Basic 編輯器]。
  14. 在 [檢視] 功能表上按一下 表單檢視
  15. 按一下 Command1,然後再按一下 [開啟的視窗中的檔案。

    檔案的路徑會出現在 [文字 1] 文字方塊中。

Microsoft Office Access 2007

  1. 在 Access 2007 開啟樣本資料庫,名為 Northwind.accdb。
  2. 在 [建立] 索引標籤上按一下 [表單] 群組中的 [表單]。
  3. 在 [格式] 索引標籤上按一下 檢視,下方的向下箭號,然後按一下 [設計檢視]
  4. Form1 中新增文字方塊,在文字] 方塊上按一下滑鼠右鍵,然後再按一下 [內容]
  5. 按一下 [全部] 索引標籤、 按一下 [名稱],然後鍵入 文字 1]。
  6. [文字 1] 文字方塊中相關聯的標籤控制項上按一下滑鼠右鍵,並按一下 [內容],然後按一下 [全部] 索引標籤。
  7. 按一下 [標題,] 然後輸入 [文字 1]
  8. Form1 新增指令按鈕、 指令按鈕按一下滑鼠右鍵、 按一下 [內容]、 按一下 [名稱]、 輸入 Command1、 按一下 [標題,然後再輸入 Command1
  9. 按一下 [事件] 索引標籤、 按一下 [On Click] 清單中的 [[事件程序],然後按一下省略符號按鈕 (...) 來啟動 Microsoft Visual Basic 編輯程式 」。
  10. 修改程式碼,類似 Command1_Click 程序中的
    Private Sub Command1_Click()    Me!Text1 = LaunchCD(Me)End Sub
    下列程式碼範例。
  11. On the Insert menu, click Module, and then insert code that resembles the following code example into Module1.
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _"GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As LongPrivate Type OPENFILENAME    lStructSize As Long    hwndOwner As Long    hInstance As Long    lpstrFilter As String    lpstrCustomFilter As String    nMaxCustFilter As Long    nFilterIndex As Long    lpstrFile As String    nMaxFile As Long    lpstrFileTitle As String    nMaxFileTitle As Long    lpstrInitialDir As String    lpstrTitle As String    flags As Long    nFileOffset As Integer    nFileExtension As Integer    lpstrDefExt As String    lCustData As Long    lpfnHook As Long    lpTemplateName As StringEnd TypeFunction LaunchCD(strform As Form) As String    Dim OpenFile As OPENFILENAME    Dim lReturn As Long    Dim sFilter As String    OpenFile.lStructSize = Len(OpenFile)    OpenFile.hwndOwner = strform.hwnd    sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _      "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)    OpenFile.lpstrFilter = sFilter    OpenFile.nFilterIndex = 1    OpenFile.lpstrFile = String(257, 0)    OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1    OpenFile.lpstrFileTitle = OpenFile.lpstrFile    OpenFile.nMaxFileTitle = OpenFile.nMaxFile    OpenFile.lpstrInitialDir = "C:\"    OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"    OpenFile.flags = 0    lReturn = GetOpenFileName(OpenFile)        If lReturn = 0 Then            MsgBox "A file was not selected!", vbInformation, _               "Select a file using the Common Dialog DLL"         Else            LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1))          End IfEnd Function
  12. 在 [偵錯] 功能表上按一下 編譯北風,然後關閉 [Visual Basic 編輯器]。
  13. 在 [格式] 索引標籤上按一下 檢視,下方的向下箭號,然後按一下 [表單檢視]。
  14. 按一下 Command1,然後再按一下 [開啟的視窗中的檔案。

    檔案的路徑會出現在 [文字 1] 方塊中。
acc2003 acc2007

警告:本文為自動翻譯

內容

文章識別碼:888695 - 最後檢閱時間:06/04/2007 19:34:07 - 修訂: 4.3

  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • kbmt kbsampledatabase kbprogramming kbautomation kbexpertiseinter kbhowto KB888695 KbMtzh
意見反應
t type="text/javascript" src="https://c.microsoft.com/ms.js">