您目前已離線,請等候您的網際網路重新連線

當 SQL Server 2005 叢集節點有不同的安裝功能時,叢集升級至 SQL Server 2008 會失敗

徵狀
請試想下列案例:
  • 您在叢集環境中安裝 Microsoft SQL Server 2005 的叢集執行個體。
  • 您在叢集的一個節點上,加上 SQL Server 2005 的功能。例如您在節點上加入 Reporting Services 或 Analysis Services。
  • 您沒有在裝載執行個體的所有叢集節點上加入功能。
在這種情況下,當您嘗試將 SQL Server 2005 的叢集執行個體升級至 SQL Server 2008 時,會收到下列錯誤訊息:
SQL Server 執行個體 'InstanceName' (已經在機器 'ComputerName' 上升級) 具有的執行個體 ID 'InstanceID' 不同於指定的執行個體 ID 'InstanceID'. 不支援在叢集 SQL Server 執行個體的節點指定一個以上的執行個體 ID。請提供與升級節點相同的執行個體 ID,以修正這個問題。
發生的原因
安裝程式嘗試確定所有節點上的功能具有相同的執行個體 ID。不過,安裝程式將安裝功能的執行個體 ID 跨節點解譯為不同於遺失功能的執行個體 ID。
其他可行方案
如果要解決這個問題,請移除安裝在叢集環境中不相符的 SQL Server 2005 功能。然後,再次執行安裝程式,將 SQL Server 2005 的叢集執行個體升級至 SQL Server 2008。
狀況說明
Microsoft 已確認<適用於>一節所列之 Microsoft 產品確實有上述問題。
內容

文章識別碼:955949 - 最後檢閱時間:08/06/2008 06:22:26 - 修訂: 1.1

Microsoft SQL Server 2008 Standard, Microsoft SQL Server 2008 Developer, Microsoft SQL Server 2008 Enterprise

  • kbtshoot kbexpertiseadvanced kbprb KB955949
意見反應
/ms.js">